Legal Information

Microsoft Platform
Software Development Kit

This is a preliminary document and may be changed substantially prior to final commercial release. This document is provided for informational purposes only and Microsoft makes no warranties, either express or implied, in this document. Information in this document is subject to change without notice. The entire risk of the use or the results of the use of this document remains with the user. The names of companies, products, people, characters, and/or data mentioned herein are fictitious and are in no way intended to represent any real individual, company, product, or event, unless otherwise noted. Complying with all applicable copyright laws is the responsibility of the user. No part of this document may be reproduced or transmitted in any form or by any means, electronic or mechanical, for any purpose, without the express written permission of Microsoft Corporation.

Portions of this document specify and accompany software that is still in development. Some of the information in this documentation may be inaccurate or may not be an accurate representation of the functionality of final documentation or software. Microsoft assumes no responsibility for any damages that might occur directly or indirectly from these inaccuracies.

Microsoft may have patents, patent applications, trademarks, copyrights, or other intellectual property rights covering subject matter in this document. Except as expressly provided in any written license agreement from Microsoft, the furnishing of this document does not give you any license to these patents, trademarks, copyrights, or other intellectual property.

© 1985-1998 Microsoft Corporation. All rights reserved.

ActiveMovie, ActiveX, BackOffice, Developer Studio, Direct3D, Direct Animation, DirectDraw, DirectInput, DirectMusic, DirectPlay, DirectShow, DirectSound, DirectX, JScript, Microsoft, Microsoft Press, MS, MSDN, MS-DOS, Natural, NetShow, Sidewalk, SQL Server, Visual Basic, Visual C++, Visual J++, WebTV, Win32, Win32s, Windows, and Windows NT are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries. OS/2 is a registered trademark licensed to Microsoft Corporation.

International CorrectSpell is a trademark of INSO Corporation.

Macintosh, Power Macintosh and QuickTime are registered trademarks and the Mac OS Logo and the QuickTime Logo are trademarks of Apple Computer, Inc. used under license.

Other product and company names mentioned herein may be the trademarks of their respective owners.


Platform SDK Release Notes

The April 1998 release of the Microsoft® Platform Software Development Kit (SDK) documentation describes the application programming interfaces (API) you need to write Win32®-based applications. The Platform SDK contains a variety of components. These components are integrated into functional groups within the SDK, making them easier to find.

The Platform SDK documentation contains APIs that depend on the version of the operating system or other components that are installed. After you have determined that a system has installed support for a particular API, you can use its functionality. When you build your application, use the new header files and import libraries from the Platform SDK.

The following topics describe the new features introduced in each release of the Platform SDK.

  • Release Notes for Windows NT 5.0 Beta 1
  • Release Notes for Windows NT 4.0 Service Pack 3

Later versions of this SDK documentation will be made available on http://www.microsoft.com/msdn/sdk.


Release Notes for Windows NT 5.0 Beta 1

The beta of Microsoft® Windows NT® version 5.0 provides corrections for problems reported with earlier versions of Windows NT and introduces new features. The following table describes the new features documented in the Platform SDK for Windows NT 5.0 beta 1.

Feature | Description
Asynchronous Remote Procedure Calls (RPC) | Asynchronous RPC allows your programs to handle multiple outstanding calls from a single-threaded client and prevent data transmission bottlenecks that can arise from slow or delayed clients or servers. With asynchronous pipe parameters, Client/Server applications can transfer large amounts of data incrementally, without blocking the client or server threads from performing other tasks.
Certificate Server | Certificate Server provides customizable services for issuing and managing certificates used in software security systems employing public-key cryptography. Certificate Server performs a central role in the management of software security systems to enable secure communications across the Internet, corporate Intranets, and other networks that are not secured.
Class store | The class store enables central deployment and management of applications, components, and services across multiple computers.
Collaboration Data Objects (CDO) for Windows NT Server | The Collaboration Data Objects for NTS Library exposes objects that allow a server application written in Microsoft Visual Basic®, C/C++, or Java to send and receive e-mail messages.
COM error handling | Almost all COM functions and interface methods return a value of the type HRESULT. For more information, see COM Error Handling.
Common controls: extended combo box, date and time picker, IP address, month calendar, and rebar ComboBoxEx controls are an extension of the combo box control that provides native support for item images.

Date and Time Picker controls exchange date and time information with a user.

IP Address controls allow the user to provide an IP address in an easily understood format.

Month Calendar controls provide a calendar-like user interface.

Pager controls allow the user to scroll to the area of a window that is not currently in view.

Rebar controls act as containers for child windows.

Common control technologies: custom draw and flat scroll bars Custom Draw is a service provided by many common controls to allow an application greater flexibility in customizing a control's appearance.

Flat Scroll Bars behave like normal scroll bars, but are not displayed three-dimensionally.

Disk quotas | Disk quotas enable administrators to control the amount of data that each user can store on an NTFS volume.
Encrypted File System (EFS) | The encrypted file system supports encrypting and decrypting files or directories on NTFS volumes, and backing up and restoring encrypted files or directories.
Generic Quality of Service (GQOS) | The generic quality of service interface uses QOS-enabled Windows Sockets 2 functions to establish network resource reservations and set traffic shaping policies for transmitting data. Applications designed to use the GQOS interface can invoke QOS transparently from any service provider. Both multicast and unicast sessions are supported by GQOS.
HTTP protocol sequence | The ncacn_http protocol allows client and server applications to communicate across the internet by using the Microsoft Internet Information Server (IIS) as a proxy. Because calls are tunneled through an established HTTP port, they can cross firewalls.
Index Server 3.0 | Index Server 3.0 indexes the contents of all drives on the computer where it is installed, allowing the user to search for any word or phrase on those drives. After beta 1, Index Server will be able to index any virtual servers created by the local Internet Information Server.
Lightweight client-side COM handlers | Lightweight client-side COM handlers are a new kind of COM handler. For more information, see Lightweight Client-side Handlers. For information about COM Handlers in general, see COM Handlers.
Link tracking | Link-tracking enables client applications to track link sources that have been moved. As a result, clients that subscribe to the link-tracking service can maintain the integrity of their references, and the objects referenced can be moved transparently. The link-tracking service in Windows NT 5.0 tracks link sources for shell shortcuts and OLE links within NTFS version 5.0 volumes.
Windows installer | Microsoft's new installation and component management technology supports just-in-time installation. As the user works, the required features and components are installed on the local hard drive only when needed.
Microsoft Management Console (MMC) | The Microsoft Management Console is an extensible user interface that provides an environment for running systems management applications, which are structured as components called snap-ins.
Multiple display monitors | A single interactive window station can support multiple display monitors.
Native Structured Storage (NSS) Native Structured Storage (NSS) is a new implementation of structured storage. It is supported through the new StgCreateStorageEx and StgOpenStorageEx functions.

Structured Storage now provides a consolidation feature, a simple mode, and a multiple-reader, single-writer, direct mode. For more information, see the STGC enumeration, the STGM enumeration, and the StgOpenStorage function.

RAS and Routing Service | The Routing and Remote Access Service enables you to administer routers and RAS servers, and to develop your own routing protocols for Windows NT routers.
Reparse points | A reparse point is a mechanism for associating additional data with a file or directory on an NTFS volume. The reparse data can affect how the NTFS file system traverses a path.
RPC name service | The RPC Name Service (Locator) uses the Active Directory as its database. This means that exported entries can be made persistent even when a server is rebooted. For more information, see RpcNsBindingExport, RpcNsBindingImportNext, RpcNsBindingLookupBegin, and RpcNsBindingUnexport.
Smart Card | The Smart Card Subsystem integrates smart cards with Microsoft Windows® platforms. It provides a standard model for interfacing smart card readers and cards with PCs, a device-independent interface for enabling smart-card-aware applications, and familiar tools for software development.
Sparse files | Sparse files on NTFS volumes contain unallocated ranges of bytes that are assumed to contain zeroes.
TAPI 3.0 | Telephony Application Programming Interface (TAPI) 3.0 is based on the Component Object Model (COM) and uses Microsoft® DirectShow™ filters to provide access to the media.
Transaction Server | Microsoft® Transaction Server (MTS) is a component-based transaction processing system for developing, deploying, and managing high-performance, scalable, and robust enterprise, Internet, and Intranet server applications.
Zero Administration for Windows | The Zero Administration for Windows initiative is a collection of guidelines and technologies that give developers the tools to make their applications easy to manage in a large enterprise environment. This both gives the applications a significant competitive advantage in the enterprise marketplace and helps reduce the Total Cost of Ownership (TCO) of Microsoft Windows workstations.

The following table describes new features in existing areas.

Existing Area | Feature
Access Control | New access control functions enable you to control access to directory service objects and their properties. You can also control access to objects on systems other than Windows NT.
Microsoft® ActiveX™ controls | The ActiveX Controls have been enhanced to take advantage of the functionality of Internet Explorer 4.0.
Base services Support for job objects, which are groups of processes that can be managed as a unit.

Extensions to the Service Control Manager (see QueryServiceConfig2 and ChangeServiceConfig).

Extensions to the file system functions to support hard links (see CreateHardLink).

Support for converting a short path to a long path (see GetLongPathName).
COM security | Delegation-level impersonation, mutual authentication, per-AppID authentication are now supported. In addition, the documentation on COM security is greatly expanded. For more information, see Security in COM.
COM tutorial | The COM Tutorial Sample series is directed to serve advanced programmers who are using their proficiency in C++ programming to develop or modify systems-level software using COM (Component Object Model) technology. These advanced samples show how to program components at the foundation level of COM. Neither MFC nor ATL is used in the samples. The topics range from basic COM object construction to Distributed COM.
Common controls For information about updated common controls, see the following topics:
  • Header Control Updates in Internet Explorer
  • Image List Updates in Internet Explorer
  • List View Updates in Internet Explorer
  • Progress Bar Control Updates in Internet Explorer
  • Status Bar Updates in Internet Explorer
  • Tab Control Updates in Internet Explorer
  • Toolbar Control Updates in Internet Explorer
  • Tooltip Control Update in Internet Explorer
  • Trackbar Control Updates in Internet Explorer
  • Tree View Control Updates in Internet Explorer
  • Up-Down Control Updates in Internet Explorer
Cryptographic API | Version 2.0 of the Cryptographic API (CryptoAPI) provides services that enable application developers to add authentication, encoding, and encryption to their applications. In addition, the section Microsoft Cryptographic Service Providers contains information about implementations of cryptographic algorithms and standards.
Microsoft® DirectX® | DirectX 5 provides updated Microsoft® DirectDraw® and Microsoft® DirectInput®, and multiple monitor support. For more information, see New for Windows 98 and Windows NT 5.0..
GDI services Alpha blending to display bitmaps that have transparent or semitransparent pixels.

Smooth shading to shade a region with a color gradient.

Support for setting and retrieving the color of the pen or brush selected into a device context.

New bitmap information header, BITMAPV5HEADER.

Internet Information Server | Internet Information Server (IIS), is now installed and runs as a native Windows NT service.
National language, font, and Unicode support | Additional functions for IME, to get code page information ( GetCPInfoEx), and to get the Unicode characters supported by a font ( GetFontUnicodeRanges).
Networking services | Support for locating domain controllers, servers, and workstations in a directory service. For more information, see Directory Service (Ds) Functions.
Power management | To save power and ensure that no data is lost when a computer or device is turned off or placed in a low power state, Windows provides power management support. Windows NT 5.0 supports OnNow Power Management.
Printing and Print Spooler | Support for publishing printer configuration data in the Windows NT directory service, and extended functions to provide greater flexibility in adding or upgrading printer drivers. For more information, see AddPrinterDriverEx, DeletePrinterDataEx, DeletePrinterDriverEx, DeletePrinterKey, EnumPrinterDataEx, EnumPrinterKey, GetPrinterDataEx, and SetPrinterDataEx.
Proxy Server | Proxy Server 2.0 tightly integrates with the Windows NT Server platform and Internet Information Server to deliver high-performance Internet access.
RPC/MIDL | MIDL now supports DBCS, TLB file generation has been significantly improved, and all type library attributes are supported. See Type Library Attributes for more information.
SNMP The Microsoft SNMP service for Windows NT 5.0 adds support for new SNMP extension agent and utility functions. For additional information, see New SNMP Programming Elements.

Support for the Windows SNMP Manager Application Programming Interface (the WinSNMP Manager API), version 1.1a, is available for SNMP-based network management applications that execute in the Windows NT operating environment, version 4.0 and later.

User interface services Special effects when showing or hiding windows.

Support for clipboard sequence numbers.

Improvements to support for flashing windows (see FlashWindowEx).

Retrieving the history of mouse and pen coordinates (see GetMouseMovePoints).

Support for locking the workstation programmatically (see LockWorkStation).

Support for the new HSHELL_ACCESSIBILITYSTATE hook code (see ShellProc).

Windows Sockets | Windows Sockets Version 2 programming functions and data structures provide developers of any Microsoft Windows application with access to standard network services, including transport protocols, drivers, and network media.


Release Notes for Windows NT 4.0 Service Pack 3

Microsoft® Windows NT® version 4.0 Service Pack 3 provides corrections for problems reported against earlier versions of Windows NT and introduces new features. The following table describes the new features documented in the Platform SDK for Windows NT 4.0 Service Pack 3.

Element | Description
CryptoAPI 2.0 | Contains the cryptographic functions of CryptoAPI 1.0, plus the functionality to manage and use certificates in secure communications, and to encode and decode PKCS#7 messages.
Disk-Space List (Setup API) | The disk-space list enables you to calculate the disk space required to complete the installation operations.
IGlobalInterfaceTable | A COM interface that allows one apartment to access an interface implemented on an object in any other apartment in the process.
InitializeCriticalSectionAndSpinCount,
SetCriticalSectionSpinCount 		Functions that set the spin count for a critical section.
SendInput | A function that enables you to synthesize keystrokes, mouse movement, and button clicks.
Strings (Setup API) | The Strings section simplifies translation of strings for international markets by placing all strings that can be displayed at the user interface in a single section of the INF file.
WH_KEYBOARD_LL | A hook that enables you to monitor keyboard input events about to be posted in a thread input queue.
WH_MOUSE_LL | A hook that enables you to monitor mouse input events about to be posted in a thread input queue.


About the Platform SDK

The following topics explain various conventions used throughout the Platform SDK documentation.

  • Preliminary Information
  • Quick Reference Information (QuickInfo)
  • Implementation Differences
  • Where to Find the Win32 Functions
  • Document Conventions


Preliminary Information

Some topics in the Platform SDK documentation begin with the following text:

[This is preliminary documentation and subject to change.]

This text is used in the documentation for components that have been released as beta versions. This text is also used to indicate new features in existing components.


Quick Reference Information (QuickInfo)

Many topics that introduce the syntax of an API element contain quick reference information. The format is as follows:

QuickInfo

Windows NT: Requires version 3.1 or later.
Windows: Requires Windows 95 or later.
Windows CE: Requires version 1.0 or later.
Header: Declared in winuser.h.
Import Library: Use user32.lib.
Unicode: Implemented as Unicode and ANSI versions on Windows NT.

The first line indicates the versions of Windows NT on which an element is supported. This information may include required service packs, option packs, or components such as Internet Explorer. If an element is not supported, the line reads "Windows NT: Unsupported."

The second line indicates whether an element is supported on Windows 95 or Windows 98. This information may include required OEM service releases, redistributables, or components such as Internet Explorer. If an element is not supported, the line reads "Windows: Unsupported."

The third line indicates the versions of Windows CE on which an element is supported. If an element is not supported, the line reads "Windows CE: Unsupported."

The fourth line indicates the file that defines an element. This value can be an .h file, .idl file, or .odl file. If the header file is supplied by the user, the line reads "Header: User-defined."

The fifth line indicates the file used to resolve calls to a function or member. This value can be a .lib file, .dll file, or .tlb file. If the import library is supplied by the user, the line reads "Import Library: User-defined." For element types that do not require an import library, this line is omitted.

The sixth line indicates whether an element exists as both a Unicode (W) version and an ANSI (A) version. If Unicode support is not available, this line is omitted. For more information, see Win32 Function Prototypes.


Implementation Differences

Because there are architectural differences between Windows 95, Windows 98, Windows NT, and Windows CE, each system implements some elements differently. These differences are relatively few, and are noted in the Platform SDK. Each paragraph that notes a platform difference is preceded by one of the following tags:

Tag | Description
Windows NT: | The paragraph applies to Windows NT, but not Windows 95 or Windows 98.
Windows 95: | The paragraph applies to Windows 95, but not Windows 98 or Windows NT.
Windows 98: | The paragraph applies to Windows 98, but not Windows 95 or Windows NT.
Windows 95 and Windows 98: | The paragraph applies to Windows 95 and Windows 98, but not Windows NT.
Windows CE: | The paragraph applies to Windows CE only.

There are also differences between different versions of the same operating system. Most of these are due to the introduction of new constants. The following examples illustrate a function return value that varies by operating system version.

Windows 98, Windows NT 4.0 and later: The return value is the resulting incremented value.

Windows 95, Windows NT 3.51 and earlier: If the result of the operation is zero, the return value is zero. If the result of the operation is less than zero, the return value is negative, but it is not necessarily equal to the result. If the result of the operation is greater than zero, the return value is positive, but it is not necessarily equal to the result.

There are also differences between localized versions of the operating system. The following example illustrates this type of tag.

Middle-Eastern Windows: The text is laid out in right to left reading order, as opposed to the default left to right order. This only applies when the font selected into the device context is either Hebrew or Arabic.


Where to Find the Win32 Functions

In earlier versions of the Platform SDK, the Win32 functions appeared in alphabetical order under one reference node. These functions now appear in the reference nodes of their corresponding overviews. For more help locating this material, see the following topics:

  • Win32 Functions in Alpha Order
  • Win32 Functions by Category


Document Conventions

The Platform SDK documentation uses the following document conventions.

Convention | Description
monospace
 Indicates source code, structure syntax, examples, user input, and program output.
Bold | Indicates a function, structure, macro, interface, method, data type, or other keyword in the programming interface or programming language.
Italic | Indicates placeholders, most often function or method parameters; these placeholders represent the information that must be supplied by the implementation or the user. In addition, italics are used to highlight the first use of terms and to emphasize meaning.
UPPERCASE | Indicates a flag, return value, or property. In addition, uppercase letters may indicate file names, registers, and terms used at the operating-system command level.
[ ] Indicates optional syntax items. Type only the syntax within the brackets, not the brackets themselves.


Contents of the Platform SDK

The following list shows the nodes that form the top-level organization of the Platform SDK. These nodes contain groups of related technologies.

  • Windows Programming Guidelines
  • Windows Base Services
  • User Interface Services
  • COM and ActiveX Object Services
  • Internet, Intranets, and Extranet Services
  • Networking and Distributed Services
  • Database and Messaging Services
  • Graphics and Multimedia Services
  • Setup and Systems Management Services
  • Reference


Windows Programming Guidelines

The Windows Programming Guidelines node contains general information that will help you create, build, and manipulate Win32-based applications. The following references are included in this node:

  • Windows CE Programmer's Guide
  • Windows CE-Specific Reference
  • Platform SDK Tools
    • Authoring
    • Compiling
    • Building
    • Debugging
    • Multimedia
    • Testing
    • Tuning
  • Windows-based Terminal Server
  • Meeting Enterprise Needs
  • Windows Logo and Programming Guidelines
  • BackOffice Programmer's Reference
    • Developing Applications in the Microsoft BackOffice Environment
    • Developing Microsoft Exchange Server Applications
    • Developing Microsoft SQL Server Applications
    • Developing Microsoft Systems Management Server Applications
    • Developing Microsoft SNA Server Applications
  • Win32 Programming
  • Programming Tips and Techniques


Windows Base Services

The Windows Base Services node contains information that will help you take advantage of the base or core Windows services. The following overviews are included in this node:

  • Microsoft Cluster Server
  • Smart Card
  • CryptoAPI 2.0
  • Cryptographic Service Providers
  • Certificate Server
  • Debugging and Error Handling
    • Debugging
    • Errors
    • Event Logging
    • Structured Exception Handling
    • Error Codes
  • Executables
    • Dynamic-Link Libraries
    • Processes and Threads
    • Services
    • PE Image Helper (ImageHlp)
  • Files and I/O
    • Communications
    • Consoles and Character-Mode Support
    • Data Decompression Library
    • File Systems
    • File I/O
    • Tape Backup
  • General Library
    • Generic Thunks
    • Handles and Objects
    • Large Integer Operations
    • Memory Management
    • Registry
    • String Manipulation
    • Time
    • Timers
    • Tool Help Library
  • Hardware
    • Device Input and Output
    • Power Management
    • System Messages
  • International Features
    • End-User-Defined Characters
    • Input Method Editor
    • National Language Support
    • Unicode and Character Sets
    • Locale Identifiers
  • Interprocess Communication
    • Interprocess Communication
    • Atoms
    • Clipboard
    • Dynamic Data Exchange
    • Dynamic Data Exchange Management Library
    • Hooks
    • File Mapping
    • Mailslots
    • Pipes
    • Synchronization
  • Removable Storage Manager Programmer's Reference
  • Security
    • Access Control
    • Security SPI
    • Window Stations and Desktops
    • WinTrust
  • Windows 95 Features
    • Windows 95 Architecture
    • Windows 95 System Limitations
    • Version Differences
    • Windows 95, OEM Service Release 2
    • Device I/O Control
    • Exclusive Volume Locking
    • FAT32 File System
    • Long Filenames
    • MS-DOS Extensions
    • Thunk Compiler
    • Virtual Machine Services
    • Windows 95 Service Control Manager
  • Windows NT Features
    • Performance Data Helper
    • Process Status Helper
    • Windows NT Performance Counters


User Interface Services

The User Interface Services node contains information that will help you create a user interface for your application and interact with the user's desktop (shell). The following overviews are included in this node:

  • Microsoft Active Accessibility
  • Shell and Common Controls
    • Windows Shell API
    • Common Controls
    • Wizard97 Specifications
  • Controls
    • Controls
    • Buttons
    • Combo Boxes
    • Edit Controls
    • List Boxes
    • Rich Edit Controls
    • Scroll Bars
    • Static Controls
  • Resources
    • Carets
    • Cursors
    • Icons
    • Menus
    • Resources
  • User Input
    • Accessibility
    • Common Dialog Box Library
    • Mouse Input
    • Keyboard Accelerators
    • Keyboard Input
    • Virtual-Key Codes
  • Windowing
    • Dialog Boxes
    • Message and Message Queues
    • Multiple Document Interface
    • Window Classes
    • Window Procedures
    • Window Properties
    • Windows


COM and ActiveX Object Services

The COM and ActiveX Objects node contains information that will help you develop object-oriented applications or components. The following overviews are included in this node:

  • COM
    • The Component Object Model
    • COM Clients and Servers
    • Error Handling
    • Monikers
    • Connectable Objects
    • Structured Storage
    • Asynchronous Storage
    • Data Transfer
    • Property Pages and Property Sheets
    • Class Store
    • Compound Documents
    • ActiveX Controls
    • Component Categories Manager Implementation
    • Defining COM Interfaces
    • URL Open Stream Functions
    • COM Tutorial Samples
  • Component Development
  • Automation
    • Overview of Automation
    • Exposing ActiveX Objects
    • Accessing ActiveX Objects
    • Standard Objects and Naming Guidelines
    • Dispatch Interface and API Functions
    • Data Types, Structures, and Enumerations
    • Conversion and Manipulation Functions
    • Type Libraries and the Object Description Language
    • Type Description Interfaces
    • Type Building Interfaces
    • Error Handling Interfaces
  • Microsoft Transaction Server 2.0
  • MIDL


Internet, Intranets, and Extranet Services

Internet, Intranet, and Extranet Services

The Internet, Intranets, and Extranets node contains information that will help you create dynamic content for your Web site. The following overviews are included in this node:

  • Active Server Pages
  • Index Server Programmer's Guide
  • Dynamic HTML
  • Delivering Content to the Web
  • Internet Tools & Technologies
  • Internet Information Server SDK
  • Microsoft Agent
  • Microsoft Application Foundation Classes for Java
  • Microsoft SDK for Java
  • About the Microsoft Virtual Machine
  • Common Internet File System Protocol
  • NetMeeting
  • NetShow SDK
  • NetShow Theater Server Administration SDK
  • Media Player Control
  • Scripting
  • Site Server
  • Component Library


Networking and Distributed Services

The Networking and Distributed Services node contains information that will help you create client/server applications. The following overviews are included in this node:

  • Active Directory Service Interfaces (ADSI)
  • Active Directory Schema
  • Generic Quality of Service (GQOS)
  • Windows Sockets Version 2
  • The DLC Interface
  • The NetBIOS Interface
  • Network Dynamic Data Exchange
  • Networking (Net)
  • Remote Access Service
  • Simple Network Management Protocol (SNMP)
  • Windows Networking (WNet)
  • Microsoft Message Queue Server (MSMQ)
  • Routing and Remote Access Services
  • Remote Procedure Calls (RPC)
  • Microsoft SNA Server
  • Telephony Application Programming Interface (TAPI)


Databases and Messaging Services

The Databases and Messaging node contains information that will help you add database and messaging services to your application. The following overviews are included in this node:

  • DAO SDK
  • Microsoft Data Access SDK
  • Microsoft Exchange Server
  • Messaging API (MAPI)
  • Collaboration Data Objects
  • Extending the Microsoft Exchange Client
  • Microsoft SQL Server Programmer's Toolkit


Graphics and Multimedia Services

The Graphics and Multimedia node contains information that will help you add graphics and multimedia services to your application. The following overviews are included in this node:

  • Broadcast Architecture
  • Color Management
  • DirectX 5
    • DirectDraw
    • DirectSound
    • Direct3D Immediate Mode
    • DirectInput
    • DirectSetup
    • AutoPlay
  • DirectX Media SDK
    • DirectAnimation SDK
    • DirectPlay SDK
    • DirectShow SDK
    • Direct3D Retained Mode SDK
  • GDI
    • Bitmaps
    • Brushes
    • Clipping
    • Colors
    • Coordinate Spaces and Transformations
    • Device Contexts
    • Filled Shapes
    • Fonts and Text
    • Lines and Curves
    • Metafiles
    • Multiple Display Monitors
    • Painting and Drawing
    • Paths
    • Pens
    • Printing and Print Spooler
    • Rectangles
    • Regions
  • Multimedia Audio
    • Audio Compression Manager
    • Audio Mixers
    • MCIWnd Window Class
    • MCI
    • Musical Instrument Digital Interface (MIDI)
    • Waveform Audio
  • Multimedia Input
    • File Input and Output
    • Joysticks
    • Multimedia Timers
  • Video for Windows
    • AVIFile Functions and Macros
    • Video Compression Manager
    • Video Capture
    • Custom File and Stream Handlers
    • DrawDib
  • Still Image
  • OpenGL


Setup and Systems Management Services

The Setup and Systems Management node contains information that will help you manage your system and applications installed on the system. The following overviews are included in this node:

  • Ensuring Your Application Migrates from Windows 9x to Windows NT
  • Integrating Your Setup Program With Setup Computer Wizard
  • File Installation Library
  • License Service Application Programming Interface
  • System Information
  • System Policies
  • System Shutdown
  • Microsoft Systems Management Server
  • Microsoft Management Console
  • Setup API
  • Windows Installer Programmer's Reference
  • Task Scheduler API
  • WBEM SDK


Reference

The Reference node contains information about 16-bit Windows Application Programming Interface (API) elements that were deleted or superseded in the Win32 API. It also contains a list of simple data types used in the Win32 API, and a glossary for the Win32 API. The Code Samples node contains files from the code samples included on the Platform SDK CD. The samples are grouped in a way that corresponds to the way the documentation for the various technologies are grouped.

The following books are included in this node:

  • Deleted and Superseded Programming Elements
  • Win32 Functions in Alpha Order
  • Win32 Functions by Category
  • Win32 Simple Data Types
  • Win32 Glossary
  • Code Samples
    • BEGIN
    • COM
    • DBMSG
    • GRAPHICS
    • INTERNET
    • NETDS
    • SDKTOOLS
    • SYSMGMT
    • WINBASE
    • WINUI


Topic Not Found

No matching topic was found. Some possible reasons and remedies are as follows:

  • The file (.chm) that contains the destination topic is not in the expected location.

Remedy: Rerun the MSDN Library Setup.

  • The file (.chm) that contains the current topic or destination topic is out-of-date and the link is no longer valid.

Remedy: Install the latest version of the MSDN Library.

  • The MSDN Library CD is not in the CD-ROM drive.

Remedy: Insert the MSDN Library CD into the CD-ROM drive.


Legal Information

Microsoft Platform
Software Development Kit

This is a preliminary document and may be changed substantially prior to final commercial release. This document is provided for informational purposes only and Microsoft makes no warranties, either express or implied, in this document. Information in this document is subject to change without notice. The entire risk of the use or the results of the use of this document remains with the user. The names of companies, products, people, characters, and/or data mentioned herein are fictitious and are in no way intended to represent any real individual, company, product, or event, unless otherwise noted. Complying with all applicable copyright laws is the responsibility of the user. No part of this document may be reproduced or transmitted in any form or by any means, electronic or mechanical, for any purpose, without the express written permission of Microsoft Corporation.

Portions of this document specify and accompany software that is still in development. Some of the information in this documentation may be inaccurate or may not be an accurate representation of the functionality of final documentation or software. Microsoft assumes no responsibility for any damages that might occur directly or indirectly from these inaccuracies.

Microsoft may have patents, patent applications, trademarks, copyrights, or other intellectual property rights covering subject matter in this document. Except as expressly provided in any written license agreement from Microsoft, the furnishing of this document does not give you any license to these patents, trademarks, copyrights, or other intellectual property.

© 1985-1998 Microsoft Corporation. All rights reserved.

ActiveMovie, ActiveX, BackOffice, Developer Studio, Direct3D, Direct Animation, DirectDraw, DirectInput, DirectMusic, DirectPlay, DirectShow, DirectSound, DirectX, JScript, Microsoft, Microsoft Press, MS, MSDN, MS-DOS, Natural, NetShow, Sidewalk, SQL Server, Visual Basic, Visual C++, Visual J++, WebTV, Win32, Win32s, Windows, and Windows NT are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries. OS/2 is a registered trademark licensed to Microsoft Corporation.

International CorrectSpell is a trademark of INSO Corporation.

Other product and company names mentioned herein may be the trademarks of their respective owners.