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1 Introduction 

In this document, a brief description is given of the processing of unmanned aerial vehicles 
(UAVs) image data and the working steps to be undertaken within OpenDroneMap ODM open- 
source software. The processing is aimed to prepare the task of image orientation, point cloud 
generation, DSM, and Orthomosaic production from UAV images. 

 
This exercise includes a procedure part of a detailed step-by-step description for each task; it 
also contains some questions to help you better understand the process. 

 

• Type: Exercise 
 

• Expected time investment: 4 hours. 
 

• Software: WebODM 

 
 

1.1 Overall learning objectives 
 

In this exercise, we aim to provide students with hands-on experience in processing UAV 
image data with and without the use of Ground Control Points (GCPs). They will assess the 
accuracy of the generated outputs based solely on the geolocated images and make 
comparisons. 
After the processing is finished, the students will be able to export several file outputs, 
including the quality report, dense point cloud, mesh, and orthophoto. These steps will 
provide a comprehensive understanding of the workflow involved in processing UAV image 
data sets for mapping purposes. 

 
After this exercise, the students will be able to: 

• Understand the basics and concepts of photogrammetry. 

• Apply the image orientation process for UAV imageries with the required settings. 

• Derive and export the dense point cloud and meshes from UAVimageries. 

• Derive and export the DSM and orthophoto generation processes for UAV imageries. 

• Assess the quality of the generated output using open-source tools. 

 
1.2 Processing with WebODM 

                        
In this exercise, we use the open-source software WebODM. WEB ODM is an open-source software tool 
designed for processing UAV imagery and generating 3D models, point clouds, and orthophotos. It 
provides a web-based interface that allows users to upload their UAV imagery datasets and perform 
photogrammetric processing to derive valuable geospatial information. There are many educational 
resources related to the use of this tool. Please check the following links. 
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https://docs.opendronemap.org/ 

 

https://courses.gisopencourseware.org/mod/book/tool/print/index.php?id=1028#ch2462 

 

 
 

 
1.3 Data 

• UAV images data set 

o Images collected over the Gulele Botanical Garden in Addis Ababa- 

Ethiopia 

o Drone: DJI version 

o 162 images, taken in one nadir configuration  

o Flying height = 100m  

o Camera: FC330, focal length= 4mm, pixel size 4000x3000 pixel 

• Ground control points 

o The points are measured with the differential GNSS technique. The date 

of the fieldwork is back to 3/8/2020 at 4:22:45 PM (UTC:3). Time zone: E. 

Africa Standard Time. 

o Coordinate system :  

▪ Name: Worldwide/UTM 

▪ Datum: WGS 1984 

▪ Zone: 37 North 

▪ Geoid: EGM 2008 Ethiopia 

 

 

 

 

 

 

https://docs.opendronemap.org/
https://courses.gisopencourseware.org/mod/book/tool/print/index.php?id=1028#ch2462
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• Images are geolocated using onboard GPS in WGS 84 coordinates stored in their EXIF metadata. 
However, the GCPs coordinates are given in the coordinate system mentioned above. The list of GCPs 
and checkpoints (CPs) coordinates is as follows: 

 

ID  Easting Northing Elevation 

CP 1 469573.152 1003244.943 2716.509 

GCP 2 469520.961 1003300.362 2716.016 

GCP 3 469501.625 1003620.190 2749.639 

GCP 4 469691.374 1003655.924 2725.989 

GCP 5 469671.973 1003269.632 2720.025 

CP 6 469579.220 1003445.327 2732.610 

CGP 7 469532.631 1003485.635 2729.992 

CP 8 469673.170 1003515.176 2729.428 

GCP 9 469618.643 1003670.132 2754.551 

 
 

 

For clarification, the GCPs' and CPs' locations are shown in Figure 1  

 
 You can watch these two videos to learn how to import and then measure the GCPs 

in your project 

https://www.youtube.com/watch?v=axuVvRU8t54&ab_channel=ShadeTreeTinkery 

https://www.youtube.com/watch?v=pzUgl-Wvp2I&ab_channel=JeremyMaurer 

https://www.youtube.com/watch?v=axuVvRU8t54&ab_channel=ShadeTreeTinkery
https://www.youtube.com/watch?v=pzUgl-Wvp2I&ab_channel=JeremyMaurer
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The format of the GCP file shouldn't be complicated when using a UTM projection as 

described here: 

 

The first line should contain the name of the projection used for the geo coordinates. This can be specified 
either as a PROJ string e.g. +proj=utm +zone=37 +datum=WGS84 +units=m +no_defs +north ), EPSG code 
(e.g. EPSG: 32637) or as a WGS84 UTM <zone>[N|S] value (eg. WGS84 UTM 37N). 

 
 

! If the coordinates are listed in WGS84 as (latitude, longitude, and elevation) then it's easy to 
import as shown in the video above. However, for our case, we need to write it as follows: 
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Figure 1. GCP and CPs locations. 

 

 
 

For more information regarding the exact location of each GCP and CP, please use the supplementary  document 
(EENSAT_PD_Practical_GCPs_Documentation.pdf) 

 
Using these GCPs and CPs, the students will have the opportunity to evaluate the impact of 

incorporating ground control information on the accuracy of their outputs. 
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2 Processing with WebODM 

 
! Please note the following sections explain the main steps to work on the WebODM and 

calculate the accuracy, however, please expect to receive different output results compared to 
the ones documented here, such as the Camera parameters. This is can be due the 
uncertainties of some measurements of the GCPs. 

We need to prepare a text file of the GCPs measurements in the required format of the WebODM by 
measuring the GCPs on the viewing images. Then the measurement text file will be uploaded 
together with the images. 

 
Let's look at the instructions to measure GCPs before starting the orientation processing as follows: 

 
! In this project, the GCPs' placement and distribution are governed by the accessibility offered to 
the project site. 

 
 Go to the pane on the left of the tool interface and select 'GCP Interface.' 

 
 

 

 

 

 

 

 

 

 

! It should be noted to run the WebODM; you need 20 GB of free space on your computer.  
 

! It should be noted that WebODM can not process checkpoints for accuracy checks like, for 
example Pix4D. 
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However, you can assess the accuracy as follows: 

 

• After processing, compare the positions from the Orthomosaic or 3D reconstruction with your 
independent checkpoints. Determine the positional discrepancies between the coordinates of 
the checkpoint and the equivalent coordinates you got from the images you processed. 

• Calculate accuracy measures like Root Mean Square Error (RMSE) to evaluate the project's 
overall accuracy. You may use this to evaluate how well the derived data (Orthomosaic) aligns 
with the checkpoints. 

 
 
 

Click on                                                                  where you will upload your GCP file       

as shown previously; the label  will  change  to 

 
 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 
 

Then, you need to measure the loaded GCPs on the viewing images.  

So, click on and select all the provided images.  
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The images will be uploaded to the interface as follows: 

 

 
 
 

As indicated by the screenshots in the appendix, you need to measure the loaded 

GCPs on the viewing images. For example, GCP 2 is viewed by image DJI_0011.JPG, so 

first click on the GCP2 symbol on the map and then on that image in the thumbnail 

image list and click on this symbol . When the symbol is colored as 'green' then it's 

measured and will be exported to the GCP measurement text file. 
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 You will continue to measure all the GCPs in all the viewing of the images. The 

minimum number is to measure only 3 GCPs in at least two images. 

 

 

! It should be noted that you only need to load and measure the GCPs and not the CPs. The 

previous figure shows both types. 

 

 

After measuring the GCPs is finished, you can export the file by clicking on 'Export 

File'. The text file will continue the XYZ of the GCPs we already imported beside the pixel 

coordinates of each measured GCP in a viewing image. 
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Now, back to the Dashboard to start the image orientation step and 3D modeling. We start by 
importing the images and the exported GCP measurement file. 

 
 Open WebODM on your desktop and select the Dashboard (on the left pane), then 1) 

create a project  and 2) click on , then select the images 
and GCP measurements text file. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Before starting the processing, you need to make a selection of intended processing which can 
be found in ' Options'. For this exercise, we choose the '3D Model' to ensure having all the 
products of the dense point cloud, DSM, and orthophoto. 

 

! It should be noted  to generate the DTM and DSM layers; please enable the options found in 

the "Edit" menu. 
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Then after completion, some information will be displayed as shown: 

 
! Notice that the software by default, is resizing (downscaling) the images for a faster and more 
economical process. 

 

 After 'Review', you start the processing                              . The software will first resize the images  

and then start processing.
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You can view the results by clicking on ' View 3D Model'. You can navigate the 3D model 
or point cloud produced and also export the quality report. 
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To download the dense point cloud, you have the choice to select the map projection and 
file format as shown. Try to download the point cloud in UTM/ EPSG 32637. 

Furthermore, you can restart the processing from any step you would like as shown 
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The exported Las file of the point cloud can be viewed by Cloud Compare as shown 

 

 
 

The camera parameters after self-calibration can also be exported as shown. 
 
 

{ 

    "dji fc330 2048 1536 brown 0.5555": { 

        "projection_type": "brown", 

        "width": 2048, 

        "height": 1536, 

        "focal_x": 0.6045198110675827, 

        "focal_y": 0.6045198110675827, 

        "c_x": 0.011140863488828246, 

        "c_y": 0.0011532139909078566, 

        "k1": -0.0014393609334307463, 

        "k2": -0.009461027359038771, 

        "p1": 0.000708615900594036, 

        "p2": 0.0007825698390231316, 

        "k3": 0.005381919545476886 

    } 

} 

 
 
 
 

! It should be noted that the image parameters ( Exterior orientation parameters) can also be 
exported.  

 

 

Focal length & 
Principle point coordinates  
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The Orthomosaic can also be exported where the user should select the EPSG and format. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Take some time and check the generated quality report. Do you accept the results? 
How can it be improved?
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3 Accuracy assessment 

To check the accuracy achieved, compute the shift between the checkpoint coordinates and the 
orthophoto image using QGIS, you can follow these steps: 

Open QGIS: Launch QGIS on your computer. 

Load the orthophoto GeoTIFF exported from WebODM. In QGIS, go to the "Layer" menu 
and select "Add Layer" > "Add Raster Layer." Browse to the location of your orthophoto GeoTIFF 
file and select it to load it into QGIS as shown. 

 

 
 

! Notice that the orthophoto is a 2D map. Then, the computed accuracy will be planimetric 
XY only. 

 

  Load the checkpoint coordinates: go to the "Layer" menu and select "Add Layer" > "Add 
Delimited Text Layer" (or use the toolbar button for this option). In the dialog box, browse to 
the file containing your checkpoint coordinates (e.g., a CSV file) and specify the coordinate 
reference system (CRS) used which is WGS84 UTM 37N. See below. 
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The checkpoints will be added as shown. 

 
! You can change the symbol of the added points. 
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Create a new shapefile layer as shown below where you tick manually the checkpoints 
from the orthophoto and prepare the measured coordinates layer of the checkpoints. 

 

 

 

 

Export the measured points shapefile to your folder. 
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You can compute the difference in the distance between the GCPs and the CPs  using the 
measuring tool.  

 

 

 
 

 

 The distance shown in is not the RMSE. To compute the RMSE, you need first to add the X,Y 
coordinates to the attributes, and then export the points measured with the shift errors 
and save it as a CSV file. 

 

 From Processing Toolbox, under the Vector table, select the Add X/Y fields to layer ( make 
sure to select the coordinate system to Projected CRS in both cases  

 

 
 

 
 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Then, use Excel to compute the RMSE. For example, see the following table of 
calculations. 
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label X Ref Y Ref X meas Y meas dx dy dx^2 dy^2 

CP6 469579.22 1003445.33 469579.65 1003444.53 0.43 -0.80 0.185 0.634 

CP8 469673.17 1003515.18 469673.27 1003514.36 0.10 -0.81 0.009 0.660 

            Avg. 0.097 0.647 

                  

            RMSE_X 0.311  
            RMSE_Y 0.804   

                  

            
RMSE 
XY 

0.862   

 

 

  Once you have the RMSE values, you can assess the shift between the checkpoint 
coordinates and the orthophoto to decide if the achieved accuracy is acceptable. 
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4 Questions and answers 

1. Define the term "Coordinate Reference System (CRS). Which coordinate reference system (CRS) is 
commonly used in the Netherlands? 

Answer: A CRS is the abbreviation of 'coordinate system' used to define and locate points on the Earth's 
surface. The common coordinate system used in the Netherlands is called Amersfoort/RD New 
(Rijksdriehoekscoördinaten). 

 
2. Explain the role of GCPs in the georeferencing process. 
Answer: GCPs represent known reference points with known (fixed) coordinates, allowing the derived 
3D point cloud, and Orthomosaic map to be aligned with real-world (national) coordinates. 

 
3. You have a set of GCP coordinates in the WGS84 UTM 37N . Describe the steps you would take to 

import and integrate them into a WebODM project. 
Answer: The steps may involve preparing the GCP XYZ text file, importing the images and GCP file into 
WebODM, start measuring the imported GCPs on images, and finally exporting the file for subsequent 
processing. 

 
4. Describe the advantages and limitations of using GCPs in photogrammetry projects. 
Answer: The advantages may include improved accuracy and georeferencing, while limitations may 
involve the cost and effort required for GCP surveying data collection and the possibility of conducting 
some errors in GCP measurements. 

 
5. What factors can impact the accuracy of UAV photogrammetry results? 
Answer: Different factors can affect the accuracy of UAV photogrammetry, including: 

• Quality of GCP measurements: Accurate GCP measurements are essential for achieving 
accurate georeferencing. This includes their distribution and being manmade features that can 
be identified clearly in the images. 

• Image quality: For improved feature extraction and matching, use high-resolution, sharp (free 
of blur), and correctly exposed images. 

• Camera calibration: Precise calibration parameters improve the accuracy of the 
photogrammetric reconstruction. 

• Flight plan: Flight parameters should be optimal to ensure sufficient image overlap and ground 
resolution. 

 

6. How does image overlap affect the accuracy and quality of a UAV photogrammetry project? 
Answer: Image overlap is critical to ensure the generation of accurate and high-quality 
photogrammetric results. Sufficient overlap between images ensures better feature matching and 
improves the accuracy of the reconstructed 3D models. Generally, a 70-90% overlap is recommended. 

 
7. How to ensure a higher density point cloud generation in WebODM? 
Answer: in the pc-quality field we can set up the point cloud density. Higher quality generates better, 
denser point clouds, but requires more memory and takes longer processing time. Each step up in 
quality increases processing time roughly by a factor of 4x. the options available are ultra, high, 
medium, low, and lowest. 
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8. List some standard techniques or algorithms used for feature matching in photogrammetry? 
Answer: Scale-Invariant Feature Transform (SIFT), Speeded-Up Robust Features (SURF), Oriented FAST 
and Rotated BRIEF (ORB), and the Harris corner detection algorithm are some of the methods and 
algorithms used by photogrammetry software for feature matching. These algorithms match 
overlapped photos based on their descriptors and extract distinguishing information from the images. 

 
9. Does the number of matched features affect the accuracy of photogrammetric results? 
Answer: The number of matched features has a direct impact on the accuracy of photogrammetric 
results. Accordingly, a higher number of matched features (redundancy) will offer in most cases more 
accurate image orientation using the SfM method. As a result, derived point clouds and orthophoto 
will be more accurate. 

 
10. How can you assess the accuracy of an orthophoto produced in WebODM? 
Answer: The accuracy of an orthophoto can be assessed by comparing specific ground control points 
or reference data with corresponding locations in the exported orthophoto. By using an appropriate 
software like Cloud Compare or QGIS, you can measure the positional accuracy by computing the RMSE 
and evaluating the deviations between the known checkpoints and their positions in the orthophoto. 

 
11. The quality of the Digital Surface Model DSM used in the generation of orthophotos directly impacts 

the orthophoto's quality, why? 
Answer: There are multiple reasons, mostly during orthophoto generation, the elevation data is used 
to correct distortions caused by the terrain relief. If the DSM is accurate, it ensures that the orthophoto 
aligns correctly with the underlying terrain, resulting in a visually accurate representation of the scene. 

 

12. What are the feature-matching algorithms offered by WebODM? 
WebODM offers three options for feature matching as follows: 

1. FLANN (Fast Library for Approximate Nearest Neighbours): FLANN is utilized as a matcher type 
for feature matching in WebODM. It enables quick and rough keypoint matching between 
photos. 

2. BruteForce: a straightforward matching algorithm that performs an exhaustive search for 
matching keypoints. It compares each keypoint in one image with all keypoints in another 
image to find the best matches. While it may be computationally expensive, it can provide 
accurate matching results. 

3. BoW (Bag of Words): a technique used in image retrieval and recognition. In WebODM, it is 
used as a matcher type for feature matching. The BoW approach represents each image as a 
collection of visual words or keypoints. Matching is then performed based on the similarity of 
the visual words between images.
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