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Chapter 5

Editors

5.1 Introduction to map editors
In a map window, map editors can be used to edit features of raster, polygons,
segment or point maps.

With the pixel editor, you can:
n edit the class names, IDs, or values of pixels in a raster map.

With the polygon editor, you can:
n edit the class names, IDs, or values of polygons, and
n create labels of polygons,
n apply labels to polygons,
n extract segments.

With the segment editor, you can:
n insert segments and delete existing ones,
n edit the class names, IDs, or values of segments,
n change the shape of segments,
n split and merge segments, and
n check segments and polygonize segments.

With the point editor, you can:
n insert new points and delete existing ones,
n edit the class names, IDs, or values of points, and
n move points to a new position.

The polygon, segment and point editor can be used with the mouse pointer on the
screen, and with the digitizer cursor when a paper map is stuck on a digitizer
tablet. To set up a digitizer and to start digitizing, see Help topic How to set up a
digitizer.

5.2 Pixel editor

5.2.1 Functionality
With the pixel editor, you can edit the class names, IDs or values of pixels in a
raster map. The pixel editor has one mode, Select mode, to select pixels of which
you want to change the class name, ID or value. The pixel editor has a menu bar, a
context-sensitive menu, and a button bar.
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To start the pixel editor
To edit an existing raster map, display a raster map in a map window, open the
Edit menu in the map window, choose Edit Layer, select the raster map layer you
want to edit. For more information, see How to edit point, segment, polygon, and
raster maps. Dependent raster maps cannot be edited: first break the dependency
links in the Properties dialog box of the map.
When the editor is started, the mouse pointer appears as a hand.

To zoom in on the map
Zoom in on the raster map for instance by clicking the Zoom In button on the
button bar. When you zoomed in deeply, the pixel values, class names or IDs of the
pixels are displayed. For more information, see How to zoom in on maps.

Select mode to select pixels
The pixel editor has one mode, Select mode, to select pixels of which you want to
change the class name, ID or value. In the Select mode, the mouse pointer appears
as a hand. You can select one or more pixels by clicking them or dragging a box
around them, in order to change their class name, ID, or value.
n to select a pixel, click it; or move the pixel selection cursor with the arrow keys

on the keyboard and press the space bar;
n to select all pixels within a selected area: drag a box with the left mouse button

and all pixels in the box are selected;
n to add pixels to a selection: press and hold down the Ctrl key and click the other

pixels you want to select. When finished, release the Ctrl key.
n to clear a part of a selection: press and hold down the Ctrl+Shift keys, then

click previously selected pixels or drag a box around pixels: these pixels are
deselected. When finished, release the Ctrl+Shift keys.

n to toggle between select and deselect: press and hold down the Shift key, then
click pixels or drag a box around pixels: selected pixels are deselected, and non-
selected pixels are selected. When finished, release the Shift key.

To change the value of selected pixels
Depending on the domain of the raster map that you are editing, you can change
the class name, identifier or value of selected pixels:
n double-click a pixel and select a class name, or enter an identifier or a value, or
n select one or more pixels, and select Edit from the Edit menu or from the

context-sensitive menu, or press Enter on the keyboard. In Edit dialog box that
appears, select a class name, or type an identifier or a value.

For more information, see Pixel editor : Edit selection. All changes you make are
immediately stored in the raster map.

To copy pixels into the clipboard
You can copy selected pixels with their coordinates and class names, IDs, or values
to the clipboard. Select the pixels you want to copy and choose Copy from the Edit
menu. For more information, see Pixel editor : Copy.
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To paste pixels from the clipboard
You can paste pixels, points, or nodes and intermediate point of segments and
polygons from the clipboard into the pixel editor.
For more information, see Pixel editor : Paste.

To exit the pixel editor
To exit the pixel editor, choose the Exit Editor command on the File menu or from
the context-sensitive menu. You can also click the Exit Editor button in the button
bar; you return to the map window. When you double-click the Control-menu box
the window is closed.

For more information, see also Appendices : Keyboard shortcuts and Appendices :
Mouse functions.

5.2.2 Pixel editor Menu commands
File Exit Editor

Edit Cut
Copy
Paste
Delete
Edit ...
Legend

Layers Add Data Layer Raster Map ...
Segment Map ...
Polygon Map ...
Point Map ...

Add Annotation Text ...
Legend ...
Grid Lines ...
Graticule ...
Box ...
Scale Bar ...
North Arrow ...
Bitmap or Picture ...

Display Options select layer
Layer Management
Background Color ...
Double-Click Action ...

Options Entire Map
Zoom In
Zoom Out
No Zoom
Redraw
Measure distance
Larger
Smaller
Extend Window Extend by Percentage ...

Extend by Coordinates ...
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Coordinate System ...
√ Adjust Window Size
√ Button Bar
√ Status Line

Help Help on this Window
Contents
Search
Index
Glossary
Operations
Menu Commands
How to ...
How to use Help
About ILWIS

Context-sensitive menu
Select Area
Edit ...
Exit Editor

5.2.3 Pixel editor Button bar
The button bar of the pixel editor largely resembles the button bar of a map
window;  there is an extra button to exit the editor.

The following actions can be performed:

Entire Map: Displays the entire map in the map window.

Zoom In: Zooms in on a selected spot or area in the map. The mouse pointer
changes into a magnifying-glass. Click to zoom in on a spot of interest, or drag the
pointer from one corner of interest to another (the mouse pointer changes into a
little box).

Zoom Out: Zooms out directly from the center of the displayed map with a factor 2.

Larger: Enlarges the size of the window with a factor 2. If this would not fit on
your screen, this button is empty.

Smaller: Reduces the size of the window with a factor 2.

Redraw: Redraws the contents of the map window.

Exit editor: Leaves the editor and keeps all changes.

The button bar can be hidden or shown with the Button Bar command on the
Options menu. If the action of a certain button cannot be performed at a certain
moment, the button appears gray.
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5.3 Polygon editor

5.3.1 Functionality
The polygon editor is used to edit a polygon map. To create a polygon map, first
digitize your segments with the segment editor and then polygonize the segment
map in the segment editor. With the polygon editor, you can only edit the class
names, IDs or values of polygons. The polygon editor has a menu bar, a context-
sensitive menu and a button bar.

You can edit polygons with the mouse pointer on the screen but you can also use
the digitizer cursor when a map is stuck on your digitizer tablet.
When you want to use the digitizer for the first time, you may have to setup the
digitizer or reference the map. For more information, see also How to setup a
digitizer and start digitizing.

When the digitizer is active, the Edit Polygons menu of the digitizer also appears.
When the digitizer is not active, reference your map again. Depending on the
digitizer set up, the numbers noted in front of a command on a digitizer menu,
correspond with a button on your digitizer cursor (see How to set up a digitizer). To
select a command, press the corresponding button. For a flowchart of the different
digitizer menus, see Appendix : Flow charts of digitizer menus.

Further, in any map editor you can always use existing maps as a background by
adding these maps as other data layers to the window (see How to digitize or How
to add extra data layers to a map window).

To edit a polygon map
To edit a polygon map, display the polygon map in a map window, open the Edit
menu, choose Edit Layer, and select the polygon layer from the cascading menu.
You can also click a polygon in the Catalog with the right mouse button and then
select Edit from the context-sensitive menu. For other methods, see How to edit
point, segment, polygon, and raster maps.

Dependent polygon maps can not be edited: first break the dependency links in the
Properties dialog box of the map.

When the polygon editor is started, a backup of the original polygon map is
automatically made; the backup has almost the same name as the original polygon
map. Only the first character is replaced by a hash (#).
When the Polygon editor is started, the mouse pointer appears as a hand. When the
digitizer is active the Edit Polygons menu of the digitizer also appears.
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Working with the mouse

To zoom in on the map
You can zoom in on the polygon map by for instance clicking the Zoom In button
in the button bar. For more information, see Map window : zoom in.

Selecting polygons
You can select one or more polygons by clicking them, in order to change their
class name, ID, or value.
n to select a polygon: click it.
n when you double-click a polygon, you can immediately change the class name,

ID, or value of the polygon.
n to add polygons to a selection: press and hold down the Ctrl key and click the

other polygons you want to select. When finished, release the Ctrl key.
n to clear a part of a selection: press and hold down the Ctrl+Shift keys, then

click previously selected polygons: these polygons are deselected. When
finished, release the Ctrl+Shift keys.

n to toggle between select and deselect: press and hold down the Shift key, then
click polygons: selected polygons are deselected, and non-selected polygons are
selected. When finished, release the Shift key.

Editing selected polygons
Depending on the domain of the polygon map that you are editing, you can change
the class name, identifier or value of selected polygons:
n double-click a polygon, or
n select one or more polygons, and press Enter, or
n select one or more polygons, and select Edit from the Edit menu or from the

context-sensitive menu.

In the dialog box that appears, select a class name, or type an identifier or a value.
Polygons in a polygon map that uses an identifier domain can only be edited
individually.

When you enter an identifier that is not yet present in the domain that the map is
using, the identifier is automatically added to the domain. When you want to enter
a class name, a list of the classes which are already in the domain appears in a text
box. You can select an existing class, a question mark ? if the polygon is
undefined, or <new> to create a new class which will be automatically added to the
domain. In maps using a value domain, you cannot enter values that do not fit in
the value range of that domain. For more information, see Polygon editor : Edit
selection.

Working with the digitizer

When in the following part is written that you have to press e.g. the Change
Window button, this means that you have to press the cursor button of your
digitizer cursor, which corresponds with the number in front of the Change
Window option in the digitzer menu. In the example, this is the cursor button
corresponding with 2:
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Editing a selected polygon
Locate the digitizer cursor on the polygon you want to edit. Press the Edit Value
button to open a dialog box. In the dialog box, the area and length of the polygon
are displayed; depending on the domain of the map that you are editing, you can
enter a new class, ID or value.

To change the window
Press the Change Window button. Move the cursor to the first corner of the area
you want to zoom in. Press the 1st Point button, you now see the zoom in box tied
to the first point. Move the cursor to the 2nd position of the area you want to zoom
in. Press the 2nd Point button, to zoom in on the area. To display the entire map
after a zoom in command, press the Entire Map button. See also Appendices :
Flow charts of digitizer menus.

Other options

To customize the polygon editor
When you choose Customize from the Edit menu or from the context-sensitive
menu, you can among others indicate whether to use Autosnap or not and choose
the colors in which you want to see your polygon boundaries. For more
information, see Polygon editor : Customize.

Extract segments
To extract all segments from the polygon map and create an editable segment map,
select Extract Segments from the File menu. For more information, see Polygon
editor : Extract Segments.

Create labels
To create an editable point map in which each polygon has a label point, select
Create Labels from the File menu. For more information, see Polygon editor :
Create Labels.

Apply labels
To apply point labels to the polygons, select Apply Labels from the File menu. For
more information, see Polygon editor : Apply Labels.



Editors

122 ILWIS Reference Guide

To exit the polygon editor
To exit the polygon editor, choose the Exit Editor option on the File menu or from
the context-sensitive menu or click the Exit Editor button in the button bar. When
you double-click the Control-menu box, the window closes. All changes you make
in the polygon map during a session are continuously stored.

For more information, see also Appendices : Keyboard shortcuts and Appendices :
Mouse functions.

5.3.2 Polygon editor Menu commands
File Undo all changes

Create Labels...
Apply Labels...
Extract Segments...
Customize
Exit Editor

Edit Copy
Edit ...

Layers see Pixel editor
Options see Pixel editor
Help see Pixel editor

Context-sensitive menu
Select Area
Edit ...
Customize
Exit Editor

5.3.3 Polygon editor Button bar
The button bar of the Polygon editor has the same buttons as a normal map window
and some extra buttons for the different modes in the Polygon editor and a button to
exit the editor.

The following actions can be performed:

Entire Map: Displays the entire map in the map window.

Zoom In: Zooms in on a selected spot or area in the map. The mouse pointer
changes into a magnifying-glass. Click to zoom in on a spot of interest, or drag the
pointer from one corner of interest to another (the mouse pointer changes into a
little box).

Zoom Out: Zooms out directly from the center of the displayed map with a factor 2.
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Larger: Enlarges the size of the window with a factor 2. If this would not fit on
your screen, this button is empty.

Smaller: Reduces the size of the window with a factor 2.

Redraw: Redraws the contents of the map window.

Exit editor: Leaves the editor and keeps all changes.

The button bar can be hidden or shown with the Button Bar command on the
Options menu. If the action of a certain button cannot be performed at a certain
moment, the button appears gray.

5.4 Segment editor

5.4.1 Functionality
The segment editor is used to create a segment map with digital line features. To
create a polygon map with digital area features, first digitize segments with the
segment editor, then polygonize the segment map in the segment editor into a
polygon map.

In the segment editor you can work with the mouse and the digitizer apart or
simultaneously.
The segment editor has a Select mode, Move Points mode, Insert mode and
Split/Merge mode. The segment editor has a menu bar, a context-sensitive menu,
and a button bar.

With the segment editor, you can:
1. insert new segments and delete existing segments,
2. edit the class name, ID or value of existing segments,
3. change the position of intermediate coordinates within a segment,
4. insert new nodes with segments (split) or merge two segment with the same

code into a new segment,
5. check segments and polygonize segments.

Additionally, you can copy and paste segments to and from the clipboard, and pack
segments.

You can create and edit a segment map in the segment editor using the mouse
pointer on the screen, but you can also use the digitizer cursor when an analog
paper map is stuck on your digitizer tablet. When you want to use the digitizer for
the first time, you may have to setup the digitizer but you must reference the map to
establish a relation between received digitizer coordinates and the XY-coordinates
on your map. For more information, see also How to setup a digitizer, reference a
map and start digitizing.
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Further, in any map editor you can always use existing maps as a background by
adding these maps as other data layers to the window (see How to digitize or How
to add extra data layers to a map window).

When you want to create polygons later on, you have to make sure that all segments
are properly connected to each other by nodes. This means you have to use snap
and split and the beginnings and ends of  all segments that are supposed to be
connected with each other.

To start the segment editor
The segment editor is automatically started when you create a new segment map.

To edit an existing segment map, display the segment map in a map window, open
the Edit menu, choose Edit Layer, and select the segment layer from the cascading
menu. For more information, see How to edit point, segment, polygon, and raster
maps. Dependent segment maps cannot be edited: first break the dependency links
in the Properties dialog box of the map.

When the segment editor is started, a backup of the original segment map is
automatically made; the backup has almost the same name as the original segment
map, only the first character is replaced by a hash (#).

The Segment editor starts in Select mode: the mouse pointer appears as a hand.
When digitizer is active, the Add Segments digitizer menu also appears.

Working with the digitizer

Make sure that the digitizer is properly set up, that the paper map is properly
referenced on the digitizer tablet, and that the Digitizer command on the Options
menu in the Main window is √Active.

When in the digitizer description below, it is written that you have to press a
button, you have to press that button on your digitizer cursor which corresponds to
the number that appears in front of the mentioned option on the digitizer menu. To
press for instance the Move Points button, press that button on your digitizer
cursor which corresponds to number 3:

For more information on digitizer menus, see Appendices : Flow chart of digitizer
menus.
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To zoom in on the map
When digitizing it is very important that you zoom in on the part on which you are
currently working to ensure proper snapping and splitting. You can zoom in with
the digitizer cursor, but you can also click the Zoom in button in the button bar
with the mouse pointer.

To zoom in with the digitizer buttons:
n press the Change Window button, and move the cursor to the first corner of

the area on which you want to zoom in;
n press the 1st Point button, you now see the zoom in box tied to the first point,

then move the cursor to the 2nd position of the area you want to zoom in;
n press the 2nd Point button.

To display the entire map again:
n press the Change Window button;
n press the Entire Map button.

Adding segments
To start segments:
1. To start a segment with a loose end:

n position the cursor at the location where you to start a new segment.
n press the Begin Segment button, and move the cursor in the direction of

the segment you want to digitize.
n press the Enter Point button. You can either press this button each time you

want to insert another intermediate point or keep this button down to
automatically add intermediate points while moving the cursor along the
segment.

2. To start a segment from an existing node on an existing segment (snap):
n Position the cursor at the node;
n Press the Snap Segment button: the selected node changes its color;
n When you want to snap to another node than the one that is currently

selected, press the Snap Other button until the correct node is selected. If
necessary, first move the cursor closer to the desired node.

n Press the Accept button: your new segment is snapped to the existing node.
3. To start a segment from any other position on an existing segment (snap/split):

n Position the cursor at the desired location in the segment;
n Press the Snap Segment button;
n Press the Snap Split button;
n When you want to split the existing segment at another location, press the

Return button and repeat the previous steps until the correct location is
selected.

n Press the Accept button: the existing segment is split at the selected location
and your segment is snapped to the newly created node.

To delete intermediate points while inserting a segment:
n press the Delete Last Point button to remove the last point; continue to do so to

remove one intermediate point at a time, or
n press and hold down the Delete Last Point button and move the cursor to

delete multiple previously entered point(s).
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To end segments
1. To end a segment with a loose end:

n position the cursor at the last point of the segment.
n press the End Segment button.

2. To end a segment on an existing node on an existing segment (snap):
n Position the cursor at the node;
n Press the Snap End Segment button;
n When you want to snap to another node than the one that is currently

selected, press the Snap Other button, until the correct node is selected. If
necessary, first move the cursor closer to the desired node.

n Press the Accept button: your segment is snapped to the existing node.
3. To end at any other position on an existing segment (snap/split):

n Position the cursor at the desired location in the segment;
n Press the Snap End Segment button;
n Press the Snap Split button to split the segment: the selected point is

shown as a red box;
n When you want to split at another location in the same or another

segment, move to that location and press the Snap Split button, until the
correct location is selected.

n Press the Accept button: the existing segment is split at the selected
location and your segment is snapped to the newly created node.

n When you decide not to snap, press the No Snapping button to return
without changes.

To assign a class name, ID or value to the new segment:
Each time you end a segment, a text box will open asking for the class name, ID,
or value of the segment. Whether you can enter a class name, ID, or value depends
on the domain of the map.
n Enter a class, ID or value.
n Click OK or press Enter on the keyboard.

In case the map uses a class or value domain, the class name or value you just
entered will be the default for the next segments that you digitize.

To move a node or an intermediate point
n Press the Move Points button and position the cursor at the point you want to

move;
n Press the Take Points button to pick up the point;
 When you want to move another point than the one that is currently selected,

press the Take Points button until the correct point is selected. If necessary,
first move the cursor closer to the desired point.

n Move the cursor to the new location of the point;
n Press the New Position button to drop the point on it’s new position.

For more information on digitizer menus, refer to Appendices : Flow charts of
digitizer menus.
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Working with the mouse

To zoom in on the map
You can zoom in on the segment map by for instance clicking the Zoom In button
in the button bar. For more information, see Map window : zoom in.

To switch between Select mode, Move Points mode, and Insert mode
n select another mode from the Edit menu, or
n click one of the mode buttons in the button bar.

You can also press the Esc or the Ins key on the keyboard, see Appendices :
keyboard shortcuts.

Select mode to select existing segments
In the Select mode, the mouse pointer appears as a hand. You can select one or
more segments by clicking them, in order to change their class name, ID, or value.
n to select a segment: click it.
n when you double-click a segment, you can immediately change the class name,

ID, or value of the segment.
n to add segments to a selection: press and hold down the Ctrl key and click the

other segments you want to select. When finished, release the Ctrl key.
n to clear a part of a selection: press and hold down the Ctrl+Shift keys, then

click previously selected segments: these segments are deselected. When
finished, release the Ctrl+Shift keys.

n to toggle between select and deselect: press and hold down the Shift key, then
click segments: selected segments are deselected, and non-selected segments are
selected. When finished, release the Shift key.

To change the code of selected segments
Depending on the domain of the segment map that you are editing, you can change
the class name, identifier or value of selected segments:
n double-click a segment and select a class name or type an identifier of a value,

or
n select one or more segments, and select Edit from the Edit menu or from the

context-sensitive menu, or press the Enter key on the keyboard. In the Edit
dialog box that appears, select a class name, or type an identifer or value.
Segments in a segment map that uses an identifier domain can only be edited
individually.

When you enter an identifier that is not yet present in the domain that the map is
using, this identifier is automatically added to the domain. To enter a new class
name, select <new> from the list, this class name is automatically added to the
domain. In maps using a value domain, you cannot enter values that do not fit the
value range of that domain. For more information, see Segment editor : Edit
selection.

To delete selected segments
First make a selection and then press the Del key on the keyboard, or choose Delete
from the Edit menu or from the context-sensitive menu.
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To cut, copy and paste
To copy segments to the clipboard, make a selection and choose Copy from the Edit
menu. Segment coordinates and segment class names, identifiers or values are
copied. To paste data from the clipboard, choose Paste from the Edit menu. For
more information, see Segment editor : Copy and Segment editor : Paste. When you
select Cut from the Edit menu, the selection is copied to the clipboard and then
deleted from the map.

Insert mode to add segments to the segment map
In Insert mode, the mouse pointer appears as a pencil. In Insert Mode you can use
Autosnap (default). When Autosnap is active, the system automatically snaps to
nodes and splits when necessary, i.e. there is less need to use the Shift or the Ctrl
key as described below. You can specify a snap tolerance in pixels in the Customize
Segment editor dialog box.

To insert a new segment
n position the mouse pointer on the location where you want to start a new

segment;
n press the left mouse button to start the segment (begin node);
n hold the left mouse button down and move the mouse to automatically insert

segment coordinates (stream mode), or
n click at the positions at which you want to insert intermediate points;
n double-click or press the space bar to end the segment with a loose end (end

node).

To delete intermediate points while inserting a segment
n press the right mouse button once to delete the last point, or
n keep the right mouse button down and move the mouse to delete multiple

points, or
n press Esc to delete all points, i.e. the complete segment.

To connect a new segment to an existing node (snap)
n position the mouse pointer on the node to which you want to snap;
n when AutoSnap is inactive, press and hold down the Shift key and click the

node;
n when AutoSnap is active, you can simply click the node.

To start or end a new segment on an existing segment (snap/split)
n position the mouse pointer somewhere on a segment;
n when the AutoSnap is inactive, press and hold down the Ctrl key and click the

segment, or
n when the AutoSnap is active, click with the mouse pointer on the segment;
n a message box asks for confirmation to split the segment;
n when you answer Yes, the new segment is snapped to the new node.
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Move Points mode to change the position of a coordinate in a segment
In the Move Points mode, the mouse pointer appears as a pair of tweezers. Further,
all segment nodes appear as boxes and all intermediate coordinate pairs appear as
crosses. In the Move Points mode, you can drag individual coordinates within a
segment to a new position.

There are three ways to move a node or an intermediate point:
1. Click a begin or end node or an intermediate point;

The selected point and its segment change their color;
Move the point to another postion;
Click again to drop the point.

2. Press and hold down the left mouse button on a node or an intermediate point,
The selected point and its segment change their color;
Move the point to another postion;
Release the left mouse button to drop the point.

3. To pick up a node to which multiple segments are connected: click the node, the
node is selected and one segment changes its color;
If this is not the segment you want, do not move the mouse and click again,
until the the correct segment is selected;
Then, move the node to another postion.
Click again to drop the point.

To snap the selected point to an existing node:
n position the selected point on the node to which you want to snap;
n when the AutoSnap is inactive, press and hold down the Shift key and click or

release the left mouse button on the node;
n when AutoSnap is active, you can simply click or release the left mouse button

on the node.

To split a segment and snap to the selected point to the created node (snap/split):
n position the selected point somewhere on a segment;
n press and hold down the Ctrl key and click somewhere on the segment;
n a message box asks for confirmation to split the segment to which you want to

snap to.

Split/Merge mode to split and merge segments
In the Split/Merge mode, the mouse pointer appears as a pair of scissors.

To split a segment:
n Position the mouse pointer at the location where you want to split a segment;
n Click the left mouse button;
n A message box asks for confirmation to split the segment.

To merge two segments:
To remove a superfluous node which connects only two segments which have the
same code:
n Position the mouse pointer at the node;
n Click the left mouse button.
n A message box asks for confirmation to merge the segments.



Editors

130 ILWIS Reference Guide

Other options

To customize the segment editor
When you choose Customize from the Edit menu or from the context-sensitive
menu, you can among others indicate whether to use Autosnap or not and choose
the colors in which you want to see your segments. For more information, see
Segment editor : Customize.

To pack segments
You can permanently remove segments from a segment map, when you have
marked some segments for deletion. See Segment editor : Pack segments.

To check segments
With Check Segments you can check whether segments were correctly digitized.
You can perform a check on self overlap, dead ends, intersections and on code
consistency.

To polygonize segments
To polygonize, choose Polygonize from the File menu. During polygonization
topology is created. You can polygonize the entire segment map or a selection of
segments in the current segment map. You can create different polygon maps from
one segment map, by using a mask. When during polygonization you create a
dependent polygon map, this map can be updated (after you have made further
changes in the segment map), by clicking the Make Up-to-Date button in the
Properties dialog box of the polygon map.

When you polygonize, a check on Self Overlap, Intersections and Dead Ends is
automatically performed before the map is polygonized. If there are errors in the
segments, the operation is aborted and the errors must first be corrected. After
correction the operation can be restarted. It is therefore advised to check segments
before polygonization; in case errors are found, you have to correct these.

To exit the segment editor
To exit the segment editor, choose the Exit Editor command on the File menu or
from the context-sensitive menu or click the Exit Editor button in the button bar.
When you double-click the Control-menu box the Window closes. All changes that
you make in the segment map during this session are continuously stored.

For more information, see also Appendices : Keyboard shortcuts and Appendices :
Mouse functions.
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5.4.2 Segment editor Menu commands
File Undo All Changes

Pack
Check Segments Self Overlap...

Dead Ends...
Intersections...
Code Consistency...

Polygonize
Customize
Exit Editor

Edit Cut
Copy
Paste
Delete
Edit ...
Insert Code ...
√ Select Mode
Move Points
Insert Mode
Split/Merge Mode
Undelete Segments

Layers see Pixel editor
Options see Pixel editor
Help see Pixel editor

Context-sensitive menu
Select Area
Edit ...
Insert Code ...
Delete
Undelete Segments
Customize
Exit Editor

5.4.3 Segment editor Button bar
The button bar of the Segment editor has the same buttons as a normal map
window and some extra buttons for the different modes in the Segment editor and a
button to exit the editor.
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The following actions can be performed:

Entire Map: Displays the entire map in the map window.

Zoom In: Zooms in on a selected spot or area in the map. The mouse pointer
changes into a magnifying-glass. Click to zoom in on a spot of interest, or drag the
pointer from one corner of interest to another (the mouse pointer changes into a
little box).

Zoom Out: Zooms out directly from the center of the displayed map with a factor 2.

Larger: Enlarges the size of the window with a factor 2. If this would not fit on
your screen, this button is empty.

Smaller: Reduces the size of the window with a factor 2.

Redraw: Redraws the contents of the map window.

Select mode: Allows you to select one or more existing segments to be edited.
When in Select mode the mouse pointer appears as a little hand. Select a single
segment by clicking it; select multiple segments by holding the Ctrl key on the
keyboard; or select all segments within a rectangular area by dragging a box around
the segments of interest.

Move Point mode: allows you to select a point within a segment and drag it to its
new position. When in Move point mode, the mouse pointer appears as a little pair
of tweezers.

Insert mode: allows you to insert new segments. When in Insert mode, the mouse
pointer appears as a little pen.

Split/Merge mode: Allows you to split a segment (insert a node within a segment),
or to merge segments (delete a node between two segments with the same class
name, ID or value). When in Split/Merge mode, the mouse pointer appears as a
pair of scissors.

Exit editor: Leaves the editor and keeps all changes.

The button bar can be hidden or shown with the Button Bar command on the
Options menu. If the action of a certain button cannot be performed at a certain
moment, the button appears gray.

5.5 Point editor

5.5.1 Functionality
The point editor is used to edit a point map.

In the point editor you can work with the mouse and the digitizer apart or
simultaneously.
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The point editor has a Select mode, Move Points mode, Insert mode and
Split/Merge mode. The point editor has a menu bar, a context-sensitive menu, and
a button bar.
With the point editor, you can:
1. insert new points,
2. move points to another position,
3. delete points
4. edit the code of existing points

Additionally, you can copy points and paste points or pixels to and from the
clipboard.

You can create and edit a point map in the point editor using the mouse pointer on
the screen but you can also use the digitizer cursor when a map is stuck on your
digitizer tablet. When you want to use the digitizer for the first time, you may have
to setup the digitizer or reference the map. For more information, see How to setup
a digitizer and How to reference a map.

When the digitizer is active, the Point Editor menu. If not, reference your map
again. Depending on the digitizer set up, the numbers noted in front of a command
in the different digitizer modes, correspond with a digitizer cursor button (see How
to set up a digitizer). To activate the command, press the button. For a flowchart of
the diferent digitizer menus, see Appendix : Flow charts of digitizer menus.

Further, in any map editor you can always use existing maps as a background by
adding these maps as other data layers to the window (see How to add extra data
layers to a map window).

To start the point editor
The point editor is automatically started, when you are creating a new point map.

To edit an existing point map, display the point map in a map window, open the
Edit menu, choose Edit Layer and select the point layer from the cascading menu.
You can also open the context sensitive menu in the Catalog and select Edit. For
more information, see How to edit point, segment, polygon, and raster maps.
Dependent point maps can not be edited: first break the dependency links in the
Properties dialog box of the map.

When the editor is started, the mouse pointer appears as a little hand (Select mode).
When the digitizer is active the Edit Point menu also appears.

Working with the digitizer

When in the following part is written that you have to press e.g. the Edit Point
button, this means that you have to press the cursor button of your digitizer cursor,
which corresponds with the number in front of the Edit Point option in the digitzer
mode window. In the example, this is the cursor button corresponding with 3:
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For the readability of this part, this is kept short.

To add a point
Move the cursor to the position where you want to add a point. Press the Add point
button. When you add the first point, a text box will open. Enter the class, ID or
value corresponding with the point you want to add (depending on the Domain of
the point map that you are editing). In case of class or value, these will be default
for the next digitized points. Press Enter on the keyboard to add, click cancel in the
box or press Esc on the keyboard to return without adding.

To move a point
Move the digitizer cursor to the point you want to move and press the Move Point
button. Move the cursor to the position you want to move the point to. Press the
New position button to put the point on the desired position or press the Return
button to cancel.

To edit a point
Move the cursor to the point you want to edit. Press the Edit Point button to open a
text box. Enter the new class, ID or value (depending on the Domain of the point
map that you are editing). Press Enter on the keyboard to edit the point, or Esc to
return without changing anything.

To change the window
Press the Change Window button. Move the cursor to the first corner of the area
you want to zoom in. Press the 1st Point button, you now see the zoom in box tied
to the first point. Move the cursor to the 2nd position of the area you want to zoom
in. Press the 2nd Point button, to zoom in the area. To display the entire map after
a zoom in command, press the Entire Map button.
See also Appendix : Digitizer Modes.

Working with the mouse

To zoom in on the map
You can zoom in on the point map for instance clicking the Zoom In button on the
button bar. For more information see Map window : zoom in.

To switch between Select mode, Move Points mode and Insert mode
n select another mode from the Edit menu, or
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n click one of the mode buttons in the button bar.

You can also press the Esc or the Ins key, see Appendices : keyboard shortcuts.

Select mode to select existing points
In Select mode, the mouse pointer appears as a little hand. You can select one or
more points by clicking them, in order to change their class name, ID, or value.
n to select a single point, click it,
n when you double-click a single point, you can immediately change the class

name, ID, or value of the point.
n to select all points within an area: drag a box with the left mouse button and all

points within the box are selected.
n to add points to a selection: press and hold down the Ctrl key and click the other

points you want to select. When finished, release the Ctrl key.
n to clear a part of a selection: press and hold down the Ctrl+Shift keys, then

click previously selected points or drag a box around points: these points are
deselected. When finished, release the Ctrl+Shift keys.

n to toggle between select and deselect: press and hold down the Shift key, then
click points or drag a box around points: selected points are deselected, and
non-selected points are selected.  When finished, release the Shift key.

To change the class name, ID or value of selected points
Depending on the domain of the point map that you are editing, you can change the
class name, identifier or value of selected points:
n double-click a single point, or
n select one or more points and press Enter, or
n select one or more points, and select Edit from the Edit menu or from the

context-sensitive menu.
In the dialog box that appears, select a class name, or type an identifier or a value.
Points in a point map that uses an identifier domain can only be edited individually.

When you enter an identifier that is not yet present in the domain that the map is
using, the identifier is automatically added to the domain. When you want to enter
a class name, a list of the classes which are already in the domain appears in a text
box. You can select an existing class, a ? mark if the point is undefined or <new>
to create a new class which will be automatically added to the domain. In maps
using a value domain, you are not allowed to enter values that do not fit in the
value range of that domain. If you do so, the points will be given the value
undefined. For more information, see Point editor : Edit selection.

To delete existing points
first make a selection and then press the Delete key, or choose the Delete option
from the Edit menu or from the context-sensitive menu.

Copy points to the clipboard
Copies selected points with coordinates and class names, identifiers or values to the
clipboard (see: point editor : edit menu : copy).
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Paste from the clipboard
Pastes data from the clipboard to the map (see: point editor : edit menu : paste)

Move Points mode to move points to a new position
In Move Points mode, the mouse pointer appears as a pair of tweezers. Take a point
and drag it to a new position.

Insert mode to insert new points
In Insert mode, the mouse pointer appears as a little pencil.
Click on the position in the window where you want to insert a new point,
select a class name for this point or type an identifier or a value or for this new
point.

You can also insert a new point by typing its coordinates on the  keyboard: select
Add Point from the Edit menu or from the context-sensitive menu.

Other Options

To customize the point editor
When you choose Customize from the File menu or from the context-sensitive
menu, you can among others indicate whether to show text next to your points and
choose the symbol type and color in which your points should be displayed. For
more information, see Point editor : Customize.

To exit the point editor
To exit the point editor, choose the Exit Editor option on the File menu or from the
context-sensitive menu or click the Exit Editor button in the button bar. When you
double-click the Control-menu box the Window closes. All changes that you made
in the point map during this session are continuously stored.
For more information, see also Appendices : Keyboard shortcuts and Appendices :
Mouse functions.

5.5.2 Point editor Menu commands
File Customize

Exit Editor

Edit Cut
Copy
Paste
Delete
Edit ...
Add Point ...
√ Select Mode
Move Points
Insert Mode

Layers see Pixel editor
Options see Pixel editor
Help see Pixel editor
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Context-sensitive menu
Select Area
Edit ...
Delete
Add Point ...
Customize
Exit Editor

5.5.3 Point editor Button bar
The button bar of the Point editor has the same buttons as a normal map window
and some extra buttons for the different modes in the Point editor and a button to
exit the editor.

The following actions can be performed:

Entire Map: Displays the entire map in the map window.

Zoom In: Zooms in on a selected spot or area in the map. The mouse pointer
changes into a magnifying-glass. Click to zoom in on a spot of interest, or drag the
pointer from one corner of interest to another (the mouse pointer changes into a
little box).

Zoom Out: Zooms out directly from the center of the displayed map with a factor 2.

Larger: Enlarges the size of the window with a factor 2. If this would not fit on
your screen, this button is empty.

Smaller: Reduces the size of the window with a factor 2.

Redraw: Redraws the contents of the map window.

Select Mode: Allows you to select one or more existing points to be edited. When in
Select Mode, the mouse pointer appears as a little hand. Select a single point by
clicking it; select multiple points by holding the Ctrl key on the keyboard; or select
all points within a rectangular area by dragging a box around the points of interest.

Move Point mode: allows you to move a point to another position. Select a point
and drag it to its new position. When in Move point mode, the mouse pointer
appears as a little pair of tweezers.

Insert Mode: allows you to insert new points with the mouse. When in Insert mode,
the mouse pointer appears as a little pen.

Exit editor: Leaves the editor and keeps all changes.

The button bar can be hidden or shown with the Button Bar command on the
Options menu. If the action of a certain button cannot be performed at a certain
moment, the button appears gray.
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5.6 Domain Class/ID editor

5.6.1 Functionality
In the domain Class/ID editor you can change the class names of a domain class
map or the IDs of a domain ID map.

A class domain contains all class names used in a map, such as the names of your
soil units or the names of your land use classes, etc. An ID domain contains all IDs
for the elements in your map.
The same domain can be used for several maps.

Class names or IDs can have any length you like. You can set the width of a
domain Class or ID through the properties of the domain (see also How to view and
edit the properties of an object). By default, the width for a class domain is 15, and
for an ID domain 6 characters. Class names and IDs may contain any character you
like (capitals, small letters, spaces, underscores, etc.). However, especially if you
want to use ILWIS in combination with other packages, it is wise to limit the use of
dots ., stars *, and spaces; underscores will generally not give rise to problems.

The domain Class/ID editor consists of:
n a window in which all the class names or IDs appear and
n a menu.

To add new class names
n open the Edit menu, select the command Add Item, and
n type a new class name, or
n press the Ins key on your keyboard and enter a new class name.

To edit a class name
n select a class name in the domain editor window,
n open the Edit menu, select the command Edit Item, and
n edit the class name, or
n double-click a class name in the domain editor window and edit it.

To delete a class name
n select a class name in the domain editor window,
n open the Edit menu, select the command Delete Item, or
n select an item in the domain editor window and press the Del key on your

keyboard.

To sort class names
Class names can be sorted alphabetically and manually. If you select a class name,
you can drag it to a new position in the list. To sort alphabetically, open the Edit
menu and select the command Alphabetic Sorting.

Through the domain Class/ID editor, you can also change the representation of
classes. Open the Edit menu and select the Edit Rrepresentation command.
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To merge domains
To merge the classes or IDs of another domain into the current domain, open the
Edit menu and select the Merge Domain command.

5.6.2 Domain Class/ID editor Menu commands
File Exit

Edit Copy
Add Item ...
Edit Item ...
Delete Item
Merge domain...
Properties
Representation
√ Alphabetical Sorting
Manual Sorting

Options Status Line
Help see Pixel editor

5.7 Representation Class editor

5.7.1 Functionality
With the representation Class editor, you can change the representation of a class
domain, a group domain, or a picture domain. In the representation Class editor,
you see all the class names of this domain, and the colors assigned to these classes.
Also, you can see the patterns assigned to polygons, line widths assigned to
segments and symbols assigned to points.

The Representation Class editor consists of a central part with the class names and
their colors, a menu bar, a button bar, and Red, Green and Blue color scroll bars at
the bottom of the window.

To start the Representation Class editor, see Help topics How to create a new
representation and How to edit a representation.

General working of the Representation Class editor
1. Select a map type:

n click one of the buttons in the button bar: raster, polygon, segment,
n or point, or
n open the Options menu and select Raster, Polygon, Segment or Point.

Keep in mind that when changing a color of a class in one 'mode' (e.g.
Polygon), then the color of this class is also changed in all other modes (e.g.
Raster, Segment).
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2. Select a class and edits its color, etc.:
n double-click a class or its color box, or
n select a class or its color box and choose Edit Item from the Edit menu, or
n select a class or its color box and press Enter on the keyboard.
The Edit Repr Item dialog box appears.

In the Edit Repr Item dialog box, you can edit:
n select or create a color (raster form);
n select or create a color and select a pattern (polygon form);
n colors and line widths (segment form);
n symbol types, symbol sizes, pen widths, colors and fill colors (point form).

To edit only the colors of a selected class, you can use the Red, Green and Blue
color scroll bars at the bottom of the window.

To interactively change colors of maps
1. For maps with a class or group domain:

n Display the map in a map window; open the Layers menu, choose the
Double-Click Action command, and select the Edit Representation option;

n Then, double-click the units in the map: each time a Edit Repr Item dialog
boxes appears in which you can directly change colors, patterns, etc.;

n Redraw  the map window to apply the changes;
n Continue editing colors and redrawing the map until satisfied.

For more information, see Map window : advanced functionality.

2. For maps with a class, group or value domain:
n Display a map with a class, group or value domain in a map window; open

the map's representation by selecting the Representation command on the
Edit menu in the map window;

n One of the representation editors appears, edit one or more colors;
n Keep the editor open and switch to the map window;

n Redraw  the map window to apply the changes;
n Continue editing colors and redrawing the map until satisfied.
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5.7.2 Representation Class editor Menu commands
File Exit

Edit Edit item (Raster)
Edit item (Polygon)
Edit item (Segment)
Edit item (Point)
Properties

Options Raster
Polygon
Segment
Point
Column Width...
Button Bar
Status Line

Help see Pixel editor

5.7.3 Representation Class editor Button bar
The buttons in the button bar of the Representation Class editor allow you to select
a map type. This shows the representation as if this representation was used by that
map type.

Every class name has one color. Each pixel, polygon, segment, point with that class
name uses that color. Further, polygons, segments, and points have some other
representation characteristics.

The following actions can be performed:

Raster Map: Edit the colors of this representation as used to display a raster map.

Polygon Map: Edit the colors and patterns of this representation as used to display
a polygon map.

Segment Map: Edit the colors and line widths of this representation as used to
display a segment map.

Point Map: Edit the colors and symbols of this representation as used to display a
point map.

The button bar can be hidden or shown with the Button Bar command on the
Options menu.



Editors

142 ILWIS Reference Guide

5.8 Representation Value/Gradual editor

5.8.1 Functionality
The Representation Value/Gradual editor allows you to change the representation
of a map that uses a value domain. In the Representation Value/Gradual editor, the
values of the domain that uses this representation are called boundary values or
limits. The general idea is that you insert limits, assign colors to limits and that you
choose a coloring method for the values in between two limits.

To start the Representation Value/Gradual editor, see Help topics How to create a
new representation and How to edit a representation.

Parts of the Representation Value/Gradual editor
n The Representation Value/Gradual editor has a menu bar.
n In the editor, you see values or percentages on the left, and colors on the right

side of the window.
– Percentages are shown when you create a new representation for a map

using the system domain Value, or when you edit an existing representation
gradual;

– Values are shown when you create a new representation for a map with any
value domain, except the system domain Value, or when you edit an existing
representation value.

These values or percentages in the representation Value/Gradual editor are
called boundaries or limits.

n At the bottom, you see a color bar which gives an overview of how all colors are
assigned to the values of the domain.

General working of the Representation Value/Gradual editor
In general, in the representation Value/Gradual editor, you can:
n insert and delete limits,
n change the color assigned to limits,
n change the value of limits,
n change the coloring method of values in between two limits.

To change the color or the value of a limit
n double-click a limit, or
n select a limit and press Enter on the keyboard, or
n select a limit and, from the Edit Menu, choose Edit Limit.
In the appearing Edit Limit dialog box, you can select new color for this limit. You
can also change the value or percentage of the limit.

To insert a limit
n press Ins on the keyboard, or
n from the Edit Menu, choose Insert Limit.
In the appearing Insert Limit dialog box, you can fill in a new value (percentage or
value) for the limit, and you can select a color for this limit.
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To delete a limit
n select a limit and press Del on the keyboard, or
n select a limit and, from the Edit Menu, choose Delete Limit.

To choose a coloring method for values/percentages in between two limits
For values or percentages in between two limits there are three possibilities:
1. colors either range from the color of the limit below to the color of the limit

above (stretch), or
2. they have the same color as the limit below (lower) or
3. they have the same colors as the limit above (upper).

To change the coloring of value/percentages in between two limits:
n double-click in between two limits, or
n select a limit or color and press Enter on the keyboard, or
n select a line in between limits and, from the Edit Menu, choose Edit Limit.
So, when starting from stretch, one double-click results in a change to the color of
the upper limit, another double-click results in the color of the lower limit, and yet
another double-click results in stretch again.

To change the number of colors in between two limits
n From the Edit menu, choose Stretch Steps.

In the appearing Stretch Steps dialog box, enter a value for the number of colors
that should be used in between two limits.

To interactively change colors of value maps
n Open a map with a value domain in a map window, open the map's

representation by selecting the Representation command on the Edit menu of
the map window;

n The Representation Value/Gradual editor is opened; insert limits, edit colors,
etc.;

n Keep the editor open and switch to the map window;

n Redraw  the map window to apply the changes;
n Continue editing colors and redrawing the map until satisfied.

5.8.2 Representation Value/Gradual editor Menu commands
File Exit

Edit Insert Limit ...
Edit Limit ...
Delete Limit
Stretch steps...
Properties

Options √ Status Line

Help see Pixel editor
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5.9 Georeference Tiepoints editor

5.9.1 Functionality
With the tiepoint editor you can create a georeference tiepoints. A georeference
tiepoints stores the relation between user-indicated points in a raster map or image
(row,col) and coordinates (X,Y). These user-indicated points are called tiepoints or
control points.

The tiepoint editor displays a raster map and existing tiepoints in a map window.
Further, the Row, Column values, and X and Y coordinates of existing tiepoints are
displayed in a table in a secondary window. The tiepoint editor has a menu bar, a
button bar, a status line and a context-sensitive menu.

Purpose of a georeference tiepoints
A georeference tiepoints is mostly used to add coordinates to a satellite image or
another map which is not North-oriented and/or in which the pixels do not
represent exactly square areas on the ground. One georeference tiepoints should be
used for all bands of an image.

When you added tiepoints to an image, you can:
n display any type of vector data on top of the map;
n create or update vector data using the georeferenced image as background (on-

screen interpretation);
n use the map in pixel info;
n when you have raster maps of different sources or images of different dates and

you want to perform raster operations to combine these maps or images (e.g.
MapCalc, Cross), first create a georeference tiepoints for each set of
maps/images, then use the Resample operation and resample the maps/images
preferably to a georeference corners;

n when you want to combine rasterized vector maps with satellite data, you can
rasterize the vector data on the georeference tiepoints of the satellite images. In
case you prefer North-oriented raster maps, rasterize the vector maps with a
georeference corners, and Resample the images with the georeference tiepoints
to this georeference corners.

Inserting tiepoints
In the tiepoint editor, tiepoints can be added to a map in several manners:
n first, click at a recognisable point in the map without coordinates,
n the Add Tie Point dialog box appears. In this dialog box, the row and column

values at the position of the click are filled out.
When you already have some tiepoints, the dialog box will also come up with a
suggestion for the XY-coordinates. This suggestion is the result of the
calculation with the existing tiepoints and using the current transformation
method. This suggestion is a measure of the quality of the current tiepoints.
The suggestion is merely a suggestion, it is advised to enter your own XY-
coordinates to prevent false accuracy.
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Then:
n click at the same position in a map which already has correct XY-coordinates

and which is displayed in another map window (master/slave), or
n digitize the same point in an analog paper map which is stuck on a digitizer, or
n read the correct XY-coordinates for this point from a table or an analog paper

map, and type these XY-coordinates in the dialog box.

(De)selecting tiepoints
Column Active in the tiepoint table indicates whether or not a tiepoint is used in
the transformation. Include tiepoints by the putting True in column Active;
exclude tiepoints by putting False in column Active. You can type T or F in
column Active or use the space bar to switch between these.

Selecting a transformation method
In the tiepoint editor, one of the following transformation methods can be selected:
conformal, affine, second order bilinear, full second order, third order and
projective. Information is displayed on the deviation (in pixels) of each tiepoint to
calculated values, also sigma is displayed. Usually, for satellite images an affine
transformation will do, and for oblique photographs a projective transformation can
be selected.

Inspecting DRow, DCol and Sigma
Columns DRow and DColumn show the difference between calculated Row and
Col values and actual Row and Col values in pixels. Very good control points have
DRow and DCol values less than 2. Sigma is calculated from these values and the
degrees of freedom, and gives a measure for the overall accountability or credibility
of the active tiepoints.

F When you have already a vector map of the area of the image, it can be handy to
display this vector map on top of the image while working with the tiepoint editor.

F When you now add tiepoints to the image and press the Redraw button , you
can judge the quality of the tiepoints.
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5.9.2 Georeference Tiepoints editor Menu commands
File Exit Editor

Edit Copy
Paste
Delete
Add Tie Point ...
Delete Tie Point...
Transformation
Customize

Layers see Pixel editor
Options see Pixel editor
Help see Pixel editor

Context-sensitive menu
Select Area
Add Tie Point ...
Delete Tie Point...
Transformation
Customize
Exit Editor

5.9.3 Georeference Tiepoints editor Button bar
The button bar of the georeference tiepoints editor largely resembles the button bar
of a map window but there are some extra buttons to add a tiepoint, to delete a
tiepoint, to choose a transformation method and to exit the editor.

The following actions can be performed:

 Entire Map: Displays the entire map in the map window.

 Zoom In: Zooms in on a selected spot or area in the map. The mouse pointer
changes into a magnifying-glass. Click to zoom in on a spot of interest, or drag the
pointer from one corner of interest to another (the mouse pointer changes into a
little box).

 Zoom Out: Zooms out directly from the center of the displayed map with a factor 2.

Larger: Enlarges the size of the window with a factor 2. If this would not fit on
your screen, this button is empty.

 Smaller: Reduces the size of the window with a factor 2.

Redraw: Redraws the contents of the map window.
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Add tiepoint: Opens the Add Tiepoint dialog box in which you can enter Row and
Column numbers and XY-coordinates for a new tiepoint from the keyboard. You
can also add tiepoints by clicking in the map window, or by typing the Row and
Column numbers and XY-coordinates directly in the tiepoint table.

 Delete tiepoint: Opens the Delete Tiepoint dialog box in which you can specify the
the number of the tiepoint you want to delete. You can also delete one or more
tiepoints by selecting records in the tiepoint table, then press the Del key on the
keyboard or choose Delete from the Edit menu.

 Transformation method: Opens the Transformation dialog box in which you can
select a transformation method with which the relation between Row and Column
values and the XY-coordinates of your tiepoints should be calculated.

 Exit editor: Leaves the editor and keeps all changes.

The button bar can be hidden or shown with the Button Bar command on the
Options menu. If the action of a certain button cannot be performed at a certain
moment, the button appears gray.

5.10 Georeference 3D editor

5.10.1 Functionality
With the georeference 3D editor, you can edit a georeference 3D and obtain a 3D
view of your study area according to your wishes. The georeference 3D editor
consists in fact of one dialog box in which you can edit 3D view parameters.
Further, the georeference 3D editor has a menu bar, a context-sensitive menu and a
button bar.

To start the georeference 3D editor
To create a new georeference 3D, you need first of all an interpolated height map
(Digital Elevation Model/Digital Terrain Model). For more information on
obtaining a DEM, see How to calculate a DEM.
Select for instance the Create Georeference command on the File menu of the Main
window. In the appearing dialog box, select the option button Georeference 3D and
select the height map and specify the size of the map window in which your 3D
view will be displayed. After the Display Options - 3D Grid dialog box, a map
window is opened showing an initial 3D view. In the map window, select
Georeference from the Edit menu to start the georeference 3D editor.

To edit an exisitng georeference 3D, you can double-click a georeference 3D in the
Catalog. After the Display Options - 3D Grid dialog box, a map window is opened
showing your 3D view. In the map window, select Georeference from the Edit
menu to start the georeference 3D editor.
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In the Display Options - 3D Grid dialog box, you can specify whether you want to
see the 3D view as grid lines with or without a drape of a raster map.

For more information on creating a georeference 3D, refer to How to create a 3D
view.

Parameters of a georeference 3D or a 3D view

Figure 1: This picture shows you a simplified overview of how the relationship between the observer
and the terrain is determined.

The options in the Georeference 3D dialog box are shortly described below.

View Angle:
The View Angle is an angle in degrees which defines the aperture of the observer's
sight, i.e. how much you can see of your 3D model.
n When the view angle is small, only a small area of the total 3D view is

observed, with the view point as the middle of the observed area.
n The larger the angle, the larger the area that is observed.
n A maximum of 180° is allowed.

Scale Height:
The Scale Height defines how much the altitude (Z) should be exaggerated
compared to the XY-scale.
n A scale height of 1 means no height exaggeration.
n A scale height  > 1 means that vertical exaggeration is increased.
Note that when you increase the scale height, more parts of your study may fall
behind exaggerated parts and can thus no longer be seen.
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View Point:
The View Point is the XY-location you want to look at. The Z-coordinate of this
point is defined by the DEM. The view point will be drawn in the center of the map
window.

Horizontal Rotation:
The Horizontal Rotation is an angle in degrees to rotate the 3D view anti-clock
wise from the south-north direction.
n When 0° is specified, the 3D view is orientated south-north. The observer is

located to the south of the DEM.
n When 90° is specified, the 3D view is oriented west-east. The observer is

located to the west of the DEM.
n When -90° is specified, the 3D view is oriented east-west. The observer is

located to the east of the DEM.

Vertical Rotation:
The Vertical Rotation is an angle in degrees away from a vertical through the
terrain.
n When 0° is specified, the line of sight is perpendicular to the 3D view; the

observer is located high in the sky and looks straight down on the 3D view.
n When 90° is specified, the line of sight is parallel to the 3D view; the oberver is

located on the same height as the view point and sees the 3D view in front of
him.

Distance:
The Distance is the distance between the observer and the view point.
n When a large distance is specified, you get a general overview of the observed

3D view.
n To observe the 3D view in detail, you should decrease the distance.

Location Point:
The Location Point is the location of the observer in XY-coordinates.

Location Height:
The Location Height is the altitude of the observer.

All changed parameters are immediately stored in your georeference 3D. To see the
effect of changed view parameters, you need to redraw the map window: click the

Redraw button  in the button bar of the map window, or press Ctrl+R on the
keyboard.
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Effects of changing 3D view parameters
The different view parameters are illustrated in the figures below.

Figure 2: Reference situation. The observer
is standing almost in front of the DEM 
looking towards the north.

In the following four pictures, only one parameter is changed.
In the last picture a number of parameters are changed.

       

Figure 3: The vertical rotation is
decreased from 82° to 40°. The observer
looks more upon the DEM.

Figure 4: The horizontal rotation is
changed from 0° to 30°. The observer is
looking into the north-west.

       

Figure 5: The view angle is decreased
from 90° to 60°. The observed part of the
DEM became smaller.

Figure 6: The view angle is increased to
120°. The observed part of the DEM
became larger.
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Figure 7: Several parameters are changed, 
including the view point. In this way, you can 
find an 'optimal' 3D view, depending on the 
purpose.

It is advised to adjust:
n the View Angle, until you see your whole study area in the map window,
n the Vertical and Horizontal Rotation, until you see your area from a favourable

position,
n the View Point, until the 3D view is nicely positioned in the map window,
n the Scale Height, to exaggerate height differences,
n or other parameters as you wish.

F The 3D view parameters are not independent. When you change one parameter,
some others may automatically change as well. When you edit the values of the
view point, horizontal rotation, vertical rotation or distance, the values of the
location point and/or location height of the observer automatically change, and vice
versa.

To exit the georeference 3D editor
To close the georeference 3D editor and return to the map window, click the Exit
editor button in the button bar, choose Exit from the File menu, or double-click the
control-menu box of the dialog box. Your 3D view is displayed in the map window.
The parameters last used in the editor are stored in the georeference 3D.

As the map window now uses this georeference 3D, you can also add other vector
maps to improve the 3D view. Of course, you can also add annotation.

To save the 3D view
To save the 3D view in the map window, choose the Save View or the Save View
As command from the File menu in the map window.
To permanently display a raster map with a georeference 3D, you can use the Apply
3D operation.
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5.10.2 Georeference 3D editor Menu commands

File Exit editor

Edit Edit

Context-sensitive menu
Select Area
Redraw
Layer Management

5.10.3 Georeference 3D editor Button bar
The picture below shows the button bar of the Georeference 3D editor.

The following actions can be performed:

Entire Map: Displays the entire 3D view in the map window.

Zoom In: Zooms in on a selected spot or area in the 3D view. The mouse pointer
changes into a magnifying-glass. Click to zoom in on a spot of interest, or drag the
pointer from one corner of interest to another (the mouse pointer changes into a
little box).

Zoom Out: Zooms out directly from the center of the displayed map with a factor 2.

Larger: Enlarges the size of the map window with a factor 2. If this would not fit
on your screen, this button is empty.

Smaller: Reduces the size of the map window with a factor 2.

Redraw: Redraws the contents of the map window.

Exit editor: Leaves the editor and keeps all changes.

The button bar can be hidden or shown with the Button Bar command on the
Options menu. If the action of a certain button cannot be performed at a certain
moment, the button appears gray.

5.11 Sample set editor

5.11.1 Functionality
In the sample set editor you can select sample pixels also called training pixels for
certain classes prior to an image classification. The sample set editor has a menu
bar, a context-sensitive menu, a button bar and a status line.
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Sampling creates a sample set which is needed for a multi-spectral image
classification. Sampling is the assignment of class names to groups of pixels which
have similar spectral values and that are supposed to represent the classes that you
want to obtain from the classification. The sampled pixels or training pixels are
thus supposed to be characteristic for a certain type of a natural resource. For
instance, to perform a land use classification, you might sample the classes: forest,
grass land, arable land etc.

Requirements
For sampling you need an image which can be easily interpreted (e.g. a color
composite), a map list, that is the set of images which you want to classify in a later
stage, and a class domain containing the set of class names that you want to assign
to training pixels. All maps must have the same georeference (or georef none).

To start the sample set editor, refer to Help topic How to create a sample set.

General working of the sample set editor
n select one or more pixels on the 'background' image
n assign a class name for the selected pixels
n view sample statistics
n view feature spaces

During sampling, you probably need to zoom in on the map. You can still add new
classes to the domain while sampling. It is advised to use the same domains as far
as possible (not every class has to be used).

F If you have an existing map of the area, you can add this map to the pixel info
window. This may help you to select training pixels during sampling.

F You can create dependent output maps with the Classify operation (various
methods, various parameters) using the current sample set as input. When you add
these dependent maps to the pixel info window, you may already see the results of
classifying during sampling.
As pixel info works on XY-coordinates in maps, all maps should be georeferenced.

Selection of pixels
n to select a pixel, click it; or move the pixel selection cursor with the arrow keys

on the keyboard and press the space bar;
n to select all pixels within a selected area: drag a box with the left mouse button.

All pixels in the box are selected;
n to add pixels to a selection: press and hold down Ctrl and click the pixels you

want to select. When finished, release the Ctrl key.
n to clear a part of a selection: press and hold down Ctrl+Shift, click pixels or

drag a box around pixels: these pixels are deselected. When finished, release the
Ctrl+Shift keys.

n to toggle between select and deselect: press and hold down Shift, click pixels or
drag a box around pixels: selected pixels are deselected, and non-selected pixels
are selected. When finished, release the Shift key.

Inspect the Sample Statistics to see the statistics of the current selection.
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Assignment of a class name to a selection
n double-click a pixel and choose a class name from the list, or enter a new class

name, or
n select multiple pixels, press the right mouse button and select Edit from the

context-sensitive menu. In a small dialog box that appears you can choose a
class name from the list or enter a new class name.
Instead of using the context-sensitive menu, you can also choose Edit from the
Edit menu in the normal menu bar.

When a new class is added, also a color can be selected. Class names in the domain
that you are using can be as long as you want: set the width of the domain through
the properties of the domain. Sampled pixels appear in the color of the assigned
class in the background map; when you move the mouse over a sampled pixel, the
statusline shows the class name of the pixel.

View Sample Statistics
Sample Statistics are displayed in a separate window. In the upper half of the
window, you can select a class name, then some statistics are calculated for the
training pixels belonging to this class: mean, standard deviation, number of pixels
with the predominant value, predominant value, and total number of training pixels
belonging to this class. In the lower half of the Sample Statistics window, statistics
are shown for currently selected pixels.

View Feature Spaces
To view a feature space, press the right mouse button in the sample set editor, and
select Feature Space from the context-sensitive menu. You can also click the
Feature Space button in the button bar, or choose Feature Space from the normal
Edit menu. Select which bands you want to be displayed by the feature space.
You can open as many feature spaces as you like, but as each of them is updated
after a new selection of training pixels, speed may decrease. Feature spaces can be
shown with or without additional grid lines, can be copied to clipboard and printed.

On the basis of the sample statistics and the feature spaces, you can for instance
decide to sample more training pixels of a certain class, merge classes with too
much overlap, delete classes, etc.

Exit the sample set editor
To exit the sample set editor, double-click the Control-menu box of the sample set
editor window or the sample statistics window. You can also click the Exit Editor
button in the button bar, or choose Exit from the File menu in the sample set editor.

To merge existing classes
When two classes of training pixels are found very similar, based on the Sample
Statistics and the Feature Spaces, you may decide to merge these classes.
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In fact, training pixels of one class are merged together with the training pixels of
another class.
n from the Edit menu or from the context-sensitive menu, choose Merge Classes.

The Merge Classes dialog box appears.

To assign training pixels to another class
n reselect the pixels that you to assign to another class, and
n from the Edit menu or from the context-sensitive menu, choose Edit.

The Edit Pixels dialog box appears. Assign the desired class to the selected pixels.

To rename a class
Renaming classes can be done in the domain Class editor. Open the domain from
the Main window, and edit a class name into another class name. For more
information, see also How to edit a domain and Domain Class/ID editor.

To delete one or more pixels from a class of training pixels
When by mistake some pixels were sampled and assigned to a certain class, you can
remove these from the class by reselecting these pixels and assigning them the
undefined value.
n in the sample set editor window, select the pixels that you want to remove from

the class, and
n from the Edit menu or from the context-sensitive menu, choose Edit.

The Edit Pixels dialog box appears. Assign the undefined value (?) to the selected
pixels.

To delete a whole class of training pixels
n from the Edit menu or from the context-sensitive menu, choose Delete Class.

The Delete Class dialog box appears, select a class of training pixels to be deleted.
Training pixels of the selected class are removed from the sample set, but the class
remains in the domain. To also remove the class from the domain, first delete the
training pixels of the class, then delete the class from the domain in the domain
Class/ID editor.

To change the color of a class
n from the Edit menu, choose Representation.

The Representation Class editor is opened where you can edit the colors of the
classes.



Editors

156 ILWIS Reference Guide

5.11.2 Sample set editor Menu commands
File Open Pixel Information

Exit Editor

Edit Cut
Copy
Paste
Delete
Edit ...
Feature Space ...
Delete Class ...
Merge Class ...
Representation

Layers see Pixel editor
Options see Pixel editor
Help see Pixel editor

Context-sensitive menu
Select Area
Edit ...
Feature Space ...
Delete Class ...
Merge Class ...
Legend
Representation
Exit Editor

5.11.3 Sample set editor Button bar
The button bar of the sample set editor largely resembles the button bar of a normal
map window; there are extra buttons to open feature spaces, to obtain a legend of
the classes of training pixels and to exit the editor.

The following actions can be performed:

Entire Map: Displays the entire map in the map window.

Zoom In: Zooms in on a selected spot or area in the map. The mouse pointer
changes into a magnifying-glass. Click to zoom in on a spot of interest, or drag the
pointer from one corner of interest to another (the mouse pointer changes into a
little box).

Zoom Out: Zooms out directly from the center of the displayed map with a factor 2.

Larger: Enlarges the size of the window with a factor 2. If this would not fit on
your screen, this button is empty.
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Smaller: Reduces the size of the window with a factor 2.

Redraw: Redraws the contents of the map window.

Feature Space: Opens the Feature Space dialog box to display a new feature space.
A feature space visually shows the separation of classes of sampled pixels. You can
open as many feature spaces as you like.

Legend: Shows a legend of the classes of sampled training pixels in a secondary
window.

Exit editor: Leaves the editor and keeps all changes.

The button bar can be hidden or shown with the Button Bar command on the
Options menu. If the action of a certain button cannot be performed at a certain
moment, the button appears gray.

5.12 Annotation editor

5.12.1 Functionality
The Annotation editor allows you to insert new annotation, and to position, size
and change display options of existing annotation. The Annotation editor has a
button bar and a context-sensitive menu.

Annotation that can be handled by the Annotation editor includes:
n texts, legends, boxes, North arrow, scale bar, grid lines, graticule, bitmaps or

metafiles (pictures) from disk,
n ILWIS maps copied to the clipboard, can be pasted as a picture into another

ILWIS map window,
n any picture or bitmap copied into the clipboard from another Windows

application program can be pasted into an ILWIS map window.

For more information, see How to add annotation to a map window.

To start the Annotation editor
The Annotation editor is automatically started when a new annotation layer is
added to a map window. To start the Annotation editor from a map window, open
the Edit menu and choose Annotation.

To insert more annotation
n click one of the add annotation buttons in the button bar of the Annotation

editor (the status line gives an explanation), or
n press the Ins key on the keyboard, or
n click the right mouse button in the map window, and choose Add Annotation

from the context-sensitive menu, or
n from the Layers menu, choose Add Annotation, or
n from the Layers menu, choose Layer Management and click the Add

Annotation button.
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To change the display options of an annotation layer
In the Annotation editor, you can double-click texts, legends, boxes, a scale bar, a
North arrow, bitmaps and pictures: a Display Options dialog box appears in which
you can directly change the settings of the double-clicked 'object'. Grid lines or a
graticule cannot be double-clicked.

To obtain a Display Options dialog box, you can also:
n open the Layers menu, choose Display Options and select an annotation
 layer, or
n select an annotation layer by clicking it, and press the Enter key on the

keyboard, or
n open the Layers menu and choose Layer Management. The Layer Management

dialog box appears, or
n click the right mouse button in the map window from the context-sensitive

menu and choose Layer Management. The Layer Management dialog box
appears.

In the Layer Management dialog box, select an annotation layer and click the
button 'Display Options', or simply double-click an annotation layer. A Display
Options dialog box appears in which you can change the settings of the selected
layer.

F After changing display options of an annotation layer, you might need to redraw

the map window: click the Redraw button .

To position annotation
n click an annotation 'object' with the left mouse button, and hold the left mouse

button down,
n drag the selected annotation 'object' to another location,
n then release the left mouse button.
Grid lines and a graticule depend on the georeference of the map window and can
only be positioned by changing their display options.

To size annotation
n select an annotation 'object' by clicking it: the borders of the annotation become

visible,
n position the mouse pointer on one of the 2, 4 or 8 size handles (little black

blocks appearing at  the annotation borders),
n drag the size handle to a new position.
Dragging one of the corner handles maintains the original ratio of height to width
ratio. Dragging one of the middle handles resizes the annotation horizontally or
vertically; the height to width ratio changes.
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To delete an annotation layer
n select an annotation layer by clicking it: the borders of the annotation becomes

visible,
n press Del on the keyboard, or
n click the right mouse button and choose Delete from the context-sensitive menu.

You can also delete an annotation layer through Layer Management.
Grid lines or a graticule can only be deleted through Layer Management.

To save annotation
When finished editing annotation, you can save the map window as a map view. In
the Annotation editor or in the map window, open the File menu, and choose the
Save View command or the Save View As ... command.

To exit the annotation editor
n double-click the Control-menu box, or

n in the button bar, click the Exit Editor button , or
n choose from the File menu, choose Exit Editor.

F To create more space in a map window for annotation, select the Extend Window
command from the Options menu. In the Annotation editor, you can also choose
Extend by Percentage or Extend by Coordinates from the context-sensitive menu.

F When pasting a bitmap into an ILWIS map window which displays a map that
already uses 256 colors, the pasted bitmap may loose its colors. When this occurs,
you might consider using 16 color bitmaps.

5.12.2 Annotation editor Menu commands
File Save View

Save View As...
Exit Editor

Edit Cut
Copy
Paste
Delete
Add Annotation ...

Layers see Pixel editor
Options see Pixel editor
Help see Pixel editor

Context-sensitive menu
Select Area
Extend by percentage...
Extend by coordinates...
Add Annotation ...
Delete
Layer Management
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5.12.3 Annotation editor Button bar
As the button bar of the Annotation editor is quite long, it is displayed here in two
parts. The first part is identical to the button bar of a map window. The second part
are the special buttons of the Annotation editor and are used to add more
annotation to the map window. If your map window does not show all buttons, you
can zoom in and then size the map window by dragging its right border.

The following actions can be performed:

Entire map: Displays the entire map in the map window.

Zoom In: Zooms in with a factor of 2 on a selected spot or area in the map. The
mouse pointer changes into a magnifying-glass. Click somewhere in the map to
zoom in on this spot, or drag the mouse pointer from one corner of interest to
another (the pointer changes into a little box).

Zoom Out: Zooms out directly from the center of the displayed map with a factor 2.

Larger: Enlarges the size of the window with a factor 2. If the enlarged window
would not fit on your screen, this button is empty.

Smaller: Reduces the size of the window with a factor 2.

Redraw: Redraws the contents of the map window.

Add Text: Add a text as an extra annotation layer to the window. The Display
Options -Text dialog box follows.

Add Legend: Add a legend as an extra annotation layer to the window. If you have
multiple data layers in your map window, the Map Layer Selection dialog box
follows. Further, the Display Options - Legend (Class) dialog box follows when you
want to add a legend of a class map and the Display Options - Legend
(Image/Value) dialog box follows when you want to add a legend to a value map.

Add Grid Lines: Add grid lines, a map border or only coordinates as text as an
extra annotation layer to the window. The Display Options - Grid Lines dialog box
follows.

Add Graticule: Add a graticule as an extra annotation layer to the window. The
Display Options - Graticule dialog box follows.
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Add Box: Add a box as an extra annotation layer to the window. The Display
Options - Box dialog box follows.

Add Scale Bar: Add a scale bar as an extra annotation layer to the window. The
Display Options - Scale Bar dialog box follows.

Add North Arrow: Add a North arrow as an extra annotation layer to the window.
The Display Options - North Arrow dialog box follows.

Add Bitmap or Picture: Select a bitmap or a Windows metafile (picture) from disk
and add it as an extra annotation layer to the window. The Add Bitmap or Picture
dialog box follows.

Exit editor: Leaves the Annotation editor and returns to the map window.

The button bar can be hidden or shown with the Button Bar command on the
Options menu. If the action of a certain button cannot be performed at a certain
moment, the button appears gray.

F To save annotation, you need to save the map window as a map view: open the File
menu in the Annotation editor or in the map window, and choose the Save View or
the Save View As command.




