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Tutorial 1: Getting Started using Ilwis Open & GEONETCast Toolbox

Chris Mannaerts & Ben Maathuis

Department of Water Resources, Faculty of Geo-Information Sciences and Earth observation (ITC), University of Twente (UT), Enschede, The Netherlands

Objectives

In this first hands-on tutorial, you will get acquainted with the llwis Open software: the windows, the
menu and file system and types, and how to perform operations. Also some important map and service
objects in llwis are reviewed. The llwis Help Menu is the most useful source for rapid learning and
understanding of the system, and one saying remains valid like in sports: “the more you train, the more
you gain”.

The Ilwis Main Window

The main window of ILWIS is made of the navigator and operation tree/list on the left side, one or more
catalogues on the right, the command line, the menu and some quick access button bars. In this exercise
we will explore the various options you have with these tools. For this Ilwis getting started training, we
use the basic llwis demonstration dataset (Cochabamba, Bolivia) available on http://52north.org (Ilwis

main open source download website) and GEONETCast MSG data [pls. see workshop for data].
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Navigation
Select in the left panel the tab labelled ‘Navigator’
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Use the navigator to go the correct location for the data. If you already have a catalogue open it will fill
the catalogue with the folder you have current selected. If you don’t have a catalogue open select the
desired catalogue and use the right-button menu and select ‘New Catalog’. A new catalogue will open
and be filled with the data in that folder.

Views on the Catalog
The Catalog has several ways of filtering to limit the number or kind of objects you see. First of all there
is the button bar.
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First of all there is the option to view everything in List (icons only) or Details view. Just toggle between
the buttons to see the difference.

Second there is the lower button bar. This simply filters on type of object. Is the button down then
everything of that type is shown, is the button up than that type is not visible in the catalogue. The first
button toggles all buttons on or off. Just press some of the buttons to see the difference.

Opening maps
Let’s now open the raster map tmb1. Double click (or right click and use the right button menu) the icon
ERTmbT . When it opens you get a ‘Display options’ dialog. You can overrule the defaults but let’s

accept them for the moment and press ‘OK’.

You should see a window that looks like
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On the left we see the layer overview (one layer now), on the right the map pane. The top contains a
button bar with some commonly used actions. When you move the mouse over the map and press the
left button you can see the values of the map. Below you will see the world location and pixel location(s)
of the mouse cursor. Ps. You look now at a Ilwis quick learning data set of Cochabamba, Bolivia.

You can add other maps in various ways but for the moment let’s take the simplest and select contour

segment map (Ej Contour ) from the catalogue and drag this onto the map pane or layer pane (doesn’t
really matter). We again get a display options form and press ‘OK’. The map window should then look
like, the map on the right side (above). An unlimited number of layers can be added this way.

Select from the ‘File’ menu the entry ‘Open Pixel information’. You get a small window looking like
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When you move the mouse over the map pane these values will constantly update to reflect the values
of location of the mouse cursor for all layers.

Where are this data from or which location is this?

You may ask yourself what images and data you are looking at? llwis is a global GIS system, so to find
out, you can display the world country vector map (supplied), and then plot (using Add Layers from the
Map Window Menu) some Cochabamba vector maps (e.g. catchment.mps). Then zoom-in to central
Latin America, central Bolivia and find your location of the RS ad GIS data (approx. lat-lon: 17N — 66W).
llwis permits any geographic data window to be displayed using an appropriate coordinate system and
georeference window. Have also a look at the 3D-view of Cochabamba (see workshop).



WFP — DRMFSS — NMA — ITC project: GEONETCast Toolbox for Water & Food Security Training Workshop, Addis Ababa, March

05-09 2012

Operations

ILWIS contains many analytical operations. Most of them are in the raster and vector domain. Accessing
the operations can be done through the main menu ‘Operations’, by right clicking a data object. You
then get the operations appropriate to that type of object or by using the operation tree/list.

Menu RMB Menu Operation tree

GILTERGEN Yiew  Window

DEM hydro-processing b |
Image Processing 13

1 Impart/Export v
j Interpolation 3 |
Raster Operations 3
{ Rasterize 3
SEBS Tools [
Bl Statistics 4 M___
% Table Operations 3 Correlation Matrix
! Yeckor Operations » Points » Factar Analysis
'_' Wectarize 3 Polygons  » IMaplist Graph 1
1 Wisualization » Raster » Maplist Statistics
i 3 13 Principal Components

Scripk Segments

Variance-Covariance Matrix

Ilwis Objects

BT Open
T DEM hydro-processing  »
BT Image Processing »
Export..,
Interpolation »
taste eratio 4 Agaregate Map...
SEBS Tools » Area Numbering. .,
Statistics » Attribute Map...
Vectorize 4 Cross...
Properties Distance Calculation. ..
Effect Distance..,
®  Edit "
Capy il Glue Maps...,
Iteration...
Delete pel Mirror Rotate. ..
Hep Sub Map...

Ilwis also makes use of several objects of different types and functions > see Help Menu Basic concepts

There are several types of ILWIS cobjects: data objects,
container objects, service objects, and special objects.
Click the next link to get a list of all ILWIS objects and their
icons in a secondary window.

Data objects are point, segment, polygon and raster maps,
satellite images, tables and columns; that are the GIS/RS
materials to work with. Maps can be displayed and edited in a
map window, tables and columns in a table window. You can
perform calculations and operations on data objects.

Data objects are:
EX raster maps (containing pixels)

B polygon (containing area features)
maps

B segment (containing line features)
maps

ER point maps  (containing point features)

M tables (containing columns)

Basic concepts
ILWIS objects and icons

Data objects are:

B raster maps (containing pixels)

B polygon (containing area features)
maps

B segment (containing line features)
maps

point maps (containing point features)

@ tables (containing columns)

M columns (not listed in Catalog)

In the llwis Help Basic Concepts, you can find information what all the Ilwis icons mean.

Container objects are:

object collections
map views
layouts
annotation text
k< graphs

Container objects are collections of data objects.

& map lists (containing a set of raster maps) @ representations

Service objects are:
& domains

georeferences
@ coordinate systems

You will learn their use during the workshop tutorials.
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In order to get some look and feel on Ilwis processing, let’s create some colour composite images from
the Landsat bands present in de demo Cochabamba (Bolivia) dataset. Go to the Operations Menu >
Image Processing > Color Composite

m Color Composite | Py ‘
a a .
v 24 bit @ Linear Stretching i
1
® RGB ¢ Histogram Equalization £
3
" Hal [¥ Percentage k
3
Red Band I LI 1.00
Green Band I LI 1.00
Blue Band [ ] [10o
| Dutput Raster Map ‘ |
Description:
Show | Define | Cancel | Help |

Detailed information about colour compositing can be found by pressing the ‘Help’ button. Let’s select
the appropriate parameters or bands. Select the input maps by pressing the 7. You get than the list of
appropriate data objects for this operation (in this case raster maps) in the current top most (active)
catalogue. You can navigate to other locations but let’s just use this one. Select the raster maps tmb5, 4

en1l( ERTmb1  etc.). Let’s call the output map FC541.

Press Show (Define will only define the map without actually calculating it). A progress manager will
show and after a short time a display options form (just press ‘OK’) will show and the calculated map will
show.

The object (fc541 colour composite image) will also be visible in the catalogue. Can you derive or explain
the relation between land cover objects and colours?

Of course spectral reflection characteristics are needed to explain, but you can also open the land use
polygon map E3Landuse jn another window and compare visually. You can also overlay this vector map
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on the image. Go to the Layer menu on the image window and use add overlay and select land use
polygon map. Now, browse with the mouse and check the land use classes.

Pls. try some other colour composite band combinations (e.g. 3,2,1 or 4,5,2 etc.) and can you explain
what the colours mean? For more practical training on this llwis demonstration data set, pls. see the
llwis Quick Guide.pdf (also available from http://52north.org llwis download or the ITC webpage).

Importing data using the GEONETCast Toolbox

ILWIS contains many analytical operations and plug-ins. The GEONETCast toolbox is such a plug-in
application, which permits to import and analyse several satellite and other data in near real time or
delayed mode. PlIs. see the main GEONETCast Toolbox manuals (Maathuis, Mannaerts et al, 2011) for
more details.

You should have ILWIS Open 3.72 installed on your system in a directory with short directory name e.g.
c:\ilwis37" or similar. If the GEONETCast Toolbox doesn’t appear in the Navigation Menu, pls. download
the Toolbox (from http://52north.org/download area) as a zip-file, and place the zip file (as zip file) in
the Extension directory of llwis, and re-open llwis. The Toolbox will be loaded automatically! Pls. see the
Toolbox Manuals for more details. Now, go to the Operation Tree panel and open the GEONETCast
Toolbox (double-click).

Operation-List I MNawigator |

Operation-Tree

Edit -

III Pixel Info Ef Geonetcast Toolbox
E:: Create | 7 [ GEONETCast Product Navigator \
B2 DEM hydro-proce | By J

e { Calculate MSG angles rd ‘ ;. " 3

- | Bl GeostationansLRIT -l s
ESA-DDS [ :::Mebuvu\ug\ca\l?luduc‘Exflsuﬁun?amwy Easy Im port anﬂ a
2 Geonetcast I || 5 S morbcanen maramicn 52 - @ < 4
2 Image Processing £} GOESMS3 FrComposka isualzskon D%t: - ehve
g g M| B oMaproducts - "
B3 Import/Export | ) TAMSAT Ranial roducts
| @ SPOTVGT Prod
+ @I lati e umcacas(p.zaﬁ
I’TtEI"pO ation | | | F EAMNET Merine Products
= : | || B AMESD-5ADC
1 Point Operations | i weror
. [ H,I JASON-Z and AVISO
B Polygon Operatic-— [
ER Raster Operation: =
ER Rasterize
|
B SEBS Tools |
B Segment Operati g 0 E
w Config XML version 1.2

m A Cmndiond DV fmminmm
4| | P cose ||

The Toolbox menu will appear as shown, illustrating the multiple import and analysis routines:

! Pls. setup Ilwis Open on the root directory of d:\ ilwis37 or any other drive for proper functioning of all toolbox routines.
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Importing and analysis of MSG (Meteosat-9) image data (MSG2 HRIT L1.5).

The following routine allows you to analyse MSG2 raw image data as received by the EUMETCast
satellite data receiving systems (e.g. Puma, GEONETCast), when in HRIT format (Level 1.5), the standard
EUMETCast data transmission format for MSG2 (next to native format). In the Toolbox Menu, go to MSG
- HRIT, and start the MSG Data Retriever. The next screen appears:

“ Metecsat Second Generation Data Retriever

File Help
Satelite

Drate / Time range (UTC) Channels [ Use bounding box

Fom: [ 871672005 = |[1200_~ DIvisa06
To [ arerzo0 w|[1z00 O vis008
=200 <] OiR_0E

Repeat Interval [min): 15 - [J/R_0z3
w062

Series O 073

. 5 - [/R_0a7
™ Multiple Channels in one File O Ao
™ Multiple Times in one File OR_108
Conversion E :E’j‘ és
& Original D Values ] HRY
" 8 hbits Values
" Radiometric: [mw//m2/sr/{em-1]1) _ Set_ |
" Radiometric [w/m2/s1/um) Fler ,— Lat MGS {r? T & &
" Reflectance / Temperature [K] ME ,— Lon 1984) H
Output ™ lgnare Enors
Format: |GEUTIFF j Projection: [M5G [~ Show Caonsale
File prefix: ™ Simple Filename r

Execute

IFKEE | Browse...
Show command line %

Go to the File Menu and open Data Sources. Check on the existing directories and create new source.
You should access your own local source folder path e.g. [see workshop for tutorial data and location].

% Meteosat Second Generation Data Retriever = =
File Help

Satellite

I

MSG2

| | Create a new Data Source téj

Date / Time range (JTC) Source folder =

From: | 22172012 ok | |

H l Browse..
Data sources Cancel
Source folder atiributes "
Folder Date range Satellite -
N First day of data: | 2/21/2012 MiIE MSG2 hd
Last day of data: 2f21jz012 | [ Today
Date-formatted subdirectony
@ Dataresides in a date-formatted subdirectory of the source folder
Auto-cletect
i~ Data resides directly under the source folder specified
t —
Mew... Edi s ‘
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Use Satellite MSG-2 (Meteosat-9) and select Auto-detect, for Ilwis to check the available data’. One
sample raw MSG dataset is provided in the tutorial dataset [see workshop for details]. By preference,
link to your own GEONETCast LAN server and data drive, if available.

WS ELEE R T T T EHLTNETEY  Now, select the image date/time e.g. 09/16/2009 1200 UTC,

el and load the Channels VIS006, VIS008 and IR016. Put the
[MsG2 =] multiple channels also in one File.

Date / Time range [UTC)

From: | 9/16/200% » (1200 =
To. | 9s16/2008 w1200 +|

Repeat Interval [min): 158 ;K

Output format:

- Use 8-bits as data format.

- Use ILWIS raster as format. A file prefix is not needed.

[ Mulple Channels in ane File E:E—gg;
iMle Times in one File . .
D:g-}gﬁ - Select an output directory on your pc system.
Conversign EIH 134
* DOrigigfal DN W alues DHFTV

" 8 bif Walues

iometiic (mw/m2/sr/om 1) | | —Sot__|

If no zoom window is selected in the disk window (using the
mouse cursor), the full Meteosat disk window will be processed. Use MSG as projection system
(geostationary). Run Execute to start the import. As llwis is open source, you can look at the import
algorithm using the open source GDAL library. Then go to your output file directory to open the images.
Pls. use the Navigator Panel to change directories.

File Edit Operations WView Window Help
=N w53 B ©
open D\visualization euroit3 200909161200 CH 1 2 3.grf

N ERERED 2aERB B @&Xne BB R

‘ Operation-Tree = D:\Visualization_euro

; Operation-List Navigato b2 A)DA0S161200_CH_1_2 3 B3 o0
Y- ParaviewTutorialData 1 00909161200_CH_1_2_3 band_1 [Et3_200¢
Ie-E3 ppt Jt2_200909161200_CH_1_2_3 band_1 [Et3_200¢
4.0 radar t2_200909161200_CH_1_2_3 band_2 EEI3_200¢
{00 Roxo B t2_200909161200_CH_1_2_% band_2 EZt3_200¢
.00 sar 200309161200 CH_1_2_3 band 3 (B 3_200:
e, B t2_20090161200_CH_1_2_3 hand_3 iEb13_200:

TR INNAnat e N cH o1 7 3 Erhea 2nn

Open the Map list. This file this corresponds to a file stack, containing the three processed MSG2
channels. The individual files (bands) can also be opened. The 3 files will be combined and shown as a
Colour Composite (MSG Daytime Natural Colour). See workshop for explanation colour scheme.



WFP — DRMFSS — NMA — ITC project: GEONETCast Toolbox for Water & Food Security Training Workshop, Addis Ababa, March
05-09 2012

L oxmw gEmo rpmml geen rgom o pep

a_200909161200_CH_1_2_3 - ILWIS
le Edit Layers Options Help

20 & 8 & 4 B o | [EmsereE ]

FAD di\L_puaniywer
+ E5' Properties

> 4 Pixel Information - ILWIS
R a_200909161: 3 _' : 7_ File Edit Options Help

+ E5' Properties

[Ficoordinate (2182715.0,-364679.4)
[E2e_200909161200_CH_:1978,2584
[Be_200509161200_CH_: 54

e 200905161200 CH_:79

s 200909161200 CH :74

[Eworidcountries 51

[Diplacename Congo, DRC

2680,1131 ( -2175435.8, -2471119.0) 23941'47.56"S, 22930'59.09"

Pls. browse the image with the cursor, and enlarge eventually. You can add the world country borders
and coastline, using the Add Layer option in the Menu bar. You can find this “world countries” vector
dataset in the tutorial 1 data set and directory [see workshop for data and file locations]. Pls. use a
colour e.g. yellow to visualize (e.g. not black = invisible,). Pls. note that when borders are added, the
cursor does NOT display anymore the pixel information (data values) on screen! This can be done using
Pixel Info eventually from the File Menu on top of the image. All geo-information on the data layers will
be given for the selected pixel. Pls. Retrieve some other band combinations and view as colour
composites: e.g. VIS006, VISO08, and IR108 (see classroom for more tips & tricks).

Create an Ethiopia window view (of an MSG image)

Import using the GEONETCast Toolbox > MSG-HRIT > MSG Data retriever > an East Africa window or
select your own country i.e. Ethiopia window, of a MSG Daytime Natural Colour (using the solar
channels VIS006, VIS008, IR016), also using the Lat-Lon coordinate system, Pixel size 0.01 degrees
(approx. 1000 m in Ethiopia; ps. 1 degree is approx. 100 km near the equator). Also overlay the image
with the world country vector data (e.g. in yellow). Your resulting image should look like below:

Pls. note the other cartographic map view compared to the MSG projected full disk image above, and
the other coordinate system (Lat-Lon) and georeference made and used by llwis. Open (right hand
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mouse click) and inspect and compare these objects @ and & in your directory. What can you derive
from this image (explain colour development)?

Pls. read the Main GEONETCast Toolbox Manual (Maathuis, Mannaerts et al, 2011) for more details. The source location settings depend on the
network or drive/directory location of the raw HRIT (MSG) files, incl. available date/time.
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