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3. CROP MONITORING 

By: André Souza1 and Agmom Rocha2   
 
The Company for Food Supply (CONAB) is present in all Brazilian regions, following the trajectory of agricultural 
production, from planning to sowing until the consumers table. CONAB contributes to the decision of the farmer's 
time to seeding, harvesting, storage and will remain involved until the distribution of the products on the market. 
The operations performed by CONAB are coordinated by the Ministry of Agriculture, Livestock and Supply 
(MAPA). For these actions, the company conducts studies and statistics of prices, as well as surveys of agriculture 
production costs, the prospect of sowing and harvesting of grain, besides the volume and location of public and 
private stocks of a range of products. The estimated ethanol production and other relevant information are also 

extended to the harvest of coffee and sugar cane. 
The Faculty of Agronomy of University of Campinas (UNICAMP/FEAGRI) is very active in developing research 
projects focused on technological solutions to problems of Brazilian agribusiness. The FEAGRI’s Laboratory of GIS 
has a role to train highly qualified professionals to act and use geoinformation as a tool for decision making. It also 
works on the development of studies, designs and integrated multidisciplinary courses on GIS applications, such as 
geographical information system (GIS), remote sensing and global positioning systems (GPS) in agriculture, 
environment and other disciplines. 

3.1. Relevance of the topic selected 

In agriculture, Brazil stands out among the world's largest producers, with emphasis on grains, coffee and bio fuels. 
This was made possible by technological advances that have provided this high ranking worldwide. However, due to 
the country's continental dimensions, climate variability is a major challenge to maintain this position and for this 
reason, the adoption of new techniques, technologies and methodologies should be developed to improve crop 

monitoring and forecasting. 

3.2. Objective of the application 

Using vegetation indices derived from SPOT-VEGETATION instrument to monitoring and identify agricultural 
areas with temporary (like maize, rice, soybeans, sugarcane) and permanent (coffee) crops as well as reforestation.  

3.3. Methodology  

The methodology used in this exercise to conduct crop monitoring was based on vegetation indices derived from the 
SPOT-VEGETATION instrument and additional information such as the regions where these crops are established 
in São Paulo and Minas Gerais, who excel in agricultural production. Also the States of Rio de Janeiro and Espirito 
Santo were included. The study area is depicted in figure 3.1. 

The time period for this case study is depending on the availability of the Dry Matter Productivity (DMP) data for 
South America. The starting decade of this product is the first decade of April 2010 and the time series ends during 
the second decade of January 2011. Two decades are missing, namely the first decade of July and the last decade of 
November 2010, therefore the time series is consisting of 27 decades. In addition to the DMP, the Normalized 
Difference Vegetation Index (NDVI) and Normalized Difference Water Index (NDWI) were used. Based on these 
data sets other indices were generated to complement the information provided by the NDVI, NDWI and DMP. 
These indices are: Fraction Vegetation Cover (FVC), Leaf Area Index (LAI), Structural Scattering Index (SSI) and 
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another one that is the result from the combination of NDVI, NDWI and DMP data. The latter only serves to 
highlight the structural patterns of agricultural crops in this study and was designated as COMBVI; the Combined 
Vegetation Index. For further information on the SPOT Vegetation products the VGT4Africa user manual can be 

consulted (Bartholomé, 2006). 
 

 
Figure 3.1 Region selected in the Southeast of Brazil  

 
The FVC was calculated using equation 1, according to Jiménez-Munhoz et al. (2005), see also table 3.1. The LAI 

was calculated by equation 2, according to Norman et al. (2003). The SSI was calculated by equation 3, following the 
procedures given by Gao et al. (2003). There is no reference provided to calculate the COMBVI index.  This index is 
a newly developed index and can be calculated using equation 4. This index intends to combine DMP, NDVI and 
NDWI, putting the last ones “almost” in the same scaling as the DMP.  Figure 3.2 shows the methodology adopted. 
 

Equation number Equation used 

Eq1 FVC = 1.1101 * NDVI – 0.08577 
Eq2 LAI = -2 * ln (1 - FVC) 
Eq3 SSI = 3.175 * NDVI – 0.297 
Eq4 COMBVI = DMP + 10 * NDVI + 10 * NDWI 

Table 3.1 Set of equations used 

3.4. Data collection and pre-processing 

Before working with the data, open ILWIS, ensure that the GEONETCast toolbox plug-in is installed, and navigate 
to your active working directory. The following pre-processing steps are already conducted to minimize the sample 
data size and processing time needed. A description of the various steps (chapter 3.4.1 to 3.4.3) is given as reference 
and applied to the raw NDVI, NDWI and DMP time series data derived from the SPOT Vegetation instrument. 

3.4.1. Pre-processing step 1  

Process data from GEONETCast - DevCoCast using the ILWIS GNC-Toolbox menu. The same process can also 
be performed using batch looping routines. Also this procedure is described.  

3.4.1.1. Importing raw files to ILWIS using the GNC-Toolbox menu 

Simply put all the raw files in a folder and set this folder path using the 'Navigator' in ILWIS. Thereafter, from the 
‘Operation-Tree’, select “Geonetcast” and “Toolbox”. Now choose the specific data source, region and finally the 
desired product. 
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Observe that you should “Configure” the “Folders”, available from the GNC-Toolbox Menu and correctly specify 
the ‘Input directory’ and ‘Output directory’. The native files from SPOT-VEGETATION for South America obey 
to a standard name convention, such as: “V2KRNS10__20090101_NDVI__S-America.ZIP”. Using the GNC 

Toolbox, only the ‘Date’ field needs to be specified according to the format required (yyyymmdec). Figure 3.3 shows 
the Toolbox menu details. 
 

Figure 3.2 Methodology for crop yield monitoring using SPOT-VEGETATION indices 
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Figure 3.3 GNC-Toolbox menu for import of the SPOT VGT products for Latin America 
 

3.4.1.2. Importing several images using batch looping routines 

It is possible to adapt the ILWIS import batch files that are stored in the “Extensions\Geonetccast-
Toolbox\Toolbox_Batchroutines” directory, see also figure 3.4. Use your Windows Explorer to browse this folder, 
situated under the main ILWIS directory. There are numerous batch files for import of data delivered through 
GEONETCast into ILWIS format, using simple MSDOS commands. 

Figure 3.4 The batch routine directory of the GNC-Toolbox 
 
To obtain the details of the raw data format meta-data information is required. Usually, this documentation also 
contains information about correction - conversion parameters and the geometry that is used. With this information, 
one can develop an import routine for the desired purpose. See the example given in figure 3.5 of a routine to import 
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data generated from the SPOT Vegetation NDVI for the Latin American region. This batch routine is adapted 
compared to the regular import when using the menu. Here the status map is applied as well. 
 

 
Figure 3.5 SPOT VGT NDVI import batch file for Latin America 

 
As more data needs to be imported to generate a time series of each of the products a new batch file can be created 
as indicated in figure 3.6, using a “FOR” and “DO” loop routine. In this example all the products with a file name 
string consisting of “*V2KRNS10__*” will be taken and the “NDVI_SPOT_Veg_import.bat” (see figure 3.5) will be 
executed. Note that the path to the batch file to be executed needs to be correctly defined, here it is assumed that all 
data is situated in the same directory.   
 

 
Figure 3.6 For – Do loop batch procedure 

 
Having selected the required time series of raw SPOT VGT NDVI products one can just execute the batch routine 
'NDVI_Start_SPOT_Veg.bat' (figure 3.6), which in turn will run the main import routine (“NDVI_SPOT_Veg_ 
import.bat”, see figure 3.5). Note: ILWIS does not need to be active as it is now operated from the MSDOS 
command prompt. Handling your import in this manner facilitates efficient construction of time series data. Figure 
3.7 provides a screen dump of the import routine when active. The import procedures should be adapted to each 
data set used, basically by configuring these two import batch routines. 
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Figure 3.7 NDVI S10 import routine screen information 

3.4.2. Pre-processing step 2  

Next step is to create Map Lists containing the imported files. From the ILWIS menu, use the ‘Create’ option and 
select ‘Map List’. Then, select the files that will be part of the list. 

Figure 3.7 Create a Map List 
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3.4.3. Pre-processing step 3 

To create sub-maps for your region of interest (ROI) from the processed Map Lists you must prepare and select a 
spatial reference with your ROI boundaries. The Map List can subsequently be resampled. From the main ILWIS 
menu go to ‘Operations > Spatial Reference Operations > Raster > Resample > Resample Map ‘. When pressing 
“Show” the Map List will be resampled. Note that various Resample Methods can be applied, here the “Bicubic” 
method is selected.  

Figure 3.8 Resampling a Map List 

3.5. Calculation of the various time series indices   

At your disposal are the NDVI, NDWI and DMP time series sub maps and a number of polygon files indicating the 
ROI, areas covered by water and the regionalized crop masks of Coffee, Sugarcane, Bio Fuel and Reforestation. To 
proceed you are going to calculate the remaining indices as indicated in table 3.1. From the ILWIS menu, select 
“Operations”, “Raster Operations” and “MapList Calculation”. Insert the formula as indicated in figure 3.9, identical 

to equation 1, now only applied if the NDVI value is greater than 0. If this is not the case, a “no data” value will be 
returned for the output map, here represented as “?”. 

Figure 3.9 Map List calculation to derive the FVC using a NDVI time series 
   



APPLICATION MANUAL 

40 

Open the newly calculated Map List and display the map “SPMG_FVC_1” using as Representation “fvc”, note that 
this is the map representing the first decade of April 2009! All more recent decades have received a higher sequential 
number. Move, with the left mouse button pressed the cursor over the active map layer. You will see “no data” 

values, represented by a “?” and negative values due to the resampling method selected. To correct for these negative 
values a new maplist can be calculated by entering the following equation directly on the command line on the main 
ILWIS menu and press enter: 
 
 SPMG_FVC_cor.mpl:=maplistcalculate("iff(@1>0,@1,?)",0,26,SPMG_FVC.mpl) 
 
Display once more the first decade of April 2009 of this newly computed map list and check if the results are correct, 
note that in the Raster Map Display Options also the minimum and maximum map values are given! 
 
Calculate in a similar manner also the other indices (equation 2 to 4 as indicated in table 3.1) and check you results. 
Correct the SSI map identical to the procedure indicated above. Display the calculated LAI map using 
Representation “lai”, and for SSI and COMBVI using the Representation “Pseudo”. 
 

SPMG_LAI.mpl:=maplistcalculate("iff(@1>0,-2*ln(1-@1),?)",0,26,SPMG_FVC_cor.mpl) 
SPMG_SSI.mpl:=maplistcalculate("iff(@1>0,3.175*@1-0.297,?)",0,26,SPMG_NDVI.mpl) 
SPMG_COMBVI.mpl:=maplistcalculate("@1+10*@2+10*@3",0,26,SPMG_DMP.mpl, 
SPMG_NDVI.mpl,SPMG_NDWI.mpl) 

3.6. Local / regional (in-situ) data 

The Southeast Region of Brazil was selected to be monitored using data provided (NDVI, NDWI and DMP) and 
derived indices (FVC, LAI, SSI and COMBVI). Regionalized crop locations are also provided for the Southeast 
Region from Brazil (figure 3.10). 
 

 
Figure 3.10 Local data from areas with sugarcane, coffee, bio fuels and reforestation in States of São Paulo, 

Minas Gerais, Rio de Janeiro and Espírito Santo, Southeast Brazil 
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The cropping areas for coffee are based on data obtained from Brazilian Institute of Statistics and Geography 
(IBGE). The sugarcane growing areas are defined by a buffer zone around the cane processing facilities, having a 
maximum radius of 30 km distance. The processing plant locations are georeferenced by CONAB. These buffer 

areas cover the main sugarcane crops grown in the region. The same process was applied to create buffer zones for 
bio fuels. To identify the reforestation areas statistical techniques were applied, such as standard deviation, using 
SPOT-Vegetation NDVI data. Around the identified areas also buffer zones have been created.  
Display in a new window the vector file “G__Data_Shapes_Geoweb_BR_Graos_DevCoCast_SEBR”, showing the 
administrative boundaries. Select from the active map window menu, the option “Layers” and “Add Layer” and 
select the layer “DevCoCast_SEBR_Waters”, as display options, activate the option “Boundaries Only” and press 
“OK”. Now from the active map window select from the menu the option “File” and “Open Pixel Information”. 
Browse with the cursor over the map and note the tabular information presented as well. Close the Pixel Information 
window. Now add the vectors of Bio Fuel, Reforestation, Coffee and Sugarcane as well, using the display option 
“boundary only”, applying a different “Boundary Color” for the various vector files. Your results should resemble 
those of figure 3.10. 

3.7. Combining “insitu” and data from GEONETCast – DevCoCast 

The processed and resampled time series indices from SPOT-Vegetation (NDVI, NDWI, DMP, FVC, LAI, SSI and 
COMBVI) for the region of interest can now be further analysed using the crop masks provided and temporal 
profiles can be generated of the agriculture areas to indentify the crop(s) behaviours due the variation of climate and 
his influence. 
Open the maplist “SPMG_NDVI” and display the map “SPMG_NDVI_1”. Add to this map the vector layer 
showing the locations of the coffee areas, called “F__Vectors_DevCoCast_RegProdCoffee” and use the option 
boundaries only for display of this vector layer. Now from the main ILWIS menu, select “Operations > Statistics > 
MapList > MapList Graph” In the malist graph window, select as MapList “SPMG_NDVI”, use a fix stretch of 0 to 
1, activate the options “Continuous” and “Always on top”. Activate the map window showing the previously opened 
map layer “SPMG_NDVI” and zoom in to the southwest corner of the map, see also figure 3.11. Browse with the 
left mouse cursor pressed over the map and try to locate the pixel situated at row 769 and column 223. Note the 
NDVI time series values in the graph window. 

Figure 3.11 NDVI map with coffee mask and time series graph of a pixel 
 
Uncheck the option “Continuous” and select the pixel situated at row 769 and column 223. Press the option 
“Clipboard Copy”.  From the main ILWIS menu select “File > Create > Table”, as table name enter “Coffee” and 
specify that there are “27” records, press “OK” to create the table. From the Table Menu, select “Columns > Add 
Column”, as “Column Name” specify “NDVI” and for “Precision”, use 4 decimals by typing: “0.0001”. Click on the 
column heading “NDVI”, the whole column now becomes blue and paste the data copied to clipboard into this 
column. Create also a number of other columns, call these “DMP”, “NDWI”, FVC_cor”, “LAI”, “SSI_cor” and 
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“COMBVI” respectively, using the same precision. From the “Maplist Graph” window, change the Maplist to 
“SPMG_DMP”, uncheck the “Fix Stretch” option and press the option “Clipboard Copy”, paste the data into the 
“Coffee” table, under the column “DMP”. Repeat this procedure until all columns have been filled with the 

appropriate time series data. Your results should resemble the table given in figure 3.12. Note that from the Table 
menu, Option “View”, the “Statistics Pane” can be activated to get some summary statistics of the respective 
columns as well. 

Figure 3.12 The resulting coffee table containing the time series indices values 
 
Press from the Table menu the Graph icon , uncheck the X-Axis and as Y-Axis select the column “ndvi”, press 
“OK”. In the felt hand graph menu, uncheck the option “Legend”. Double click the “ndvi” item and from the 
"Graph Options –Graph from Columns” menu, select the option “Line” and press “OK”, double click the “Y-Axis 
left”, modify the text as follows:”ndvi, dnwi, fvc_cor, lai and ssi_cor”, change the “Min-Max” scaling from -1 to 4 
and specify as “Interval”:”1”, press “OK”. Double click also the “Y-Axis right”, modify the text as follows:”dmp and 
combvi”, change the “Min-Max” scaling from 0 to 150 and specify as “Interval”:50. Activate the option “Show Axis” 
and unselect the option “Show Grid”, press “OK”. Double click the text “ndvi” at the top of the graph and specify 
as “Graph Title”: “Coffee time series index response [location row-col 769,223]”.  
From the Graph menu, select “Edit > Add Graph > From Columns”, now select the column “dmp” and press 

“OK” to add this column. Double click the item “dmp” in the left hand legend menu of the graph, change it to a line 
representation and use a black color. Now “Use Y-Axis” “Right” to scale the data, note also from the table that the 
data range is completely different for the dmp and the combvi. Press OK to see the newly dmp time series on the 
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graph. Repeat this procedure until all columns are added, change the axis of the combvi to right hand Y-axis, for the 
others the left hand axis can be used. Your resulting graph should resemble the top left graph of figure 3.13.   
Repeat the procedure described above and prepare a table and graph for sugarcane (pixel row- col 381, 1414), bio 

fuel (pixel row- col 127, 1063) and reforestation (pixel row- col 227, 1155). You can copy the already created 
“coffee” table to a new table called “sugarcane’ by selecting the table “coffee” (press it once using the left mouse 
button and from the main ILWIS menu, select “Edit > Copy Object to” and select the option “New Name”, in this 
case use as name “Sugarcane”. Open the table “sugarcane” and from the clipboard the data can now be pasted into 
this table for the various columns.  

Figure 3.13 Time series graphs of coffee, sugarcane, bio fuel and reforestation 
 
It is clear that for the selected crops and reforestation there is a different temporal response using the various indices. 
It should be noted that sometimes there are remarkable peaks and dips in the time series which might require 
additional filtering steps as this response could be related to pre-processing of the initial data.  The graphs can now 
be further analysed, this should be done in conjunction with a good knowledge on the cropping calendar and the 

normal (average) response that is expected during a given time of the crops. Deviations can be easily identified, both 
positive (good crop performance) and well as negative (crop development stresses). Other climatological information 
can be used as well for this purpose.  

3.8. Conclusions 

This exercise shows the ability and potential to use data delivered through GEONETCast in the development of a 
monitoring system based on data obtained from satellite and local observations. Accordingly, this information can be 
fully explored and the results can be applied in various sectors, providing data that can be used to quantify 
bioclimatic parameters and monitor its evolution in time and space, thus constituting an important source of 
information. 
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