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10. FROM CLOUD TOP TEMPERATURE TO RAINFALL; 
BLENDING MSG AND TRMM-TMI  

 
By: Ben Maathuis1  

10.1. Relevance of the application 

Continuous rainfall estimates at high temporal and spatial resolution is of great importance in climate variability 

monitoring, Numerical Weather Prediction and in hydrological model inputs amongst other applications.  
Precipitation is one of the most variable quantities in space and time. The existing rain gauge network is sparse and 
available data are insufficient to characterize the high spatial variable rainfall distribution. Combined with the uneven 
distribution of rain gauges, weather radars and the relative lack of rainfall measurements over the oceans have 
therefore significant limitations.  
Rainfall measurements from space are based on the interpretation of the electromagnetic (EM) radiation that is 
scattered or emitted from clouds, precipitation and underlying surface, and is monitored by the satellite instruments 
at discrete spectral regions. Several studies have focussed on usage of visible and infrared (10.5 - 12.5µm) portions of 
the EM spectrum. Rainfall estimation methods using these spectral regions can be classified into cloud-indexing, 
spectral life history and cloud model-based methods. Each of the categories stresses a particular aspect of the sensing 
of cloud physical properties using satellite imagery. The primary drawback of the VIS/IR techniques is that the 
observations only relate to the characteristics of the cloud tops, rather than the precipitation reaching the surface. 
Clouds are opaque in the VIS and IR spectral range and precipitation is inferred from the cloud top structure. At 
passive MW frequencies precipitation particles are the main source of attenuation of the upwelling radiation. MW 
techniques are thus physically more direct than those based on VIS/IR radiation. The emission of radiation from 

atmospheric particles increases the signal received by the satellite sensor while at the same time the scattering due to 
hydrometeors reduces the radiation stream. Type and size of the detected hydrometeors depend upon the frequency 
of the upwelling radiation (Levizzani et al, 2002, 2007). Research is on-going to blend - combine observations from 
different sensors - spectral regions in an attempt to improve accuracy, coverage and resolution of the satellite derived 
rainfall estimates.  

10.2. Objective  
The main objective of this exercise is to make use of the TRMM-TMI derived rain rates to calibrate a collocated 
Meteosat-9 Cloud Top Temperature image (10.8 micron band) and subsequently transform a time series of MSG 
images into precipitation.  

10.3. Methodology and study area 

10.3.1. Methodology adopted 

A flowchart of the overall procedure is presented in figure 10.1. All required data is provided in the zipped exercise 
data file. The import procedures for the TRMM TMI data are described as well to allow application of the 
methodology to retrieve rainfall for other events. 
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Figure 10.1 Flowchart of methodology adopted 

10.3.2. Study area 

The study area selected is covering the central and southern part of Africa. The bounding coordinates are from 25 
degrees south to 10 degree north latitude and from 10 degree west to 50 degree east longitude. Most of the rainfall in 
these regions is attributed to convective precipitation as during this time of the year the ITCZ is situated over this 
region. The methodology applied is more suited towards deriving this type of precipitation. The frontal and 
orographic rainfall regions are not appropriately extracted due to the fact that these cloud top temperatures are not as 
cold as the cloud tops from cumulonimbus clouds.   

10.4. Data preprocessing 

Download the exercise data and unzip the file into your active working directory. Note that your working directory 
name should not contain spaces in the name. Note furthermore that there is a sub-directory (“\23febr2008”) 
containing the raw time series MSG HRIT data for the 6.2 and 10.8 micron channels. 

10.4.1. TRMM TMI rainfall data retrieval 

The period selected for this exercise is 23-02-2008. The TRMM data provided in the exercise was retrieved from the 
website: http://mirador.gsfc.nasa.gov/cgi-bin/mirador/homepageAlt.pl?keyword=TRMM. 
If you want to retrieve the data yourself load the website indicated above, select from tab “Available”: TRMM, 
subsequently select from the “TRMM Data Group”: Orbital and finally select as “Data Set”: 2A12 (Version 006): 
Hydrometeorprofile (TMI). Select the appropriate date and time: “2008-02-23” and “18:14:28”, you can also have a look 
at the preview of the image using the “View Image” option, see also figure 10.2. Note once more that this file is 
already provided and is situated in your active working directory. 
Download this data file and unzip it. To inspect the various data layer of the downloaded 2A12 data file you can use 
“Orbit Viewer”. Orbit Viewer is a tool for displaying the HDF data of the Tropical Rainfall Measuring Mission 
(TRMM).  To download Orbit Viewer, follow the link below and press “Download the Orbit Viewer” option from 
http://disc.sci.gsfc.nasa.gov/precipitation/additional/tools/trmm_ov.shtml. 
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Figure 10.2 TMI Surface Precipitation rate. 
 
For the purpose of this exercise you can use the following Orbit Viewer version: “orbit_1.3.5_win.exe”. Eventually 
download the “tutorial.pdf” as well. After download you can install the utility by double clicking on the 
file:”orbit_1.3.5_win.exe” or by right clicking with the mouse on the filename and selecting from the context sensitive 
menu “Run as Administrator”. After specifying an appropriate output directory the self-extractor is unzipping all 
required files. Browse to the specified directory. 
Activate the Orbit Viewer by double-clicking on the  “setupWIN.exe” program.  Then, double-click on the 
“orbitWIN.exe” program (in the sub directory \TSDISorbitViewer) or use the “orbit” shortcut on your systems’ 
desktop. 

10.4.2. TRMM TMI rainfall data extraction of central Africa 
To view the downloaded HDF file you need to use the Orbit Viewer. The example provided here is using the file 
“A12.080223.58539.6.HDF” containing information about the surface rain (mm/hr) for the evening overpass, on 23 
February 2008 (using version 6 of the TRMM rainfall estimation algorithm) over Central Africa, see also figure 10.3.  
Start Orbit and open from the menu “File” > “Open File”, browse to the directory containing the file 
“2A12.080223.58539.6.HDF” (unzipped!). From the left hand “Arrays” options select “Surface Rain” and from the 
bottom global orbit zoom in on “central – southern Africa”. Note that as indicated in figure 10.3 a zoom resolution 
is used of “30 degree Longitude” (from the Menu, under “Option” > “Zoom Resolution”). 

Figure 10.3 Orbit Viewer surface rain rate 
To get the time-date and rainfall intensity information, click with the mouse on a rainfall area, note the values in the 

lower left-hand corner. Also check the time stamps on both ends of the swath over Southern Africa. Note that when 
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you select different locations the time is changing (in this window roughly from 19:25 to 19:35 UTC, from NW to 
SE respectively). 
To export the selected frame to Ascii tables use the option “File” > “Save Data” and select as Output Format “Swath: 

ASCII (ARC/INFO)”, see also figure 10.4. Specify an appropriate output directory and filename. The file with the 
extension “TXT” is containing the rainfall intensities and the “GEO” file is providing the corresponding GEO 
location information. In general two TRMM overpasses over a specific area per day exist! Note that these files have 
already been created for you and are contained in the exercise data zip file. The extracted rainfall and geolocation 
files are called “surfaceRain.txt” and “surfaceRain.geo” respectively. 

Figure 10.4 Export to ascii tables using Orbit Viewer 

10.4.3. Extracting thermal channel from MSG for central Africa   

To relate the cloud top temperature with the rain rates, you have to import for the corresponding period the 
Meteosat-9 thermal image, so select 23 February 2008, 19:30 UTC, for band WV_062 and IR_108, convert the image 
to temperature (in Kelvin), select the appropriate area and export it as an ILWIS file.  
Open ILWIS, select “Geonetcast” > “Toolbox” > “MSG-HRIT” > “MSG Data Retriever”. Start the Data Retriever by 
pressing the button “Start MSG Data Retriever”. First check the “Data Sources” (from the Menu select the “File” 
option). If there is an existing data source specified, select it and use the option “Delete” and confirm the deletion. 
Select the option “New” and press “Browse”, navigate to the sub-directory “23febr2008”. Select the option “Data resides 
directly under the source folder specified”, press the “auto-detect” button, the first and last day of data should now indicate 
“2/23/2008”, press “OK” and “Close”. 
To get the settings as of the figure 10.5 below also use can be made of the ‘msg-project settings’. In the Meteosat 
Second Generation Data Retriever, select from the Menu “File” > “Open” and select from the exercise working 

directory the file: “msg_cal1930.msg1project” and press “Open”. With these project settings the MSG Data Retriever 
should look identical to figure 10.5 below and now execute the import (note the output file folder, if needed change 
this to your appropriate working directory). The file prefix is assigned with cal (for calibration) as the IR_108 will be 
used to determine the relation between cloud top temperature and the rainfall intensity from TRMM. Make sure that 
the imported TRMM geo and txt files are located in the same working directory as the MSG files which have been 
imported. 
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Figure 10.5 MSG Data Retriever settings 

10.5. Data analysis 

10.5.1. Retrieving the potential rainfall fields 
Activate ILWIS and navigate to the appropriate directory where you stored the tables and the MSG image files. 
Display the individual images and check the values and the differences between the Water Vapour and the Thermal 
Infrared channels, also have a look at the coordinates (MSG projection!). You can use an “Inverse” Representation for 
display of the images, use from the Map Window, “File” > “Open Pixel Information”, in the Pixel Information Window, 
select “File” > “Add Map”. Now select the other image and per pixel an idea can be obtained of the brightness 
temperature in these two channels. Select pixels that have cloud conditions and select also pixels that are not cloudy. 
Note that the colder areas (clouds) will have a white tone and the warmer areas are darker toned when using an 
inversed grey scale lookup table Representation. From the main exercise directory you can add to the image the 
country boundaries (“Add layer”, select the file “country_02”, uncheck the option “Info” and check the option 
“Boundaries only” and press “OK”). 
Note that you have imported 2 channels, the water vapour (6.2 micron) and the thermal IR (10.8 micron). Water 
Vapour has an absorption band around 6 microns and therefore it absorbs radiation from below but emits radiation 
according to the 2nd Kirchoff law.  Therefore the water vapour channels are indicative of the water vapour content in 
the upper part of the troposphere. The maximum signal from WV_062 is at 350 hPa, and for WV_073 at 500 hPa 
(assuming normal pressure at sea level approximate elevation is at 8980 m and 5965 m amsl respectively), see also 
figure 10.6. If there is no water vapour radiation from far below can reach the satellite (V. Zwatz-Meise, ZAMG). 

Figure 10.6 MSG channel normalised weighting functions 
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The thermal channel records the emitted energy from the Earth surface itself.  Based on a classification using MSG 
channel 108 and 062, applying a threshold on the temperature difference of less than 11 Kelvin an approximation of 
the clouds that have a high likelihood of precipitation can be obtained. This is an empirically determined threshold 

reported by Kidder, et al. (2005). 
To calculate the potential precipitating clouds, type the following algorithm on the command line in the main ILWIS 
window: 
 

pcloud:=iff(cal0000_band_2-cal0000_band_1<11,1,0) 
 
Use the default Raster map definition and press “Show”. Compare this map with the WV and IR image data. Display 
the map: “clm20080223_1930”. This is the Cloud Mask Product of the same time obtained from EUMETSAT. The 
Cloud Mask (CLM) product is an image-based product in full pixel resolution that displays information on the 
presence of cloud. When possible, each pixel is classified as one of the following three types: clear sky over water 
(value=0), clear sky over land (value=1) and cloud (value=2). Right click with the mouse the map 
“clm20080223_1930”, select “Spatial Reference Operations” and “Resample”. As resampling method use “Nearest 
Neighbour”, as georeference “Cal0000” (the georeference from the WV and TIR MSG bands) and specify an 
appropriate output map name, e.g. “clm1930”. Press “Show”.  Now you can integrate the Pcloud map with the CLM, 
type the following statement on the command line line in the main ILWIS menu and execute it using the default map 

definition: 
 

combine:=pcloud+clm1930 
 
Have a look at the location of the areas that have been classified as precipitating clouds in the pcloud map (note that 
precipitating clouds have a value of 3 and are all situated within the cloud masked areas).  

10.5.2. Import the two TRMM tables  

To import the file with the geo location information, here called “surfaceRain.geo” use the option from the main 
ILWIS menu: “File” > “Import” >”ILWIS” > “Table” > “Comma Delimited”, use the browse button to specify 
appropriate input and output file and press “OK” > “Next”. Check the table configuration and the meaning of each 
of the columns and modify the Column names according to figure 10.7 (left) presented below (Column2 to “X” and 
Column3 to “Y”), press “Finish” and “OK”. Repeat the same procedure (figure 10.7, right) for the Ascii table with the 
Rainfall intensities (here called: “surfaceRain.txt”). 
 
 
 
 
 
 
 
 
 
 

Figure 10.7 Import table windows for the TMI locations and rain rates 
 

After the tables have been imported, open both the tables and check the content. Activate the table with the geo 
location information. Select now from the table menu the option “Column” and “Join”. Specify the rainfall intensity 

table and select the column containing these values (here column2 called “Rain”). Specify an appropriate output 
column name, e.g. “rainfall” and execute the operation (using the default data type, range, precision, etc). The results 
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should be like those given in figure 10.8, note that here only a few records are displayed and that each set of XY 
coordinate pairs has a rainfall value assigned, in case of no rainfall the value is 0.  

Figure 10.8 Resulting table using the join operation 
 
Using Table calculation, from the table command line calculate a new column in which only those locations are used 
that have actual precipitation. Type the following command in the table command line: 
 

rain_more0:=iff(rainfall>0, rainfall,?) 
 
Execute this statement. For those records that have no rainfall a question mark is returned, in ILWIS this is assigned 
undefined (see the ILWIS help function for more details). Close the table. 
The next step is to transform this table into a point map, so it can be crossed with the Meteosat image at a later stage 
to calculate if there is a correlation with the cloud top temperature and if so, to find a suitable regression function to 
transform the cloud top temperature into rainfall intensity. 
With the mouse, right click the table (with the X,Y and rainfall columns), select “Table Operations” > “Table to 
PointMap”. Modify the options such that they represent those as given in figure 10.9 below. The X and Y columns 
are used for the location; the coordinate system assigned is an ILWIS system coordinate system (LatLonWGS84). 
Make sure that you use the column rainfall for assignment of the point values in your output map.  

Figure 10.9 Table to point map settings 
 

Execute the operation and display the resulting point map, here called “rain_more0”. Check the values and zoom in 
on some of the rainfall points. Use the measuring tool option from the map display window menu and measure the 
distance between the points to get an idea of the spatial distribution of the TRMM measurements. Use the option 
“Layer” > “Add Layer” and display the MSG 108 band (here “cal0000_band_2”) and the map “Combine” in the same 
window. Zoom in on the image and check the results obtained. The image view should represent the results as given 
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in figure 10.10, here a “pseudo” colour representation is used. Select from the display window, under “File” the option 
“Open Pixel Information”. Roam the mouse over the image and check the temperature and rainfall values that are 
presented in the pixel information viewer. You can check and uncheck in the legend the layers to furthermore 

visually inspect the relation between the precipitating clouds and the TRMM rainfall locations.  

Figure 10.10: TRMM point observations over the (precipitating) clouds and MSG TIR image 
 
This process completes the integration of TRMM data with MSG. Now the relations between the two sets of sensor 
data – products has to be further investigated. Do you have an idea of the type of rainfall; is it orographic, 
convective, etc? How about the matching of precipitating clouds and the TRMM rainfall locations? 

10.5.3. Correlation of TRMM rainfall point measurements with MSG 

To determine if there is a correlation with rainfall intensities and MSG cloud top temperature first the TRMM point 
rainfall map has to be transformed into a raster map. Next step is to cross both maps and the resulting cross table 
can be used to compute the correlation between the two. 
To transform the point map to a raster map right click the point map using the mouse button and select the option 
“Rasterize” > “Point to Raster”. Select as georeference the one given for the MSG image, here “cal0000”. Use the 
default output map name, point size, value range and precision. Display the results, zoom in and use the 
measurement tool to measure the distance between the raster elements that have obtained a value. Display the point 
map on top of this map, using “Layer” > “Add Layer” and note the effect of this resampling procedure. 
Next cross the two maps to obtain the cross table. To do so select from the main ILWIS menu “Operations” > “Raster 
Operations” > “Cross”, select the appropriate two input maps and specify an output table name. There is no need to 
generate an output map. Make sure that both input maps have the “Ignore Undef” option active. Display the resulting 

table, see also figure 10.11. Select from the table menu the option “Columns” > “Statistics”, as function select 
“Correlation” and select the rainfall and temperature columns, press “OK” to derive the correlation coefficient which 
is about -0.4.   
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Figure 10.11 Resulting table from the cross operation 
 

Note that the correlation coefficient has a negative tendency, meaning that with decreasing temperature there is an 
increase in rainfall intensity, but the overall correlation is weak. Figure 10.12 below shows some of the reasons for 
this low initial correlation and therefore the need for averaging (after Turk, et al., 2003). 
 

Figure 10.12 Collocating PMW and IR observations 
 

With respect to the current data there are also alignment errors, e.g. the time (MSG requires 12 minutes to complete 
a full disk scan (3712 scan lines recorded from South to North start scan at 19:30, takes 6 minutes to scan the 
southern hemisphere of the field of view, compared with TRMM, recorded for this window from 19:25 to 19:35 
UTC, from NW to SE respectively), looking angle (current MSG position is at 0 degree longitude over the equator, 
and original pixel size increases with increasing looking angles). TRMM has a relatively narrow swath. With respect to 
quickly changing phenomena like convective cloud system development and parallax offset it is not strange that there 
are low correlations. A method to average the data is presented below although there are more approaches possible 
to tackle this problem.  



APPLICATION MANUAL 

132 

10.5.4. MSG averaging 

As stated above there are more methods to improve the correlation. In literature approaches are described using 
larger areas (resampling of the IR data to account for spatial offset) or averaging two IR data acquisitions to 
compensate for timing offset.  Here a slightly different procedure is proposed: the TRMM assigned rainfall pixels 
with corresponding rainfall intensities are averaged based on MSG–IR pixels having equal temperature (in classes of 
0.5 or 1 degree Kelvin). This results in a temperature range, e.g. from 180 to 260 Kelvin, having for each temperature 
class interval a certain averaged corresponding rainfall intensity. These two variables are then used to determine the 
correlation and when satisfied a suitable regression function can be used for regionalization using the IR image as 
well as a short term IR time series of  15 minutes interval images (in the case of MSG). 
To perform this operation in ILWIS first a new domain has to be created with the appropriate temperature intervals 
(in Kelvin). From the main ILWIS menu, select the option “Create” > “Domain” Specify an appropriate input domain 
name, select the “Class” option and the “Group” function (see figure 10.13). By pressing the “insert” key a new class 
interval can be added as well as the associated code. After having finished inserting all the class intervals the domain 
editor can be closed. For your convenience this domain is available in the main exercise directory, called “temp_cl1”! 
Open this domain. 

Figure 10.13 Creating a new class domain 
 
Close the domain and open the cross table which was created previously by crossing the temperature image with the 
point rainfall raster map. Now you first have to classify the temperature column into 1 degree intervals. In the table 
menu, use the option “Columns” > “Column slicing”. Use as column name the temperature column and as domain the 
1 degree temperature interval domain. Specify a name for the output column, e.g. “slicingT”. A new column is now 
created with these class intervals for each record.   

Figure 10.14 Column slicing operation 
 

This newly created slicing column is now going to be used to create a new output table in which the average rainfall 
per temperature class interval is calculated. Select from the table menu “Columns” > “Aggregation”. Select the “rainfall” 
column for Column input, use the function “Average”, “Group” it by the column “slicingT”. Specify a name for the 
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new table that is going to be created and an appropriate output column name. Execute the operation and open the 
newly created table. Check the results of this operation.  

Figure 10.15 Aggregation function 
In the newly created table (here called “temp_rain1”) there is only one column: the average rainfall, the temperature is 
given by the record ID. You can use the predefined variable, %K, to create a new column using these record 
numbers. Type in the table command line the following expression:  
 

temperature:=%K  
 
Use as domain the default domain and execute the expression. Using the right mouse button click on the name of 
the temperature column (the whole column is now blue) and select from the drop down list the option “Properties” 
and change the domain to a “Value” domain. You will note that the column content is now aligned at the right hand 
side of the column (as in figure 10.16). 

Figure 10.16 Final rainfall and temperature table 
 

From the table menu, select “Columns” > “Statistics”, from the drop down menu, the function “Correlation” and use as 
input the two columns of this table. As you can see the correlation by this type of averaging is already considerably 
improved (R is now nearly -0.8). To get a better idea of the characteristics of your data you can create a graph as well. 
Use the Graph button from the table menu, for the X-axis use the “temperature” column and for the Y-axis the “rain” 
column. Modify the X-axis range (from 150 to 300). The negative relation between temperature and rainfall intensity 
can be clearly depicted from this graph. To see if it is possible to obtain a least square fit through this data set, select 
from the Graph menu the option “Edit” > “Add Graph” > “Least Square Fit”. The example given below shows a 
“Polynomial” fit using “4” terms (3rd order). The associated properties of the line can be retrieved when double 
clicking the line representation in the left hand legend.  
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Figure 10.17 Graphical representation of relation temperature – rainfall and polynomial function 
 
Close the graph window and from the table menu, select “Columns” > “Least Squares”. As X-axis “temperature”, as Y-
axis “rain”, function is “Polynomial” and as number of terms “4”, now specify as output column “poly_3” and press 
“OK”. In the Column Properties window, press the option “Additional Info” and note the equation of the fitting 
function (Y =  801.825646+ - 9.357660* X  + 0.036419* X^2  + -0.000047 * X^3) and press “OK” twice. Check the 
values of the new column “poly_3” obtained and calculate the “correlation” between the “poly_3” and the “temperature” 
columns. 
If satisfied with these results the fitting equation obtained can be used to transform a single thermal image (10.8 
micron cloud top temperature) into a rainfall intensity map. You can enter the equation obtained into the command 
line of the main ILWIS window and conduct the transformation from temperature into rainfall:  
 

rain1930:=iff(pcloud=1, 801.825646 + -9.357660 *cal0000_band_2+0.036419 * cal0000_band_2^2+-
0.000047 *cal0000_band_2^3,?) 

 
Here we are going to follow a more generic approach as ILWIS is showing only a few decimals and for higher order 
polynomial functions the number of decimals is of critical importance. Copy and paste from the “temp_rain1” table 
the columns rain and temperature into an Excel worksheet. Only take for both columns the relevant data range as 
given by the temperature column from 190 to 296. Select from the Excel menu the “Chart Wizard”, as chart type 
select “XY (Scatter)” and as subtype “Scatter” (compares pairs of values), press “Next” and specify the appropriate 
data series (X=temperature and Y=rainfall) and press “Next” and “Finish”. The initial graph is shown in the active 
worksheet. Eventually change the X-axis data range (from 175 to 300). Right click with the mouse in the graph on 
the data points and from the context sensitive menu select the option “Add Trendline”, select “polynomial” and use as 
order “3”. From the “Options” tab, activate the options “Display equation on chart” and “Display R-Squared value on chart”, 
press “OK”. The equation of fit is given, activate the equation window, right click the mouse on this window again 
and from the context sensitive menu select the option “Format Data Labels”, from the “Number” tab, select “Number” 
and as “decimal places” specify “10”and press “OK”. Don’t activate the option ‘Use 1000 Separator (,)’. The chart, 
equation and correlation coefficient obtained should resemble the results of the graph presented below. 
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Figure 10.18 3rd order polynomial function and equation of fit 
 

The resulting equation that can be typed in the command line of the main ILWIS menu now becomes: 
 

rain1930_p3:=iff(pcloud=1, -0.0000584843*cal0000_band_2^3+ 0.0447655985* cal0000_band_2^2 - 
11.3942639435*cal0000_band_2 + 966.1798474926,?) 

 
Specify as value range “0” to “250”, precision of “0.01” and press “OK”. Note that “pcloud” is the precipitating 
cloud map calculated before and if there are no precipitating cloud pixels defined in this map an undefined is 
returned in the output map! Display the resulting map. Also calculate a 4th order polynomial function, a sample 
equation is provided below: 

 
rain1930_p4:=iff(pcloud=1, 0.0000009548*cal0000_band_2^4 -0.0009862060*cal0000_band_2^3 + 
0.3804618224*cal0000_band_2^2 - 65.0015824495*cal0000_band_2 + 4153.4825533355,?) 

 
The resulting 3rd order polynomial function rainfall map should look like the figure presented below. Add also a 
vector layer with the country boundaries for visualization purposes. Use as representation the colour assignment as 
provided by “mpe_single”. Open from the map window the option “File” > “Pixel Information” and roam the cursor 
over your map, inspect the values obtained. Eventually add the point map with the TRMM rainfall locations. Repeat 
this procedure for the 4th order polynomial function. 

Figure 10.19 Rainfall map obtained derived from MSG Cloud Top Temperatures 
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The near real time multi sensor precipitation estimate (MPE) can be directly retrieved from the EUMETSAT 
Website (available: http://oiswww.eumetsat.int/~idds/html/grib.html, a rolling archive with files given for the last 
24 hours). To derive the MPE use is made of the relationship between cloud temperature and rainfall intensity, as 

colder clouds are likely to produce more rainfall as seen in the relationship determined before. The MPE uses a 
statistical matching algorithm in temporal and geographical windows to correlate the SSM/I instrument derived rain 
rates with Meteosat IR brightness temperature images. The obtained relationship is later-on converted to the full 
Meteosat-9 temporal resolution and a MPE product is generated each 15 minutes. The algorithm performs well for 
the tropical and subtropical convection areas. The relationship is based upon SSM/I – Meteosat co-located pixels 
from 40 degree North to 40 degree South (Heinemann, et al, 2002). With the DMSP program (two satellites in polar-
orbit array), a given location on Earth is revisited every 6 hours, allowing 4 brightness temperature versus rain rate 
calibration events on a 24 hr basis. The data is provided in GRIB format and other functionality in the 
GEONETCast toolbox allows one to import these files. 
Open the map “mpe20080223_1930” to see the results of the MSG rainfall product (MPE) for the full field of view 
of the geostationary satellite. “Resample” this map, from the option “Spatial Reference Operations”, using the thermal 
image georeference “cal0000”.  
Visually check the differences between the two maps and also calculate the difference between the two rainfall maps 
(keep the undefined pixels in mind!). You can also determine the correlation between the two maps (R of 0.8 or 
higher) using the “Cross” operation. What can be concluded when comparing your own calculated results with those 

from the multi sensor precipitation estimate (MPE)?  

10.5.5. Compute rainfall intensities for a time series of thermal images  

Once more retrieve the data for channels WV_062 and IR_108 of Meteosat-9. Use the MSG data retriever with the 
settings as indicated in the figure below (File, open and load the “msg_tday.msg1project” file). Note that for 23 February 
2008 all data is retrieved on a 15 minutes basis, transformed into two ILWIS map lists (multiple times in one file), 
and converted to temperature for an identical window as was used previously. Note the folder settings for the output 
files! Use your active working directory. 

Figure 10.20 MSG import setting for time series retrieval 
 

To visualize the time series created, move to your working directory and right click the maplist icon, select “Open” 
from the drop down menu and select the option “As Slide Show”. Also study the naming convention of the different 
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times used (instead of ‘Band_n’ it should be interpreted as ‘Time_n’). Use an “Inverse” representation, use the default 
stretch and click “OK”, in the display options set the refresh rate to a higher value, e.g. “150” and press “OK”. 
Have a look at the animation and close the animation window afterwards. Now calculate for each time step in the 

time series the precipitating clouds in a similar way as has been done previously for the 19:30 hr image. In order to 
do so select from the Main ILWIS menu “Operations” > “Raster Operations” > “Maplist Calculation”. Select the 
appropriate map lists and enter the expression as indicated in figure 10.21 below (note that t0000 is representing the 
WV channel and t0001 is representing the TIR channel).  

Figure 10.21 Map list calculation for time series computation 
 

Now you can use the 3rd order polynomial formula as used for the 19:30 hr UTC image to transform the whole time 
series of the 23rd of February to rainfall intensities. Once more select “Maplist Calculation”. Select the appropriate map 
lists and enter the expression using the coefficients for the previous obtained 3rd order polynomial fit, see also figure 
22. Now each image in the maplist is transformed into a new maplist with rainfall intensities. Display this maplist as a 
slide show using as representation “mpe_single”, add the country boundary vector layer as well.  

Figure 10.22 Transforming a maplist of thermal images into rainfall intensities 
 

Double click the rain maplist and select image band_79 (which is actually the 19:30 hr UTC image) and display this 
image. Keep the map display window open. Close the maplist. Now select the maplist icon again using the right 
mouse button and select from the drop down list “Statistics” > “Map List Graph”. Activate the fix stretch option and 
assign “0” to the minimum and “20” to the maximum, activate the “continuous” button as well. Now roam the mouse 
over the map display window and check the temporal activity of the rainfall over certain pixels during the 23rd of 
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February, note that the X-axis is the time (1=00:00 – 96=23:45 hr UTC) and the Y-axis is the rainfall intensity in 
mm/hr.  
Now you have obtained a continuous rainfall record consisting of 96 observations over the day, transformed in a 

similar way as the 19:30 hr UTC image which was calibrated using a TRMM single overpass observation.  

10.5.6. Compute total daily rainfall  

To compute the total rainfall the Maplist statistics Sum function can be used. Right click with the mouse the maplist 
“p_time”, select “Statistics” > “Maplist Statistics” and specify the appropriate settings, as statistical function use “Sum”.  
Execute the operation and display the resulting map.  

Figure 10.23 Summation of the 96 precipitation events 
 

As the initial unit per timestamp is in mm/hr and we have 4 events on an hourly basis a final correction needs to be 
applied to obtain the total precipitation per day in mm. Type the following expression in the command line of the 
main ILWIS menu: 
 
 Rain_day20080223:=sum_p/4 
 
Use the default map definition settings, display the resulting map and check the values. For better visualization you 
can use the representation “mpe_sum”. Your results should resemble those of figure 10.24. 

Figure 10.24 Precipitation calculated over central Africa for 23-02-2008 
 

Leave the map “Rain_day20080223” open. To check the temporal distribution of the rainfall, right click with the 
mouse on the map list icon “p_time”. From the context sensitive menu, select the options “Statistics” > “Maplist 
Graph”, use a fixed stretch from “0” to “20”, activate the options “Continuous” and “Always on Top”. Now browse 
with the mouse over the map “Rain_day20080223” and check the rainfall details in the Maplist Graph window (note 
that the unit is mm/hr!). 
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10.6. Concluding remarks 

The purpose of the exercise is to show how information obtained from other sensors can be used in conjunction 
with the cloud top temperature from geostationary satellites. Here the evening TRMM TMI overpass is used to 
calibrate a whole day of MSG 15 minutes interval images; you could use other overpasses from different satellites as 
well.  
Here a statistical curve fitting procedure is adopted for the sake of simplicity to demonstrate the procedures. This 

adopted methodology is not able to cope with all miss-alignment issues. Furthermore the function applied to 
perform the averaging is resulting in the fact that the high precipitation events are not well taken into consideration 
and therefore under-estimation occurs, which could clearly be observed when comparing the rain rates derived with 
the ‘mpe’ precipitation product. It should furthermore be noted that for this product another sensor, the Special 
Sensor Microwave Imager (SSM/I) onboard the polar orbiting DMSP satellites, is used as well as another overpass 
time.  
More complex procedures are currently in place to obtain satellite derived rain rates, also incorporating gauge based 
ground observations. The timing for the total daily rainfall most likely deviates from the one that is presented by the 
meteorological organization of your country. To compare the obtained results with real rain gauge measurements one 
needs to know the time when the reading is done and use the same temporal settings for the MSG derived images!  
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