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Chapter 8

 How to…

Note: This chapter is written as an enhancement to Chapter 8: How to… in the
ILWIS 2.1 Reference Guide. It does not completely replace the mentioned
chapter: instead you are invited to use both as one.

8.1 How to add…

8.1.1 How to add annotat ion to a map window

Simple annotation can be added to a window in the form of texts, legends, boxes,
North arrow, scale bar, grid lines, graticule or bitmaps or metafiles/pictures from
disk. Further, any picture or bitmap that was copied to the clipboard from other
Windows application programs can be pasted into ILWIS. You can also paste the
contents of another ILWIS map window into a current map window; for instance as
an inset-map giving an overview of a larger area.
This type of annotation can be edited in the Annotation editor. To store this type of
annotation, you need to save the map window as a map view.

Furthermore, you can create an Annotation Text object when you want to store
multiple texts at multiple positions. When creating an Annotation text object, you
can base the texts that will appear in the text object on an existing point, segment, or
polygon map. If you do so, the text object will contain a text (class name, ID or
value) for each point, segment or polygon in the selected map.
An Annotation Text object can be edited with the Annotation Text editor or in a
table window. In the Annotation Text editor, you can easily insert more text items,
change and refine the position of texts (move), make text duplicates, and specify
fonts, font sizes, appearance (bold, italics, underline), colors, rotations, etc. for
(multiple) selected texts.

Annotation is generally used on top of one or more data layers (displayed maps).

To add an annotation text object to a map window
§ From the Layers menu in a map window, choose Add Annotation, and select

Text Layer from the cascading menu.
The Add Annotation Text dialog box will appear in which you can select an
existing annotation text object or create a new annotation text object.
When you select an existing annotation text object, it will be added to the map
window.
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When you create a new annotation text object, the Annotation Text editor will be
opened.

§ From the Layers menu in a map window, choose Layer Management.
In the appearing Layer Management dialog box, click the Add Annotation
button.
In the appearing Add Annotation (from Layer Management) dialog box, select
Text Layer.
The Add Annotation Text dialog box will appear as described above.

§ Drag an existing annotation text object from the Catalog to the map window.
The annotation text object will be added to the map window.

To add a simple annotation to a map window
§ From the Layers menu in a map window, choose Add Annotation, and select

Single Text, Legend, Grid Lines, Graticule, Box, Scale Bar, North arrow or
Bitmap or Picture from the cascading menu.
Except for bitmaps and pictures, you have to specify some display options for
the annotation layer before the annotation is shown. The newly added annotation
is displayed at the center of the map window; you are now in the Annotation
editor.

§ From the Layers menu in a map window, choose Layer Management. In the
appearing Layer Management dialog box, click the Add Annotation button.
In the appearing Add Annotation (from Layer Management) dialog box, select
Single Text, Legend, Grid Lines, Graticule, Box, Scale Bar, North arrow or
Bitmap or Picture.
Proceed as in previous paragraph.

§ From the Edit menu in a map window, choose Annotation. The Annotation
editor is opened immediately. You can add simple annotation in the Annotation
editor as described below.

Annotation Text editor

In the Annotation Text editor, you can:
§ insert new texts and delete selected existing texts,
§ move one or more selected texts to another position,
§ make text duplicates, and
§ specify fonts, sizes, colors, etc. for (multiple) selected texts.

For detailed descriptions, refer to Annotation Text editor: functionality.

Annotation editor

To add annotation from within the Annotation editor:
When you have already added simple annotation and you are in the Annotation
editor, you can use the same possibilities as above but you can also:
§ click one of the add annotation buttons in the button bar of the Annotation editor

(the status line gives an explanation), or
§ click the right mouse button in the map window, and choose Add Annotation

from the context-sensitive menu.
Except for bitmaps and pictures, a display options dialog box follows.
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To add bitmaps or pictures from disk to a map window
§ use one methods described above, choose Bitmap or Picture,
§ in the appearing Add BitMap or Picture dialog box, select a Bitmap (.BMP) or

Picture/Metafile (.WMF) from disk.
The bitmap or picture is displayed at the left top corner of the map window; you are
now in the Annotation editor.

To add an ILWIS map as an inset-map to another map window
§ display the map you want to use as inset-map,
§ from the Edit menu in this map window, choose Copy,
§ display the map in which you want the inset map to appear,
§ from the Edit menu in that map window, choose Paste.
The inset-map is displayed at the center of the map window; you are now in the
Annotation editor.

To add bitmaps and pictures via Clipboard to a map window
§ Open a Windows application program (for example Paintbrush),
§ create a bitmap, picture, logo, graph, laid-out text, other graphics, etc.
§ copy this to the clipboard,
§ go to an ILWIS map window,
§ from the Edit menu, choose Paste.
The bitmap, picture, text or symbol is displayed at the left top corner of the map
window; you are now in the Annotation editor.
For more information, see Copying and Pasting through the clipboard.

F Before adding annotation to a map window, you might want to increase the size of
the map window, in order to have space for a title (text), the legend, etc. To achieve
this, you can select Extend Window from the Options menu in the map window.

F The Annotation editor allows for the positioning and sizing of annotation, and for
the insertion of new annotation.

F When finished adding and editing simple annotation and when you want to keep this
annotation, you need to save the map window as a map view: in the Annotation
editor or in the map window, open the File menu and choose the Save View or the
Save View As ... command. For more information, see How to save annotation.

8.1.2 How to add coordinates to an image etc.

To add coordinates to a satellite image, to a scanned map, or to a scanned
photograph when you do not have a Digital Terrain Model (DTM), create a
georeference tiepoints. A georeference stores the relation between locations in the
image (row,col) and real world coordinates (X,Y). These locations are called
tiepoints or ground control points. A georeference uses a coordinate system.

§ In case you have a scanned photograph without fiducial marks and you have a
DTM of the area, create a georef direct linear.

§ In case you have a scanned aerial photograph with fiducial marks and a DTM,
create a georef orthophoto.

For more information on types of georeferences, see ILWIS objects : georeferences.
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The remainder of this topic deals with georeferences tiepoints.

The topic contains the following paragraphs:
1. Introduction.
2a. Creating a georef tiepoints while working with an interactive color composite, a

single band of a satellite image, a scanned map or a scanned photograph.
2b. Creating a georef tiepoints while working with a permanent color composite.
3. Adding tiepoints.
4. Adding the created georef tiepoints to all bands of a satellite image.
5. Optional resampling to a georef corners.

1.  Introduction
By creating and adding tiepoints to a color composite, one band of a satellite image,
a scanned map or a scanned photograph, the tiepoint coordinates are added to the
image, photo or map which was specified as background map.

When you were successful in creating a georef tiepoints for a color composite, a
band of a satellite image, a scanned map or a scanned photograph, you can:
§ see the coordinates according to the created georeference tiepoints on the status

line of the map window;
§ display any type of vector data on top of the map;
§ create new vector data using the georeferenced image as background;
§ update vector data using the georeferenced image as background;
§ use the map in pixel info;
§ rasterize any vector data on this georeference (for map calculations);
§ you can also resample the image which has a georeference tiepoints to a

georeference corners, or vice versa, in order to perform raster operations in
which raster maps with different georeferences need to be combined;

§ screen digitize on satellite images or on scanned photographs which have a
georef tiepoints.

2a.  Creating a georef tiepoints while working with an interactive color
composite, a single band of a satellite image, a scanned map or a scanned
photograph
§ Display in a map window:

– an interactive color composite (create a map list of all bands of an image and
double-click the map list in the Catalog or use the Show Map List as Color
Composite option), or

– one of the bands of your satellite image, or
– a scanned map, or
– a scanned photograph.

§ Choose the Create Georeference command from the File menu in the map
window. In the subsequent Create Georeference dialog box, type a name for the
georeference, choose for a Georef Tiepoints and select a coordinate system.
When you click the OK button, the Georeference Tiepoints editor is
automatically started in the map window.

You can now add tiepoints to the georeference tiepoints: continue with step 3.



How to add… How to…

ILWIS 2.2 Guide 229

2b.  Creating a georef tiepoints while working with a permanent color
composite
When your graphics board cannot be configured to use more than 256 colors (see
Display Settings in Windows' Control Panel), you need to create a permanent color
composite with the Color composite operation. A permanent color composite is
available in the Catalog and is stored on disk.
§ Create a permanent color composite (from the Operations menu in the Main

window, choose Image Processing and Color Composite);
§ Open the Properties dialog box of the color composite;
§ In the Raster Map Properties dialog box, click the Break Dependency Link

button (if available);
§ Show the map in a map window, choose Create Georeference command from

the File menu in the map window, In the subsequent Create Georeference dialog
box, type a name for the georeference, choose for a Georef Tiepoints and select a
coordinate system. When you click the OK button, the Georeference Tiepoints
editor is automatically started in the map window.

You can now add tiepoints to the georeference tiepoints: continue with step 3.

Other methods
When you create a georeference tiepoints through the File menu of the Main
window, or through the Edit Properties dialog box of a raster map, you have to
open the Georeference Tiepoint editor yourself, for example by double-clicking
the newly created georeference tiepoints in the Catalog.
For more information, see How to create a georeference.

3.  Adding tiepoints
You have to add tiepoints or ground control points to the image or scanned
photograph, which is displayed in the map window of the Georeference Tiepoints
editor. Each tiepoint establishes a relation between the row and column value in the
map and an XY-coordinate.

In the Georeference Tiepoints editor, you can add tiepoints to a map in several
manners:
§ first, click at a recognizable point in the map without coordinates,
§ the Add TiePoint dialog box appears. In this dialog box, the row and column

values at the position of the click are filled out. When you already have some
tiepoints, the dialog box will also come up with a suggestion for the XY
coordinates.

Then:
§ click at the same position in a map which already has correct XY coordinates

and which is displayed in another map window (master/slave), or
§ digitize the same point in an analog paper map on a digitizer, or
§ read the correct XY coordinates for this point from an analog paper map or a

table, and type these XY coordinates in the dialog box.
For a more detailed description on inserting tiepoints (for instance Master/Slave),
refer to How to use the Georeference Tiepoints editor.
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Furthermore, for a georef tiepoints, you have to select a transformation method:
conformal, affine, second order, full second order, third order or projective. The
number of tiepoints that are required depends on this selected transformation
method.
§ For satellite imagery, an affine transformation will usually do.
§ For scanned photographs, a projective transformation is recommended.

F To judge the quality of your tiepoints while entering them in the Tiepoint editor:
§ display any existing vector data on top of the background map in the Tiepoint

editor (choose Add Data Layer from the Layers menu),
§ add tiepoints to the image or photograph in the map window, and
§ press the Redraw button .
You can now easily see whether existing roads, rivers, etc. coincide with the
background map.

4.  Editing properties of satellite bands
You have to make sure, that all maps, which exactly fit on each other also use the
same georeference. You can change the georeference of a map in the properties
dialog box of the map.

Thus, when you located the tiepoints:
§ on only one of the bands of an image (as described under 2a), or
§ on a permanent but a non-dependent color composite (as described under 2b),

you have to add the created georef tiepoints to all (other) bands of the image.

After you have finished adding tiepoints to the background map in the Tiepoint
editor:
§ Open the Properties dialog boxes of all other bands of the image;
§ Click the Edit Properties button and select the correct georef tiepoints.
See also How to view and edit properties of an object.

In case you have create a georef tiepoints (as described under 2a) for:
§ an interactive color composite, then the created georef tiepoints will be

automatically linked to all maps in the map list. You do not need to edit
properties of the individual maps in the map list.

§ a scanned map or a scanned photograph, then the created georef tiepoints be
automatically linked to the scanned map or photo. You do not need to edit
properties.

5.  Optional resampling to a georef corners
When maps use a georef tiepoints, you can decide to resample these maps to the
georeference of another existing north-oriented map to be able to combine the maps
with each other in MapCalc, etc. For more information, see Resampling :
functionality.
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8.2 How to calculate…

8.2.1 How to calculate a confusion matrix

To access the accuracy of an image classification, it is common practice to create a
confusion matrix. In a confusion matrix, your classification results are compared to
additional ground truth information. The strength of a confusion matrix is that it
identifies the nature of classification errors, as well as their quantities.

To obtain a confusion matrix
1. Have the output raster map of your image classification available; check the

Properties of the classified image to know which domain and georeference are
used by the classified image.

2. Create a raster map, which contains additional ground truth information, such a
map is also known as the test set. There are several ways to create a test set,
these are shortly described here; at the end of this topic you will find more
details of creating a test set.
– Create a new raster map with the same domain and georeference as the

classified image, and add some test pixels to this map yourself with the pixel
editor while using an existing map as a background (f.e. a land use map),

– Use an existing, recent and reliable raster map with the same domain and
georeference as the classified image directly as a test set.

– Use half of your ground truth data for the sample set before classification,
and use the other half of your ground truth data for creating a test set.

Make sure that the ground truth/test set raster map does not contain the same
pixels as the sample set raster map from the training phase. Your accuracy
assessment will show too optimistic figures when the pixels in the sample set (on
which the classification is based) are also used in the test set (with which the
classification results are checked).

3. Perform a Cross operation with your ground truth map and the classified image
to obtain a cross table.
To start the Cross operation:
– from the Operations menu in the Main window, select Raster Operations and

then the Cross command, or
– double-click the Cross item in the Operation-list, or
– use the right mouse button on your test set raster map in the Catalog and

from the context-sensitive menu select Raster Operations and Cross.

In the Cross dialog box:
– for First Map, select the test set map,
– accept the default selection of the Ignore Undefs check box for the first map,
– for Second Map, select the classified image,
– clear the Ignore Undefs check box for the second map,
– type a name for the output cross table, and
– select the Show check box to directly display the output cross table in a table

window.
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4. In the table window displaying the cross table, open the Options menu and
choose Confusion matrix.
In the Confusion matrix dialog box:
– for First Column, select the test set column in the table,
– for Second Column, select the classified image column in the table,
– for Frequency, select the NPix column in the table.

When you click OK, the confusion matrix is displayed in a secondary window.

Additional information to create a test set
1. Creating a test set yourself with the pixel editor using a background map:

– Check the domain and georeference of the classified image in the Properties
dialog box of the image. Check the georeference of the background map,
which can be for instance an existing land use map. If the background map
does not have the same georeference as your classified image, you can use
the Resample operation to resample the existing map to the georeference of
the classified image.

– Display the background raster map in a map window. It is advised to select
the Legend check box in the Display Options dialog box of this background
map.

– From the File menu in the map window, choose the Create Raster Map
command to create an empty ground truth map. In the Create Raster Map
dialog box: type a new name for the ground truth map; accept the
georeference of the classified image; and select the same domain as used by
the classified image,

– The pixel editor is opened automatically; the background map is displayed.
When you zoom in, you can start selecting and giving names to pixels in
your ground truth map.

2. Using an existing raster map or polygon map of the area:
When you have a recent and reliable polygon or raster map of the area, you can
directly use this map as the ground truth map. If the map does not have the same
domain as the classified image, you can add a column (with the domain of the
classified image) to the attribute table of the map, assign a class to each class in
the map and create an attribute map. If the map does not have the same
georeference as the classified image, you can either rasterize the polygon map on
the georeference of the image, or resample the raster map to the georeference of
the image. Then, you can directly cross the raster map with the classified image.

3. When you have collected ground truth data in the field, a calculation-wise
correct method is to use half of these data for the sample set, and the other half
for the test set.

8.2.2 How to calculate a Digital  Elevation Model

In ILWIS, you can obtain a Digital Elevation Model (DEM) by interpolation of
segments, by an interpolation of points, or by an interpolation of a raster map which
contains rasterized value segments and points.
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From Segments

Digitize the contour lines of a segment map with a value domain. Make sure that
contour lines that consist of more than one segment have the same value. Code
consistency of segments can be checked in the Segment editor.

Then perform a Contour interpolation. Contour interpolation is an operation which
first rasterizes the contour lines in a segment map with a value domain, and then
calculates values by means of a linear interpolation for pixels that are not covered by
segments. For the Contour interpolation operation, you can also use a segment map
with a class or ID domain as input, then the segment map must have an attribute
table with a value column representing height values.

To create a Digital Elevation Model from Segments
§ from the Operations menu in the Main window, choose Interpolation, Contour

Interpolation, or
§ double-click the InterpolSeg operation in the Operation-list, or
§ use the right mouse button on a segment map in the Catalog and select Contour

Interpolation from the context-sensitive menu.

The Contour Interpolation dialog box appears.

F When later on you want to create a georeference orthophoto or a georeference direct
linear, which will use the created DEM, it is strongly advised to mark the
Interpolation check box in the Raster Map Properties dialog box of the DEM.

From Points

Perform a point interpolation on your point map. A point interpolation performs an
interpolation on randomly distributed point values and returns regularly distributed
point values. This is also known as gridding. In ILWIS, the output values are raster
values.

The input map for a point interpolation is a point map where:
§ points are values (point map with a value domain), or
§ points are identifiers (point map with an ID domain) and for which elevation

values are stored in a column in a linked attribute table.

To create a Digital Elevation Model from Points
§ from the Operations menu in the Main window, choose Interpolation, Point

Interpolation, Moving Average or Moving Surface, or
§ double-click the MovAverage or MovSurface operation in the Operation-list, or
§ use the right mouse button on a point map in the Catalog and select

Interpolation, Moving Average or Moving Surface.

The Moving Average dialog box or the Moving Surface dialog box appears.

F Point interpolation is a time consuming operation, to speed up the process the user is
advised to use a relatively large pixel size during the interpolation and perform the
Densify operation after the interpolation. Densify is a raster operation which lets
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you reduce the pixel size of your map. The number of rows and columns is
increased, and new values are assigned to the pixels by means of a bilinear or
bicubic interpolation.

F When later on you want to create a georeference orthophoto or a georeference direct
linear, which will use the created DEM, it is strongly advised to mark the
Interpolation check box in the Raster Map Properties dialog box of the DEM.

From Segments with additional Point data

1. Digitize the contour lines of a segment map with a value domain. Rasterize the
segment map with the Segments to Raster operation:
– from the Operations menu in the main window, choose Rasterize, Segment to

Raster,
– double-click the SegRas operation in the Operation-list, or
– use the right mouse button on the segment map in the Catalog and select

Rasterize, Segment to Raster from the context-sensitive menu.

2a. If you have a point map with a value domain, rasterize the point map with the
Points to Raster operation:
– from the Operations menu in the main window, choose Rasterize, Point to

Raster,
– double-click the PntRas operation in the Operation-list, or
– use the right mouse button on the point map in the Catalog and select

Rasterize, Point to Raster from the context-sensitive menu.

2b. If you have a point map that contains points with identifiers (point map with an
ID domain) for which elevation values are stored in a column in a linked
attribute table,
– rasterize the point map with the Points to Raster operation (see 2a) and in the

Rasterize Point Map dialog box, select the correct column in which your
elevation data is stored.

Use the same georeference for both the rasterized segment and rasterized point
map.

3. Then, combine the two raster maps by typing the following MapCalc expression
on the command line of the Main window:
pntseg = iff(isundef(pntras), segras, pntras)
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in which:
pntseg is the output raster map name of the combined point and segment map
pntras is the name of the rasterized point map
segras is the name of the rasterized segment map

4. Finally, interpolate the pntseg raster map, which contains the rasterized
segments and the rasterized points. Type on the command line of the Main
window:

DEM = mapinterpolcontour(pntseg)

Visualize a DEM

To visualize a DEM, you can simply the DEM in a map window or apply the
Shadow filter on the DEM and display the filtered map in a map window; you can
overlay the contour lines in one color. Further, you can use Display 3D to create a
three-dimensional view of your study area. For more information and an example,
see How to display Digital Elevation Models.

8.2.3 How to calculate the Optimum Index Factor (OIF)

To obtain multivariate statistical information on a data set, you can calculate the
Optimum Index Factor (OIF) for any combination of three bands within your map
list. The Optimum Index Factor (OIF) is a statistic value that can be used to select
the optimum combination of three bands in a satellite image with which you want to
create a color composite. The optimum combination of bands out of all possible 3-
band combinations is the one with the highest amount of 'information' (= highest
sum of standard deviations), with the least amount of duplication (lowest correlation
among band pairs).

To calculate and show the Optimum Index Factor
1. Create a map list, which contains the multi-spectral bands of your satellite

image. For more information, refer to How to create a map list.
2. Calculate a variance-covariance matrix or a correlation matrix for the maps in

the map list:
– in the Main window, open the Operations menu, choose Statistics, Map List

and the Variance-Covariance or Correlation command, and select a map list,
or

– double-click the VarCovMat or the CorrMat operation in the Operation-list,
and select a map list, or

– press the right mouse button on the map list in the Catalog, choose Statistics
and Variance-Covariance or Correlation from the context-sensitive menu.

For more information, refer to Variance-covariance matrix or to Correlation
matrix.

3. Open the Properties of the map list:
– from the Edit menu in the Main window, choose Properties, and select the

map list, or
– press the right mouse button on the map list in the Catalog, and choose

Properties from the context-sensitive menu.
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The Map List Properties dialog box appears.
4. Click the Additional Info button in the Map List Properties dialog box.

A dialog box appears which displays the ranked OIF values and corresponding band
combinations. For more information on the interpretation the OIF values, refer to
Optimum Index Factor: functionality / algorithm.

Note: The Additional Info button will not appear in the Map List Properties dialog
box when a Variance-covariance matrix or a Correlation matrix has not been
calculated yet for the map list.

8.3 How to calculate (Advanced)…

8.3.1 How to calculate a cross-section through the terrain

This topic describes how you can make a cross-section through (a part of) your
study area. In general, the procedure is as follows:
1. Choose the location of the cross-section and make raster map which only shows

the pixels of the cross-section.
You can also screen-digitize one segment along which you want to obtain a
cross-section.

2. Convert the raster map to a points map, or convert the segment map to a point
map.

3. Open the point map as a table and perform a calculation on the point data so that
for the coordinates of all points, the height information is retrieved from a
DEM.

4. Finally, make a graph to show the cross-section.

Choosing the location of the cross-section
Open some satellite images and raster maps. You can use for instance the TMbands
or the Geology or Landuse maps from the Cochabamba area. Furthermore, it is
assumed that you already created a DEM from the area.

Column 165 in the Geology map seems to cover many different terrain units and is
chosen as the line along which the cross-section should be made. To make a raster
map showing the cross-section, use the formula:

crosssec = IFF(%C=165, geology,?)

In this expression, you specify with %c the column number along which you want to
obtain the geology class names.
Raster map crosssec only shows the geological classes along column 165; all
other pixels of this map are undefined.

Convert the raster map to a point map
Drag raster map crosssec from the Catalog to the RasPnt operation in the Operation-
list. The Raster to Points dialog box appears:
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§ Fill out the name of the output point map; you can use map name crosssec
again as the extension of a point map (.MPP) is different from the extension of a
raster map (.MPR).

§ Furthermore, you can mark the Show check box.
The output point map will be calculated.

In the Display Options dialog box of the point map, accept the default representation
and click on OK. The point map will appear on the screen.

(When you screen-digitized a segment along which you want to obtain the cross-
section, use the Segments to Points operation. The operation extracts points at
regular distances along the segment; you have to specify the distance between the
subsequent point coordinates (e.g. 20m).)

Open the point map as a table and performing calculations in the point table
To open the point map as a table, click point map crosssec in the Catalog with
the right mouse button, and choose Open as table from the context-sensitive menu.

The table shows all points. Columns X and Y are the XY-coordinates of the points
and column Name shows the geology class of each point.

X Y Name
21 798770.00 8090110.00 Shales
22 798770.00 8090090.00 Shales
23 798770.00 8090070.00 Shales
24 798770.00 8090050.00 Shales
25 798770.00 8090030.00 Shales
26 798770.00 8090010.00 Shales

When you would like to retrieve land use information for all points, i.e. to find out
about the land use type at each point coordinate, you can type the following formula
on the command line of the table window:

Landuse = MAPVALUE(landuse,COORD(X,Y))

For each XY-coordinate in the point table, the land use class as found in raster map
Landuse at that coordinate will be retrieved; this is stored in column Landuse.
Accept the defaults in the Column Properties dialog box and click OK.

The new column is calculated and appears in the table.
X Y Name Landuse

629 798770.00 8077950.00 Lake deposits Agriculture
630 798770.00 8077930.00 Lake deposits Agriculture
631 798770.00 8077910.00 Lake deposits Agriculture
632 798770.00 8077890.00 Lake deposits Agriculture
633 798770.00 8077870.00 Lake deposits Urban periphery
634 798770.00 8077850.00 Lake deposits Urban periphery
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In the same way, height information can be retrieved for each point coordinate. You
can use the same MAPVALUE function, but this time you will information from
raster map DEM:

Altitude = MAPVALUE(dem,COORD(X,Y))

For each XY-coordinate, column Altitude contains the elevation values as found in
the Digital Elevation Model.

X Y Name Landuse Altitude
21 798770.00 8090110.00 Shales Grassland   4260.0
22 798770.00 8090090.00 Shales Grassland   4257.8
23 798770.00 8090070.00 Shales Grassland   4256.7
24 798770.00 8090050.00 Shales Grassland   4254.4
25 798770.00 8090030.00 Shales Grassland   4253.0
26 798770.00 8090010.00 Shales Grassland   4252.7

Furthermore, you can see that the difference between each subsequent Y-coordinate
is 20m; this is the pixel size of the original raster map from which you extracted the
points.
To make a distance axis in kilometers for the graph, you can use the following
expression:

Distance = %r * 20 / 1000

In this expression, %r depicts the record numbers; these are multiplied by 20m and
divided by 1000. The answers are stored in column Distance.

X Y Name Landuse Altitude Distance
21 798770.00 8090110.00 Shales Grassland   4260.0    0.420
22 798770.00 8090090.00 Shales Grassland   4257.8    0.440
23 798770.00 8090070.00 Shales Grassland   4256.7    0.460
24 798770.00 8090050.00 Shales Grassland   4254.4    0.480
25 798770.00 8090030.00 Shales Grassland   4253.0    0.500
26 798770.00 8090010.00 Shales Grassland   4252.7    0.520

(When you screen-digitized a segment from which you extracted points, then
multiply the record numbers with the distance value that you specified in the
Segments to Points operation, and divide by 1000 if you want to obtain values in
kilometers.)

Displaying the cross-section as a graph
Now you can display the cross-section by making a graph, which shows the relief
values along the distance values. From the Options menu in the table window,
choose Show Graph.
The Edit Graph dialog box appears:
§ For the X-axis, select: Distance.
§ For the Y-axis, select: Altitude.

Accept other defaults, click OK, and the graph is displayed on the screen.
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In this case, you can also choose column Y for the X-axis of the graph, because the
points were extracted along a column of a north-oriented raster map; in the point
table you can see that X-coordinate values are constant and only Y-coordinate
values change.

The graph shows the relief along the cross-section. The first point lies high in the
mountains on an altitude of around 4300 m while the end of the cross-section is in a
relatively flat area around 2500 m altitude.

8.4 How to change…

8.4.1 How to change the domain of  a map

This topic contains five sections to change the domain of a map:
§ from system domain Value to a user-defined value domain,
§ from the Image domain to system domain Value,
§ from a Class domain to an ID domain or vice versa,
§ from a Picture domain to a Class domain,
§ from a Class or ID domain to another Class, ID, or to a value domain.

From system domain Value to a user-defined value domain
When a map uses system domain Value, the map can only be displayed with a
representation gradual  (boundaries in percentages). For intermediate calculation
results, this may be fine. For a final map however, you may want to create a
representation value  (boundary values in values) so that you can assign specific
ranges of colors to specific ranges of values in the map. To be able to create a
representation value, the map with system domain Value needs to be converted
into a map with a user-defined value domain.

The legend of a map using system domain Value or a user-defined value domain
will in both cases show values. Thus it is only necessary to change the domain of a
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map with system domain Value when you want to assign specific colors to specific
values in the map, instead of to percentages.

To convert a map (e.g. Map1) with system domain Value to a map (e.g. Map2)
with a user-defined value domain:
§ Type a simple MapCalc formula on the command line of the Main window, like

Map2 = Map1
§ In the Raster Map Definition dialog box, check the minimum and maximum

values as stated under Value Range and Precision which would be used for the
output map if you would accept the default system domain Value again;

§ However, instead of accepting system domain Value in the Raster Map
Definition dialog box, click the create domain button in the Raster Map
Definition dialog box to create a new value domain;

§ In the appearing Create Domain dialog box, type a new name for your new value
domain and select the Value option button.
Click the OK button in the Create Domain dialog box.

§ Then, in the appearing Edit Domain Value dialog box, type the minimum and
maximum values as well as the precision for this new value domain. You can
use the value range and precision as found in the Raster Map Definition dialog
box, widen the value range and/or increase or decrease the precision. In any
case, specify a value range and precision that fit the values in your map.

§ Click the OK button in the Edit Domain Value dialog box.
§ The Raster Map Definition dialog box will be activated again. The newly created

domain appears in the Domain list box.
§ In the Raster Map Definition dialog box, type values for the value range and

precision for the output map; these can be the same values as used in the Edit
Domain Value dialog box.

§ Click the OK button in the Raster Map Definition dialog box.

To create a user-defined representation for your map (Map2) with the user-defined
value domain:
§ Display Map2 and in the map's Display Options dialog box, click the create

representation button. The Create Representation dialog box will appear: type a
name and optionally a description for your new representation value.
Click the OK button in the Create Representation dialog box.

§ The Representation Value editor will be opened and you can see that values of
your domain are used for the limits, i.e. the boundary values.
Insert limits, choose or create colors for each limit, specify whether to stretch
colors in between limits or use the color of the upper or lower limit, and in case
of stretching colors, specify the number of stretch steps.

§ When finished, click the OK button in the Display Options dialog box. You do
not have to close the Representation Value editor window.

§ You can continue to edit your representation value, in the Representation Value
editor and redrawing the map in the map window.

§ When you already closed the Representation Value editor, you can open it again
by selecting the Representation command from the Edit menu in the map
window. Edit the representation value and redraw the map.
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§ When you want to create another representation value for the map, choose
Display Options from the Layers menu. In the appearing Display Options dialog
box of the map, click the create representation button.

From domain Image to system domain Value
You can use a very simple MapCalc statement; type on the command line something
like:
mapval = mapimg

where mapimg is the name of your image and mapval is the name of the output
map.
In the Raster Map Definition dialog box that follows directly after you typed the
statement, select system domain Value, and specify minimum 0, maximum 255,
precision 1.

From a Class domain to an ID domain or vice versa
In some cases you may want to change from classes to IDs or vice versa.
§ In the Catalog, click a map with the right mouse button, and choose Properties.

In the map's properties dialog box, check which domain the map is using.
§ In the Catalog, click the domain with the right mouse button, and choose

Properties.
§ In the Domain Properties dialog box, click the button Convert to Classes or the

button Convert to Identifiers.

Mind: when converting classes to IDs, you should keep in mind that an ID domain
does not use a representation.

From a Picture domain to a class domain
After import, you may find that a raster map has a Picture domain. The colors of the
map seem OK but when you want to perform calculations with this map, it is
strongly advised to first convert the domain of the map from a Picture domain to a
Class domain.
§ In the Catalog, click the raster map with the right mouse button, and choose

Properties.
§ In the Raster Map Properties dialog box, check which Picture domain the map is

using.
§ In the Catalog, click the Picture domain with the right mouse button, and choose

Properties.
§ In the Domain Properties dialog box, click the button Convert to Classes.

The domain will contain as many classes as you had colors before. The classes will
obtain default class names, like Class1, Class2, etc. In the domain Class/ID editor,
you can change these default class names. The colors of the Picture domain will now
be available in the representation of the Class domain.

From a Class or ID domain to another Class, ID, or value domain
In short, you have to add a column with the correct domain to an attribute table of
the original map and then you have to create an attribute map of the original map.
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When your original map does not have an attribute table yet:
§ In the Catalog, click a map with the right mouse button, and choose Properties.
§ In the map's Properties dialog box, select the Attribute Table check box, and

click the create button.
§ A table will be created with the same domain as the map and the table will be

displayed in a table window.
§ Proceed with the section below.

When your original map already has an attribute table:
§ Add a column to the table and select for this column the correct domain.
§ Fill the column with values, classes or IDs as you like:

– the domain of the table (gray) shows the current class names or IDs in your
map;

– the class names, IDs or values in your column represent the correct class
names, IDs, or values that you want to assign to the map.

§ In the Catalog, click the map with the right mouse button and choose Raster
Operations, Attribute Map (when you are working on a raster map) or Vector
Operations, Attribute Map (when you are working on a polygon, segment or
point map).

§ In the appearing dialog box Attribute map of Raster/Polygon/Segment/Point
map,
– the name of the map is already filled out,
– the attribute table currently linked to this map is already filled out,
– select the attribute column in which you filled out the correct class names,

IDs, or values
– fill out the rest of the dialog box, and click OK.
The output map will by default use the same domain as the column you selected
from the table.

For more information, see the Attribute map of raster map, Attribute map of polygon
map, Attribute map of segment map, Attribute map of point map.

8.5 How to create…

8.5.1 How to create a color composite

A color composite is created by combining three raster images (bands/maps). One
map is displayed in shades of red, one in shades of green and one in shades of blue.
Putting the three bands together in one color composite can give a better visual
impression of the reality on the ground, than displaying one band at a time.

There are three types of color composites: natural color composites, pseudo natural
color composites and false color composites. Natural color composites are made of
the green, blue and red part of the spectrum. This results in an image with realistic
colors. A pseudo color composite is created with other parts of the spectrum, but the
result has natural looking colors. In false color composites the colors in the image
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are not the same as in reality: for instance, healthy vegetation is red and urban areas
are blue.

In ILWIS, there are two ways in which you can display or create a color composite:
§ by showing a map list as a color composite; the resulting color composite is

displayed in a map window (interactive color composite), and
§ by using the Color composite operation; the resulting color composite is stored

as a raster map on disk (permanent color composite).

Interactive color composites
An interactive color composite can be created when your graphics board is
configured to use more than 256 colors, for instance High Color 16-bit, or True
Color 24-bit (see Display Settings in Windows' Control Panel).

To use an interactive color composite:
§ from the Operations menu in the Main Window, choose Visualization, Show

Map List as Color Composite, or
§ double-click the ColorComp item in the Operation-list.

The Show Map List as Color Composite dialog box appears; select a map list.

Subsequently, the Display Options - Map List as Color Composite dialog box
appears; this dialog box will furthermore directly appear:
§ when you use the right mouse button on a map list in the Catalog and select

Visualization, as Color Composite from the context-sensitive menu,
§ when you double-click a map list in the Catalog, and the map list contains raster

maps with the Image domain or a value domain.

In the Display Options - Map List as Color Composite dialog box:
§ from the map list, select three raster maps (domain Image or a value domain)

which should be displayed in Red, Green and Blue,
§ for each map, specify the stretch range.

The interactive color composite is displayed in a map window.
§ You can easily change intervals, select other bands, etc. by changing the display

options of the map list. Open the Layers menu in the map window, choose
Display Options and select the map list, or use the right mouse button in the map
window and select the map list from the context-sensitive menu.

§ To save an interactive color composite, save the contents of the map window as
a map view. Open the File menu in the map window and choose the Save View
command.

Permanent color composites
The output of the Color composite operation is stored as a raster map on disk.
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To create a permanent color composite:
§ from the Operations menu in the Main Window, choose Image Processing, Color

Composite, or
§ double-click the  ColorComp operation in the Operation-list, or
§ drag an image from the Catalog to the  ColorComp operation in the Operation-

list.

The Color Composite dialog box appears:
§ select three raster maps (only domain Image allowed) which should be

displayed in Red, Green and Blue.
§ specify the type of color composite which you want to create:

– standard color composite: choose between linear stretching (values or
percentage intervals) and histogram equalization,

– dynamic color composite: specify the number of output colors,
– 24-bit color composite (when your graphics board is configured to use more

than 256 colors): choose between linear stretching (values or percentage
intervals), histogram equalization or use instead of images, Hue, Saturation
and Intensity bands as input.

8.5.2 How to create a georeference

A georeference stores the relation between rows and columns of a raster map
(row,col) and real world coordinates (X,Y) or (X,Y,Z). A georeference is needed for
raster maps. A georeference uses a coordinate system.

It is advised that raster maps of the same area use the same georeference, because
raster operations in which raster maps are combined will only make sense if the
pixels in the maps refer to the same area on the ground.

There are basically five types of georeferences:
§ georeference corners:  a North-oriented georeference to be used during

rasterization of vector data or as the North-oriented georeference to which you
want to resample maps;

§ georeference tiepoints: a non-North-oriented georeference to add coordinates to
a satellite image or to a scanned photograph, a scanned map, etc. without using a
DTM;

§ georeference direct linear: to add coordinates to a scanned photograph while
using a DTM;

§ georeference orthophoto: to add coordinates to a scanned photograph while
using a DTM and camera parameters;

§ georeference 3D: to create a three dimensional view of maps.

General ways to create a georeference
To create any kind of georeference, you can open the File menu of the Main window
and choose Create Georeference, or double-click the New Georef item in the
Operation-list. The Create Georeference dialog box will appear. You can create a
georef corners, a georef tiepoints, a georef direct linear, a georef orthophoto or a
georef 3D.
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When an image, a scanned map or a scanned photograph is displayed in a map
window, you can open the File menu in the map window, choose Create
Georeference. The Create Georeference (in map window) dialog box will appear.
You can create a georef tiepoints, a georef direct linear or a georef orthophoto.

Finally, also through the Edit Properties dialog box of a raster map, you create a new
georeference by clicking the create georeference button. The Create Georeference
(through Properties) dialog box will appear. You can create a georef corners, a
georef tiepoints, a georef direct linear or a georef orthophoto.
For more information, see How to view and edit the properties of an object.

To create a georeference corners during a Rasterize operation
When rasterizing vector maps, you can directly create a georeference corners for the
output raster map by clicking the create georeference button in the dialog box of the
Rasterize operation. The Create Georeference (during Rasterize) dialog box appears
in which you can specify the pixel size and the boundaries of the map.
When rasterizing maps of the same area, it is usually sufficient to only once create a
georeference corners; for the other maps to be rasterized, select this same
georeference.

To add tiepoints to an image, a scanned photograph or a scanned map
To add tiepoints to a satellite image, a scanned photograph or a scanned map, first
display the image, photo or map in a map window. Then, open the File menu in the
map window, and choose the Create Georeference. The Create Georeference (in map
window) dialog box appears.
Choose whether you want to create a georef tiepoints, a georef direct linear or a
georef orthophoto.

In case of creating a georef tiepoints or a georef direct linear, the Tiepoint editor will
be opened.
In case of creating a georef orthophoto, first the Locate Fiducial Marks dialog box
will be opened in which you can specify the principle distance of the camera and in
which you can reference the fiducial marks of the scanned aerial photograph. After
that, the Tiepoint editor will be opened.

In the Tiepoint editor, you can insert tiepoints, also called ground control points,
which establish relationships between the map pixels (row,col) and XY- or XYZ-
coordinates.

F When you want to use a created georef tiepoints for all bands of a satellite image:
after you have finished adding tiepoints to a background map in the Tiepoint editor,
you have to add the created georef tiepoints to all other bands. This can be done by
opening the Properties dialog boxes of the other bands, click the Edit Properties
button, then select the correct georef tiepoints.
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For more information and tips, refer to the Create Georeference dialog boxes
mentioned above or to How to add coordinates to a satellite image, How to screen
digitize, How to monoplot, How to create an orthophoto.

To create a georeference 3D
To obtain a three-dimensional view of your study area, select Visualization, Display
3D on the Operations menu in the Main window or double-click the Display 3D
item in the Operation-list. In the Display 3D dialog box, click the create
georeference button. The Create Georeference 3D dialog box appears. Then, after
the Display Options 3D Grid dialog box in which you can specify whether you want
to see your 3D view with grid lines with or without a raster map drape, a map
window is opened with an initial georeference 3D.

To modify the 3D parameters, select Georeference from the Edit menu in the map
window and the Georeference 3D editor is started. Change the 3D parameters as you
wish and exit the editor. The last set of parameters is stored in the georeference 3D.

The 3D view is displayed in a map window. If you like, you can add any other
vector map or annotation to this map window. You can save the 3D view in the map
window as a map view. To permanently apply a georeference 3D to a raster map,
use the Apply 3D operation.

8.5.3 How to create an orthophoto

An orthophoto is a rectified (North-oriented raster map with square pixels) scanned
photogrammetric aerial photograph with corrections for tilt and relief displacement.
An orthophoto is obtained by resampling a photograph, which has a georef
orthophoto to a georef corners.

Requirements
§ a  scanned photogrammetric aerial photograph on which you can distinguish 2,

3, or 4 fiducial marks;
§ known principal distance of the photogrammetric camera;
§ Digital Terrain Model (DTM) of the area.

1.  Creating a georef orthophoto
You need to create a georeference orthophoto for the scanned photograph.
The process is described in topic How to monoplot, steps 1 - 4.

F For a correct behaviour of a georef orthophoto, it is essential that you have marked
the 'Interpolation' check box in the Properties dialog box of your DTM raster map.
For more information, refer to the Raster Map Properties dialog box.

When finished creating and editing a georef orthophoto, leave the Tiepoint editor
and close the map window as well.
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2.  Resampling the scanned photo
Once you have a georeference orthophoto for your scanned aerial photograph, the
only step you have to take is to resample the photograph to a North-oriented georef
corners.

Usually, you will already have a georeference corners, e.g. the one on which you
rasterized your Digital Terrain Model (DTM). In case you do not have a
georeference corners yet, create one, for instance by clicking the create button in the
Resample dialog box.

To start the Resample operation:
§ choose Image Processing, Resample from the Operations menu in the Main

window, or
§ double-click the Resample operation in the Operation-list, or
§ click the scanned photograph in the Catalog with the right mouse button, then

choose Image Processing, Resample from the context-sensitive menu.
The Resample dialog box will appear.

In the Resample dialog box:
§ select for the input raster map your scanned aerial photograph (which uses a

georef orthophoto),
§ select for the target georeference a georeference corners,
§ choose for nearest neighbour, bilinear interpolation or bicubic interpolation,
§ type a name for the output raster map,
§ optionally, type a description for the output map.

For each pixel in the output map, a value will be retrieved from the nearest pixel in
the input map, or a value will be calculated from 4, or 16 near pixel values in the
input map.

Finally, display the output map in a map window.

F When you add grid lines to the resampled photo in the map window, the grid lines
will be straight and perpendicular to each other.

8.5.4 How to create a representation

A representation defines the manner in which the classes of a map with a class
domain, a group domain or a picture domain, or the values of a map with a value
domain or the image domain should be represented on the screen and on a printer.

A representation stores colors or ranges of colors for the classes in a class domain,
or for specific values or ranges of values for the values in a value domain.
Furthermore, for polygon classes, colors, hatching and patterns can be stored; for
segment classes, colors, line types and line widths, etc. can be stored; and for point
classes, colors, symbols, symbol sizes, etc. can be stored.
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A representation is a service object for a domain, i.e. a domain uses a certain
representation.

Maps with a Bool, the Bit, an ID, or the Color domain do not have a stored
representation on disk:
§ For maps with a Bool domain or the Bit domain, you can interactively select

colors in the Display Options dialog box of the map each time you show the map
§ Maps with an ID domain can be shown in 7, 15, or 31 colors to inspect the map

itself. In most cases however, you will display an ID map by one of its attributes
as stored in the map's attribute table; to do so, select the Attribute check box in
the Display Options dialog box of the ID map and select an attribute column

§ Raster maps with the Color domain store colors in each pixel, so no
representation is needed

Furthermore, special options for point symbols available in the Display Options
dialog box of a point map.

To create a new representation for a class, group or value domain
§ in a Display Options dialog box of a map with a class, group or value domain,

click the little create button  next to the Representation list box, or
§ in the Properties dialog box of a domain, click the little create button  next to the

Representation list box, or
§ from the File menu of the Main window, choose Create Representation, or
§ in the Operation- list, double-click the New Repr item.
For more information on obtaining a Display Options dialog box or a Properties
dialog box, see below.
The Create Representation dialog box will appear. A newly created representation
will be directly linked to the specified domain.

Representation types
When you create a new representation for (a map with):
§ a class domain: you create a representation class;
§ a user-defined value domain: you create a representation value;
§ the system domain Value: you create a representation gradual;
§ any other system value domain: you create a representation value.
For more information on representation types, see ILWIS objects: representations.

Depending on the type of representation you are creating, the Representation Class
editor is opened or the Representation Value/Gradual editor is opened.

Representation Class editor
In the Representation Class editor, you can for each class in the domain:
§ select or create a color (raster form);
§ select or create a color and select a hatching type or a pattern (polygon form);
§ select or create a color, select a line type (e.g. single, double, triple, dot, dash

dot, blocked), specify line width, have an optional support line, etc., or a symbol
font and a symbol which will be used to draw lines (segment form);

§ select or create a color, select a simple symbol or a symbol from any installed
symbol font,  specify symbol size, etc. (point form).
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Furthermore, you can assign a single color or a smooth range of colors to multiple
selected classes.

Representation Value/Gradual editor
In the Representation Value/Gradual editor, you can:
§ insert limits, i.e. boundary values for a representation value, or percentages for a

representation gradual,
§ choose or create a color for each limit,
§ indicate whether to stretch colors between the limits or to use the color of the

upper of lower boundary,
§ when you stretch in between limits: the number of steps to be used for stretching

the colors.

Mind: When a map uses the system domain Value and you create a representation
gradual, then in the Representation editor, boundary values can only be specified in
percentages.
For value maps which have a specific meaning (e.g. height values) and which need
fixed colors, it is therefore advisable to create a user-defined value domain and a
user-defined representation value. Then, in the Representation editor, you can insert
boundary values as values.
To convert a map, which uses system domain Value to a map with a user-defined
value domain, see How to change the domain of a map.

F To show representations in the Catalog, refer to How to customize the Catalog.

To obtain a Display Options dialog box
§ in the Catalog, double-click a map which uses a class, group, value, or picture

domain, or
§ from the File menu in the Main window, choose Open, and select a map which

uses a class, group, value, or picture domain.
A Display Options dialog box will appear.

To obtain a Domain Properties dialog box
§ from the Edit menu in the Main window, choose Properties and select a class,

group, value, or picture domain, or
§ in the Catalog, click a class, group, value, or picture domain with the right

mouse button, and select Properties from the context-sensitive menu.
The Domain Properties dialog box will appear.

8.5.5 How to create a sample set for image classif ication

To perform an image classification, a sample set has to be created. Then, you can
sample training pixels: assign class names to groups of pixels with similar spectral
values and that are supposed to represent a known feature on the ground.
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A sample set consists of:
§ a reference to a map list, that is the set of images you want to classify in a later

stage; the images in the map list are used to extract sample statistics during
sampling and display these in feature spaces,

§ a reference to a class domain, that is the collection of class names that you want
to assign to your training pixels,

§ a reference to a sample set raster map which is automatically created and obtains
the same name as the sample set; this map contains the locations of the training
pixels and the class names assigned to them.

§ when your graphics board is configured to use 256 colors, a reference to a
background map, that is the map on which you can locate your training pixels;
this background map can for instance be a color composite.

F When your graphics board is configured to use more than 256 colors, you will use
an interactive color composite; then, a background map on disk is not used. For
more information, refer to How to create a color composite.

To create a sample set
§ from the File menu in the Main window, choose Create Sample Set, or
§ in the Operation-list, double-click the item New SmpleSet, or
§ in the Operation-list, double-click the item Sample Map, or
§ from the Operations menu in the Main window, choose Image Processing,

Sample.

By the first two actions, the Create Sample Set dialog box will appear. In the this
dialog box, you can specify the sample set's name, and the domain, map list, and
background map that you want to use during sampling.
By the last two actions, the Sampling dialog box appears in which you can select an
existing sample set, for instance to add more training pixels, but you can also create
a new sample set by clicking the little create button. If the create button is used, the
Create Sample Set dialog box will follow.

When everything is OK, the sample set editor is started which allows you to select
training pixels, show feature spaces, etc.

8.6 How to display…

8.6.1 How to display a map l ist as a sl ide show

With Slide Show, you can display multiple raster maps that are combined in a map
list as a slide show in a map window. The maps of the map list are displayed one
after the other in the map window at a user-specified rate. A slide show is designed
to present multi-temporal changes in maps.

Raster maps that you can include in a map list for a slide show may be:
§ satellite images of the same area of for instance different months,
§ derived products from satellite images, such as NDVI maps, of for instance

different months,
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§ classified satellite images of for instance different months or years,
§ thematic raster maps (e.g. land use maps) of for instance different years.

A slide show is in fact the same as repeatingly replacing raster maps in a map
window, e.g. by dragging raster maps from the Catalog one by one into a map
window.

To create a map list
The first step of making a slide show is to create a map list of all the raster maps that
you want to show. For more information, refer to How to create a map list.

To start a Slide Show
There are several ways in which a slide show can be started:
§ From the Operations menu in the Main window, choose Visualization, Show

Map List as Slide Show, and select a map list in the Show Map List as Slide
Show dialog box, or

§ Double-click the Slide Show item in the Operation-list and select a map list, or
§ Use the right mouse button on a map list in the Catalog and select Visualization,

as Slide Show from the context-sensitive menu, or
§ Drag a map list from the Catalog to the Slide Show item in the Operation-list, or
§ Double-click a map list in the Catalog; the map list should contain raster maps

which do not use the Image domain nor another value domain (if they do, an
interactive color composite will be shown), or

§ From the File menu in the Main window, choose Open and select a map list in
which the raster maps do not use the Image domain nor another value domain
(if they do, an interactive color composite will be shown), or

§ Drag a map list to an existing map window. A small dialog box will appear
asking you whether the maps in the map list should be displayed as a Color
Composite or as a Slide Show; choose Slide Show.

A Display Options dialog box appears for the first raster map of the map list.
§ specify the display options, these settings will be used for all the maps in the list.

The Display Options - Map list as slide show dialog box appears.
§ specify the number of maps you want to see per minute as the Refresh Rate.

The Slide Show will start after you press the OK button.

F A map list can only be created of raster maps that have the same georeference and
the same domain.

F If the refresh rate is set to zero, it means that the maps will not be refreshed
automatically. To show the next slide, click the Redraw button in the button bar of
the map window or press Ctrl+R on the keyboard.

F To stop the show, press Esc. To restart the show, press the Redraw button.
F When you create a map list of raster maps that are the outcome of the Apply 3D

operation (for instance depicting the same area in three dimensions but from
different angles), and display this map list as a slide show, you can obtain a kind of
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rotating DEM with raster drape. For more information, refer to Display 3D and
Apply 3D.

8.7 How to edit…

8.7.1 How to edit  a georeference

A georeference stores the relation between rows and columns of a raster map
(row,col) and real world coordinates (X,Y) or (X,Y,Z). A georeference is needed for
raster maps. A georeference uses a coordinate system.

There are basically five types of georeferences:
§ georeference corners: a North-oriented georeference to be used during

rasterization of vector data or as the North-oriented georeference to which you
want to resample maps;

§ georeference tiepoints:  a non-North-oriented georeference to add coordinates
to a satellite image or to a scanned photograph, a scanned map, etc. without
using a DTM;

§ georeference direct linear:  to add coordinates to a scanned photograph while
using a DTM;

§ georeference orthophoto: to add coordinates to a scanned photograph while
using a DTM and camera parameters;

§ georeference 3D:  to create a three dimensional view of maps.

Other types of georeferences (non-editable) are obtained when performing an
operation on raster maps:
§ georeference factor: created by the Aggregate map and the Densify operation;
§ georeference mirrorrotate: created by the MirrorRotate operation;
§ georeference submap: created by the Sub-map of raster map and the Glue raster

maps operation.
Further, you can have georeference None for raster maps without a georeference
(not advised).

F You can see the type of a georeference by viewing the properties of a georeference.
F To be able to calculate with raster maps, it is advised that raster maps of the same

area use the same georeference corners or the same georeference tiepoints.
F To have a raster map use another georeference than its current one, perform the

Resample operation.
F To show georeferences in the Catalog, refer to How to customize the Catalog.

To edit a georeference
§ double-click a georeference in the Catalog, or
§ click a georeference in the Catalog with the right mouse button, and choose

Open from the context-sensitive menu,
§ open the Edit menu in the Main window, choose Edit Object and select any

georeference, or
§ in the Operation-list, double-click the Edit item, and select any georeference, or
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§ drag any georeference from the Catalog to the Edit item in the Operation-list, or
§ when a raster map is displayed in a map window, you can also choose the

Georeference command on the Edit menu in the map window.

Depending on the type of the georeference you selected (or on the type of the
georeference of the raster map in the map window), a dialog box will appear or an
appropriate editor will be opened:
§ for a georef corners: the Edit Georeference Corners dialog box will appear;
§ for a georef tiepoints, a georef direct linear, or a georef orthophoto: the Tiepoint

editor will be opened. When editing a georef orthophoto, the Locate Fiducial
Marks dialog box will appear first;

§ for a georef 3D: the Display Options - 3D Grid dialog box appears, in which you
can specifying how the 3D view should be displayed in the map window. When
the 3D view is displayed in a map window, you can select the Georeference
command from the Edit menu of the map window to edit the georeference 3D.
The Georeference 3D editor is started with the Georeference 3D editor: Edit
dialog box.

8.7.2 How to edit  a representation

A representation defines the manner in which the classes of a map with a class
domain, a group domain or a picture domain, or the values of a map with a value
domain or the image domain should be represented on the screen and on a printer.

A representation stores colors or ranges of colors for the classes in a class domain,
or for specific values or ranges of values for the values in a value domain.
Furthermore, for polygon classes, colors, hatching and patterns can be stored; for
segment classes, colors, line types and line widths, etc. can be stored; and for point
classes, colors, symbols, symbol sizes, etc. can be stored.

A representation is a service object for a domain, i.e. a domain uses a certain
representation.

Maps with a Bool, the Bit, an ID, or the Color domain do not have a stored
representation on disk:
§ For maps with a Bool domain or the Bit domain, you can interactively select

colors in the Display Options dialog box of the map each time you display the
map;

§ Maps with an ID domain can be shown in 7, 15, or 31 colors to inspect the map
itself. In most cases however, you will display an ID map by one of its attributes
as stored in the map's attribute table; to do so, select the Attribute check box in
the Display Options dialog box of the ID map and select an attribute column.

§ Raster maps with the Color domain store colors in each pixel, so no
representation is needed.

Furthermore, special options for point symbols available in the Display Options
dialog box of a point map.



How to… How to edit…

254 ILWIS 2.2 Guide

F You can see which representation is linked to a certain domain by viewing the
properties of a domain.

F You can see the type of a representation by viewing the properties of a
representation.

F To show representations in the Catalog, refer to How to customize the Catalog.

To open and edit a representation
§ double-click a representation in the Catalog, or
§ click a representation in the Catalog with the right mouse button, and choose

Open from the context-sensitive menu,
§ open the Edit menu in the Main window, choose the Edit Object command, and

select any representation, or
§ in the Operation-list, double-click the Edit item, and select any representation, or
§ drag any representation from the Catalog to the Edit item in the Operation-list, or
§ when a map is displayed in a map window, you can also choose the

Representation command from the Edit menu in the map window, or
§ open a class domain, and in the domain class editor, choose the Representation

command from the Edit menu.

When a map with a class domain is displayed in a map window, you can also set the
Double-Click Action in the map window to Edit Representation. For more
information, see the section on interactively changing colors in maps below.

Depending on the type of the representation you selected (or the type of the
representation of a map in a map window), the Representation Class editor or the
Representation Value/Gradual editor is opened.

For a representation class, the Representation Class editor is opened:
§ for each class in the class domain to which this representation fits, you can:

– select or create a color (raster form);
– select or create a color and select a pattern (polygon form);
– select or create a color, select a line type (e.g. single, double, triple, dot, dash

dot, blocked), specify line width, have an optional support line, or select a
symbol font and a symbol which will be used to draw lines, etc. (segment
form);

– select the symbol type, size, pen width, color and fill color (point form);
§ furthermore, you can select multiple classes and assign a single color or a

smooth range of colors to the selected classes.

For a representation value or gradual, the Representation Value/Gradual editor is
opened:
§ insert limits, i.e. boundary values for a representation value, or percentages for a

representation gradual,
§ choose or create a color for each limit,
§ indicate whether to stretch colors between the limits or to use the color of the

upper of lower boundary (slice),
§ when you stretch in between limits: the number of steps to be used for stretching

the colors.
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F For maps, which use system domain Value, only a representation gradual can be
created which works on percentages. When you want to create a representation
value (working on values) for such maps, you need to change the domain of the map
from system domain Value to a user-defined value domain. For more information,
see How to change the domain of a map.

To interactively change colors in a map
1. For maps with a class or group domain:

– Display the map in a map window and make sure that the Info check box in
the map's Display Options dialog box is marked;

– Open the Layers menu in the map window and choose the Double-Click
Action command; in the appearing dialog box, select the Edit Representation
option;

– Then, double-click the pixels, polygons, segments or points in the map: each
time an Edit Repr Item dialog box will appear in which you can directly
change colors, polygon patterns, segment line types, line widths, point
symbols, etc.

– For a polygon, segment or point map, the map window will directly show the
map in the changed representation. For raster maps, click the Redraw  button
in the map window to apply the changes;

– Continue double-clicking units in the map and editing the representation of
that class until satisfied.

For more information, see Map window: advanced functionality.

2. For any raster, polygon, segment or point map with a class, group or value
domain:
– Display the map in a map window;
– Open the Edit menu in the map window and choose the Representation

command;
– Depending on the type of representation that the domain of this map is using,

the representation class editor or the representation value/gradual editor is
opened;

– In the appearing representation editor window, edit one or more colors, etc;
– Press the Redraw  button in the map window.
– Continue editing colors in the representation editor and redrawing the map

window until satisfied.
In this way, you can work with a representation editor and a map window
simultaneously.

F You cannot edit a representation in this way when you displayed a value map in the
map window with a system representation like Gray, Pseudo, etc., or when a
representation is read-only. In those cases the Representation command is grayed
out on the Edit menu of the map window.
Instead, you can create a new representation: in the Display Options dialog box of
the map, click the create button next to the Representation list box. The Create
Representation dialog box will follow.
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§ When the map uses the Image domain or a value domain which is not system
domain Value, you will create a representation value(which works on values);

§ When the map uses system domain Value, you will create a representation
gradual (which works on percentages).

After the Representation Value/Gradual editor is opened, you can interactively edit
the new representation as described above.

Editing a representation class in table form
Advanced users may wish to edit a representation class in table form; click a
representation class with the right mouse button in the Catalog, and choose Open As
Table from the context-sensitive menu.

8.8 How to export data

Exporting data using Export

You can use Export to export ILWIS maps and tables to the following packages and
formats:
Raster: ILWIS 1.4, ILWIS 1.4 ASCII (.ASC) , Arc/Info non-compressed

ASCII (.NAS) , IDA (.IMG) , Windows Bitmap (.BMP) , Erdas
(.GIS, .LAN) , Geosoft (.GRD) , GIF images (.GIF) , Idrisi maps
(.DOC, .IMG) , PaintBrush pictures (.PCX) , Themak2 (.THR) ,
(Geo)TIFF images (.TIF) .

Vector: ILWIS 1.4, ILWIS ASCII segments(.SMT) , Arc/Info .E00 files,
Arc/Info ASCII .LIN, Arc/Info ASCII .PTS, Arc/View Shape files
(.SHP, SHX, DBF) , Atlas segment files (.BNA) , AutoCad .DXF
files, Cart/o/graphics (.CV, .VTE) , Erdas (.DIG) , Gina (.GIA) ,
HPGL (.HPG) , InfoCam (.SEQ) , Intergraph (.SIF) , Themak2
polygons (.THP) , Themak2 segments (.THS) , UseMap (.USE) .

Table: ILWIS 1.4, dBase (.DBF) , dBase-SDF (.SDF) , ASCII comma
delimited (.TXT) .

§ Open the File menu in the Main window and choose Export, or
§ Double-click the Export item in the Operation-list.
The Export dialog box will follow.

You can also export ILWIS maps and tables, and all other objects that are internally
stored as a table, to one of the formats listed above by typing an expression on the
command line or by creating a script which contains one or more export commands.
For more information, see Appendices: ILWIS script language (syntax).

Exporting data using Convert 1.4

You can use Convert 1.4 to export data to the following packages and formats:
Raster: ITC's Laboratory of Image Processing files (.LIP), Post Script level 2

(.PS).
Vector: ILWIS ASCII polygons (.SMT), ILWIS 1.2, ILWIS ASCII ArcVtp.
Table: Lotus (.DIF).
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1. First, export your data to ILWIS 1.4 format:
– Open the File menu in the Main window and choose Export, or
– Double-click the Export item in the Operation-list.
The Export dialog box will follow.

2. Then, double-click the Convert 1.4 item in the Operation-list.
The Convert program of ILWIS 1.41 will be started in a DOS box; choose
whether you want to export Vector Output, Raster Output or Table Output and
choose the format to which you want to export. Answer all questions manually.
Your data will now be available in the selected format.

8.9 How to import…

8.9.1 How to import ASCII  point data

When you have lists of coordinates with or without extra attribute data, e.g. in a
spreadsheet, you can choose to:
§ copy the Windows data to the clipboard and paste it into an ILWIS 2 table; then

you can convert the table to a point map with an attribute table, or
§ save the external data as an ASCII file and edit the ASCII file to insert a one-line

header (this simulates the ILWIS 1.4 point map file structure); then you can
import the ASCII point file as ILWIS 2 point map.

Both methods are described below; you can use the method, which suits you best.

This topic describes the tricks to obtain a point map with or without additional
attribute table from external Windows packages or from an ASCII file. You can also
use the descriptions below to obtain an ILWIS table from an external Windows
package or ASCII table.

Copying and pasting through the clipboard

1. Start the Windows application with which you normally show your point data;
e.g. a spread sheet, a data base or a Word table. Open the point data file, and:
– inspect how many columns you have;
– inspect what type of columns you have, i.e. character columns, numerical

columns (number of decimals), etc.
– Keep the Windows application open.

2. Start ILWIS and from the File menu in the Main window, choose the Create
Table command.
– In the Create Table dialog box:

– specify a new name for the table;
– choose to create a table with domain None;
– specify for the number of records: 0.

– The table is displayed in a table window.
– Add columns to the table of the correct type and make sure that you follow

the column order of the other package.
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For each column in the other package, open the Columns menu in the ILWIS
table window, and choose the Add Column command.
In the Add Column dialog box:
– type a name for the column (this is up to you, column names in ILWIS 2

can be as long as you like);
– select a domain for the column. It is advised to choose either system

domain String or system domain Value as explained below. When you
already have created domains, which fit the column data, you can choose
an existing domain.
When the other package shows:
– a coordinate column, choose for the ILWIS column the system domain
Value, and specify the number of decimals;

– a column with numbers or strings which represent the name by which
the points are identified, choose for the ILWIS column the system
domain String;

– a column with numbers representing the values of the points, choose for
the ILWIS column the system domain Value, and specify the number
of decimals;

– a column with numbers which should be considered as other attribute
information, choose for the ILWIS column the system domain Value,
and specify the number of decimals;

– a column with characters which should be considered as other attribute
information, choose for the ILWIS column the system domain String.

– optionally, type a description for the column.
– When finished adding columns, keep the table window open.

3. Return to the other Windows application, and:
– select the data which you want to copy,
– choose Edit, Copy.
The data will be copied to the clipboard. You can inspect the clipboard contents
by using the Windows Clipboard Viewer.

4. Return to your ILWIS table, and:
– make sure that no fields are selected (press the ESC key to clear any

selections);
– open the Edit menu and choose Paste.

The data is now pasted into your ILWIS table.

5. The next step is to convert any String columns in the table into class or ID
columns. Only columns containing (long) descriptions of the points, which you
do not want to use as point names, can remain columns with domain String.
In the ILWIS table:
– Double-click the column names of the columns with a String domain.
– In the appearing Column Properties dialog box, click the Create Domain

button.
– In the Create Domain for String Column dialog box:
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– type a name for a new domain;
– create an ID domain when the point names in the column are unique; if the

table contains a column with strings by which points are identified, you
should create an ID domain for that column;

– create a Class domain when the strings in the column are not unique;
– apply the new domain to the selected column.

6. You can now convert the table to a point map. Depending on whether:
– you do not mind to obtain new IDs for your points, continue with step 6a;
– your table only contains coordinate columns X, Y and one value column, e.g.

Z, continue with step 6b;
– you want to keep original IDs of the points, continue with step 6c.

6a. Although the table may have an ID column representing point names, you do not
mind to obtain new IDs for the points. The table may also contain additional
attribute information.
Use the Table to Point map operation:
– From the Operations menu in the Main window, choose the Table

Operations, Table to PointMap command, or in the Operation-list, double-
click the TblPnt item.

– In the Table to Point Map dialog box:
– select the table;
– select the column which contains X-coordinates;
– select the column which contains Y-coordinates;
– select or create a coordinate system for the point map (for more

information, see the Create Coordinate System dialog box);
– choose to use the record numbers in the table to automatically create a new

domain for the output point map;
– optionally, type a prefix for the new ID domain: every ID in the new

domain will be preceded by this prefix;
– type a new name for the output point map;
– optionally, type a description for the output point map.

Result: a point map with linked attribute table; the domain of the point map and
the attribute table contains new IDs; the point map will have a coordinate
system.

6b. Besides the coordinate columns, the table only has one value column with point
values (e.g. columns X, Y, Z).
Use the Table to point map operation:
– From the Operations menu in the Main window, choose the Table

Operations, Table to PointMap command, or in the Operation-list, double-
click the TblPnt item.

– In the Table to Point Map dialog box:
– select the table;
– select the column which contains X-coordinates;
– select the column which contains Y-coordinates;
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– select or create a coordinate system for the point map (for more
information, see the Create Coordinate System dialog box);

– choose to use the value column in the table as the domain for the output
point map;

– type a new name for the output point map;
– optionally, type a description for the output point map.

Result: a point map without attribute table; the domain of the point map is a
value domain; the point map will have a coordinate system.

6c. The table has an ID column representing point names and you want to keep these
original IDs in your point map. The table may also contain additional attribute
information.
First use the Change domain of table operation, then use the Table to Point map
operation.

Using the Change domain of table operation
The ID column with point names will become the domain of your table.
– From the Operations menu in the Main window, choose the Table

Operations, Change Domain command, or in the Operation-list, double-click
the TblChDom item.

– In the Change Domain of Table dialog box:
– select the table;
– select the ID column representing the names of the points;
– do not aggregate;
– type a new name for the output table.

– Open the output table to check the result: you will see that the point names or
point IDs are now displayed on the gray record buttons, i.e. the table now
uses a class or ID domain; the record order will be the order of the ID
domain.

Using the Table to point map operation
The table with the ID domain will be converted to a point map and an additional
attribute table.
– From the Operations menu in the Main window, choose the Table

Operations, Table to PointMap command, or in the Operation-list, double-
click the TblPnt item.

– In the Table to Point Map dialog box:
– select the table;
– select the column which contains X-coordinates;
– select the column which contains Y-coordinates;
– select or create a coordinate system for the point map (for more

information, see the Create Coordinate System dialog box);
– choose to use the domain of the table as the domain for the output point

map;
– type a new name for the output point map;
– optionally, type a description for the output point map.



How to import… How to…

ILWIS 2.2 Guide 261

Result: a point map with linked attribute table; the domain of the point map and
the attribute table contains the original IDs; the point map will have a coordinate
system.

Simulating the file structure of an ILWIS 1.4 point map (ASCII)

You will open the ASCII file and edit it (adding a one-line header which contains
column names and types of columns) to simulate the file structure of an ILWIS 1.4
point map and then import the ILWIS 1.4 point map into ILWIS 2.

Standard ILWIS 1.4 point map
An ILWIS 1.4 point map is an ASCII file with extension .PNT; an ILWIS 1.4 point
map may contain the following:
X! Y! Name$ Attrib1# Attrib2% Attrib3&
5000102 560205 Point1 253 8356 63.9
5001102 561205 Point2 132 572 84.5
5002102 562205 Point3 96 1830 47.2
5003102 563205 Point4 58 6293 64.5

Columns X and Y are the columns containing the coordinates; column Name
contains the name with which points are represented and columns Attrib1,
Attrib2 and Attrib3 are optional attribute columns.
Column names in ILWIS 1.4 may not be longer than 20 characters.

As you can see, each column name is directly followed by a special sign, which
defines the type of the ILWIS 1.4 column. You can use:
colname$ to store any strings or characters
colname# to store byte values (whole positive numbers between 0 and 255)
colname% to store integer values (whole numbers between -32766 and 32767)
colname! to store long integer values (whole numbers between -2 to +2 billion)
colname& to store real values (values with decimals)

Furthermore, an ILWIS 1.4 point map complies to the following:
§ It is obligatory that there are one or more spaces between each column name and

also between the strings or values in the columns themselves; i.e. the file is
space delimited. This implies that empty fields are not allowed! You should fill
empty fields with a question mark or any other character you like.

§ For a point map, it is obligatory that columns X and Y are available. Other
columns are optional.

§ The column type of the X and Y columns must be either ! (long integers) or &
(reals).

§ When you use the Name$ column, this must be a string column, thus use column
type $.

§ Strings in a string column cannot contain spaces as spaces are used as delimiters
and indicate the start of a next column. When you have spaces in strings, you
can replace these with underscores.

§ The first line of the file containing the column names, is called the header of the
file.

§ The file has extension .PNT.
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When you want to import table-like data from other packages which are not point
data, you can use the same file structure as described above, only coordinate
columns X and Y are not necessary and the file must have extension .TBL. You will
then simulate an ASCII ILWIS 1.4 table.

Procedure to simulate an ILWIS 1.4 ASCII point map
1. Make sure that:

– the file is saved in ASCII format;
– the file has extension .PNT;
– any empty fields in the original table have been replaced by a question mark.
This means: when you use the Type filename.pnt command in a DOS window
or when you open the file in NotePad, the file should be readable and should not
have odd looking characters; the contents of columns should be shown next to
each other but not necessarily aligned; each record should start at a new line.

2. Open the ASCII file in an editor; you can use for instance Edit in a DOS
window or NotePad, whichever is available (or can be installed) as one of the
Windows Accessories.
– At the top of the file, add one line which represents column names and add to

each column name one of the special signs to define the column type as
explained above.
– a column which contains X-coordinates must be named X
– a column which contains Y-coordinates must be named Y
– for these coordinate columns, use column type ! (long) or & (real)
– only when the file contains a column with strings representing the names

identifying the points, give this column the name and type Name$;
otherwise do not use a Name$ column at all;

Make sure that there is at least one space or tab between each column name.
– Save the file as an ASCII file with extension .PNT. The file name should not

be longer than 8 characters.

Note: Very large ASCII files which cannot be handled by the DOS Editor nor by
NotePad can always be opened and edited with other word processing packages.
However, when saving the file in such word processing packages, you must take
special care that the file is saved in ASCII format. Usually, you will have to save
the file as 'Text Only' or 'MS-DOS Text' which will generate a file with
extension .TXT. Then, in a DOS window, you will have to copy or rename the
file to extension .PNT yourself. Avoid working with files which seem to have
double extensions!

To check whether everything is correct:
– Open a DOS window (in Windows 3.1 by double-clicking the DOS icon in

the Program Manager; in Windows '95 by choosing Start, Programs, MS-
DOS Prompt);

– In the DOS window, type: Type filename.pnt
The file should be readable; the file should look like the standard ILWIS 1.4
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point map as described above; the fields should be shown next to each other;
each record should start at a new line.

3. Start ILWIS 2.
– From the File menu in the Main window, choose the Import command, or

double-click the Import item in the Operation-list.
– In the Import dialog box:

– for the Import format, select ILWIS 1.4 point map .PNT;
– your file will now appear in the left hand list box; select it;
– type a name for the output ILWIS 2 point map.
– click the OK button.

Depending on whether or not the .PNT file contains a Name$ column, either the
Import Point Map from version 1.4 dialog or the Import other point maps dialog
box will follow.

4a. When your file contains a Name$ column, the Import Point Map from
version 1.4 dialog box will follow:
– choose for the Domain of the point map:

Class: when the point names in the Name$ are not unique (not advised);
Identifier: when the point names in the Name$ column are unique (advised);
Value: when the Name$ column contains values and when you do not

care for an attribute table.
– type a name for the domain of the point map and optional attribute table;
– when the file contains additional attribute columns: type a name for the

attribute table (you can use the same name as for the output point map);
– type a name for the output ILWIS 2 point map.
– click the OK button.
Result: ILWIS 2 point map with or without linked attribute table. When you
selected to create an ID domain, the strings of the Name$ column are used as the
IDs, both in the point map and in the optional attribute table. When you selected
to use system domain Value for the points, the points will have the value as
found in the Name$ column and an attribute table will not be available; the point
map will have coordinate system Unknown.

4b. When your file does not contain a Name$ column, in the Import Other Point
Maps dialog box:
– choose for the Domain of the point map:

Identifier: a new ID domain will be created; the points will
automatically obtain identifiers like pnt 1, pnt 2, etc.

– type a name for the domain of the point map and optional attribute table;
– when the file contains additional attribute columns: type a name for the

attribute table (you can use the same name as for the output point map);
– type a name for the output ILWIS 2 point map.
– click the OK button.
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Result: ILWIS 2 point map with or without linked attribute table; the domain of
the point map and the optional attribute table will contain new IDs like pnt 1,
pnt 2, etc.; the point map will have coordinate system Unknown.

5. The Catalog will now show your ILWIS 2 point map with or without attribute
table. You can double-click them to open them.

6. To create a correct coordinate system for the point map, you can open the File
menu in the Main window and choose the Create Coordinate System command.
– In the Create Coordinate System dialog box:

– choose the correct type of coordinate system (all coordsys types are
available);

– in any following dialog box, specify the coordinate boundaries of the map,
optional projection, ellipsoid and/or datum, etc.

– Then, in the Catalog, click the point map with the right mouse button and
choose Properties from the context-sensitive menu.

– In the Point Map Properties dialog box, click the Edit Properties button.
– In the Edit Properties dialog box, select the correct coordinate system.

You can also create a coordinate system for the map, by first displaying the point
map in a map window. Then, open the File menu in the map window and choose
the Create Coordinate System command.
In the Create Coordinate System (in map window) dialog box:
– choose the correct type of coordinate system (only types coordsys formula

and coordsys tiepoints available);
– in any following dialog box, specify the coordinate boundaries of the map,

optional projection, ellipsoid and/or datum, etc.

The created coordinate system will be directly linked to the map.

8.9.2 How to import data

Importing data from ILWIS 1.4

To import single maps or tables from ILWIS 1.4:
§ open the File menu from the Main window and choose Import, or
§ double-click the Import item in the Operation-list.
The Import dialog box will follow.

To import multiple maps and tables from ILWIS 1.4:
§ open the File menu from the Main window and choose Batch import from 1.4, or
§ double-click the Import 1.4 item in the Operation-list.
The Import from ILWIS 1.4 dialog box will follow.

For more information, see also: How to import data from ILWIS 1.4.

Importing data using Import
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You can use Import to import data from the following packages and formats:
Raster: ILWIS 1.4, ILWIS ASCII raster (.ASC) , General Raster Data,

Arc/Info non-compressed ASCII files (.NAS) , Arc/Info .E00 files
(.E00) , IDA images (.IMG) , Windows Bitmaps (.BMP) , Erdas (.GIS,
.LAN) , GIF images (.GIF) , Idrisi maps (.DOC) , Paintbrush pictures
(.PCX) , (Geo)TIFF images (.TIF) ,

Vector: ILWIS 1.4, ILWIS ASCII segments (.SMT) , Arc/Info .E00 files,
Arc/Info ASCII .LIN, Arc/Info ASCII .PTS, Arc/View Shape files
(.SHP, .SHX, .DBF) , Atlas segment files (.BNA) , AutoCad .DXF
files, InfoCam sequential files (.SEQ) .

Table: ILWIS 1.4, dBase tables (.DBF) .

§ Open the File menu from the Main window and choose Import, or
§ Double-click the Import item in the Operation-list.
The Import dialog box will follow.

Except for General Raster Data and dBase DBF, the data types listed above can also
be imported by typing an expression on the command line or by creating a script,
which contains one or more import commands. For more information, see
Appendices: ILWIS script language (syntax).

Importing data using Convert 1.4

You can use Convert 1.4 to import data from the following packages and formats:
Raster: ITC's Laboratory of Image Processing files (.LIP), Geosoft (GRD),
Vector: ILWIS ASCII polygons (.SMT), Intergraph (.SIF), HPGL (.HPG),

ILWIS 1.2, Atlas polygons (.BNA), GINA (.GIA), UseMap, SiCad
(.GDB), SysScan (.GPI),

Table: Comma Delimited files (.TXT), Lotus (.DIF), DBase (.SDF).

1. First, double-click the Convert 1.4 item in the Operation-list.
The Convert program of ILWIS 1.41 will be started in a DOS box; choose
whether you want to import Vector Input, Raster Input or Table Input and
choose the format from which you want to import. Answer all questions
manually. Your data will be imported into ILWIS 1.4 format.

2. Now that you have imported your data into ILWIS 1.4 format, you can import it
into ILWIS 2.
– Open the File menu in the Main window and choose Import, or
– Double-click the Import item in the Operation-list, or
– Open the File menu in the Main window and choose Batch import from

ILWIS 1.4, or
– Double-click the Import 1.4 item in the Operation-list.
The Import dialog box or the Batch import from ILWIS 1.4 dialog box will
follow.
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8.10 How to monoplot
Monoplotting is the process of creating and/or editing a segment or point map while
a scanned photogrammetric aerial photograph is displayed as a background in a map
window. On the photograph, you should be able to distinguish 2, 3, or 4 fiducial
marks and you should know the camera's principal distance. Furthermore, a Digital
Terrain Model (DTM) of the area should be available.

By creating a georeference orthophoto (differential rectification) for the photograph,
you will obtain a georeference with corrections for tilt and relief displacement and
you can, by using the mouse, directly digitize elements of interest on the scanned
aerial photograph.

When your scanned photograph was taken with a normal camera, i.e. no fiducial
marks, but you do have a DTM, you should create a georef direct linear (direct linear
transformation; also corrections for tilt and relief displacement, but more tiepoints
required).
When your scanned photograph was taken with a normal camera, i.e. no fiducial
marks, and you have no DTM, you should create a georef tiepoints (select
transformation projective, no corrections for relief displacement).

1.  Display the scanned aerial photograph
Display the scanned photogrammetric photograph, which you want to use as
background in a map window. When the map already has a correct georeference
orthophoto, i.e. check the properties of the map, continue with step 5.

2.  Creating a georeference
When the map is using georef None, i.e. when the status line of the map window
only shows Row Col values, open the File menu in the map window, and choose the
Create Georeference command.

The Create Georeference (in map window) dialog box appears:
§ choose to create a georef orthophoto;
§ specify the coordinate system and the DTM you want to use.

F For a correct behaviour of a georef orthophoto and subsequent monoplotting, it is
essential that you have marked the 'Interpolation' check box in the Properties dialog
box of your DTM raster map. For more information, refer to the Raster Map
Properties dialog box.

The Locate Fiducial Marks dialog box will appear.

When your scanned photograph was taken with a normal camera, i.e. no fiducial
marks, but you do have a DTM, you should create a georef direct linear.
When your scanned photograph was taken with a normal camera, i.e. no fiducial
marks, and you have no DTM, you should create a georef tiepoints.   
To digitize on photographs, which have no fiducial marks or on satellite imagery,
see topic How to screen digitize.
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The remainder of the current topic deals with georefs orthophoto.

3.  Registering fiducial marks
When in the photograph, fiducial marks are available both in the corners of the
photo and in the middle along the edges of the photo, then choose which type of
fiducial marks you want to use. You may not mix corner fiducials with mid-edge
fiducials.

In the Locate Fiducial Marks dialog box,
§ specify the principal distance of the camera,
§ then, zoom in on a fiducial mark in the scanned photo, position the mouse

pointer carefully in the middle of a fiducial mark, and press the left mouse
button (under heading RowCol (pixels), the row and column number of this
fiducial mark will appear),

§ type under heading Photo (mm), the location in photo-coordinates in mm of the
fiducial mark as precisely as you can (decimals allowed).

§ register other fiducial marks in the same way.

For more information and examples, see the Locate Fiducial Marks dialog box.

When finished, the Tiepoint editor will be opened.

4.  Using the Tiepoint editor
In the Tiepoint editor, you have to insert tiepoints, also called ground control points,
which establish relationships between the scanned photo pixels (row,col) and real
world XYZ-coordinates.

To add tiepoints:
§ first, click at a recognizable point in the photograph displayed in the map

window,
§ the Add Tiepoint dialog box appears. In this dialog box, the row and column

values at the position of the click are filled out.
When you already have some tiepoints, the dialog box will also come up with a
suggestion for the XY-coordinates. This suggestion is the result of the
calculation with the existing tiepoints and using the current transformation
method. This suggestion is a measure of the quality of the current tiepoints. The
suggestion is merely a suggestion, it is advised to enter your own XY-
coordinates to prevent false accuracy.

Then:
§ click at the same position in a map which already has correct XY-coordinates

and which is displayed in another map window (Master/Slave), or
§ digitize the same point in an analog paper map on a digitizer, or
§ read the correct XY-coordinates for this point from a table or an analog paper

map, and type these XY-coordinates in the dialog box.
§ you can optionally specify a Z-value for the inserted tiepoint; otherwise the

height value as found in the DTM is used.
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The inserted tiepoint appears in the map window and in the tiepoint table.

A georef orthophoto, which performs a differential rectification, has a mathematical
minimum of 3 tiepoints.

F You should always insert more tiepoints than is mathematically required.
F Tiepoints should be well spread over the map (XY).

For more information on the Tiepoint editor, see Georeference Tiepoint editor:
functionality.

When finished editing the georeference, leave the Tiepoint editor by choosing Exit
from the File menu or by clicking the Exit Editor button in the button bar. The
photograph map will now use the coordinates as stored in the georeference you just
created. The photograph is still displayed in a map window; the status line now
shows Row Col values and XY-coordinates.

5. Creating and/or editing a segment or point map on the background map
Have the raster map, which now uses correct XY-coordinates and which you want to
use as background displayed in a map window.

To create a new segment or point map, open the File menu in the map window, and
choose Create Segment Map or Create Point Map. The Create Segment Map or the
Create Point Map dialog box appears. Type a map name, specify a domain and
optionally type a description. Accept the coordinate system and map boundaries,
which are already filled out.

To edit an existing segment or point map, first add the map to the map window by
selecting the Add Data Layer command from the Layers menu in the map window.
When the segment or point map is displayed, choose the Edit Layer command from
the Edit menu of the map window: select the segment or point map which you want
to edit.

The Segment editor or the Point editor is opened. You can now add, edit and delete
segments or points by using the mouse as usual.

When your background map uses a georef orthophoto, you may see that an edited
segment or point does not exactly appear at the position of the pencil pointer: this is
a measure of the quality of your georeference in the area. Errors will usually be
larger along the edges of a photograph.
§ When the deviation is small, your georeference is good enough;
§ When the deviation is large, you can check the number, even distribution and

quality of the tiepoints in your georeference, the quality of your DTM, etc.

F When you add grid lines to the photo in the map window, the grid lines will not be
straight nor perpendicular to each other; the grid lines indicate the corrections for tilt
and relief displacement.
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6.  Resampling the scanned photograph, yes or no
The crux of this topic is that you do not need to use the resample operation in order
to monoplot on scanned photogrammetric aerial photographs, which use a georef
orthophoto. An advantage of using the original image or photograph instead of a
resampled one is that the original image is not disturbed by the resampling; in
general, features of interest will be easier to recognize using the original data.

Performing a resample operation is required to obtain a North-oriented and rectified
orthophoto. In this case, resample the photograph with a georef orthophoto to a
georef corners. For more information, see How to create an orthophoto.

Furthermore, performing a resample operation is required before using MapCalc
when you want to combine raster maps with for instance a georeference corners with
a scanned photograph using a georef orthophoto. In this case, before using MapCalc,
resample for instance your photograph with the georef orthophoto to a georef
corners.

8.11 How to save…

8.11.1 How to save annotat ion

Simple annotations such as single texts, legends, boxes, scale bar, North arrow, grid
lines, graticule, bitmaps or metafiles/pictures which are displayed in a map window
can only be stored by saving the map window as a map view.

When you want to use such simple annotations as displayed in one map window in
another map window as well, it is advised:
§ to open the Annotation editor (map window Edit, Annotation) and
§ to copy an annotation layer into the clipboard (Ctrl+C or Edit, Copy)
§ you can then paste this layer into the other map window (Ctrl+V or Edit, Paste).
For more information, see also How to add annotation to a map window.

Annotation Text objects however, which can store multiple texts for multiple
positions, are genuine ILWIS objects: when creating or editing an annotation text
object, all text strings, positions, fonts, font sizes, colors, etc. as defined in the object
will be stored in the Annotation Text object itself. For annotation text objects, there
is thus no need to save a map window as a map view.

What is the use of a map view
When you want to save everything that is currently displayed in a map window, you
can save the map window as a map view: all data and/or annotation layers that are
currently available in the map window are stored including the current display
options for all these layers.

A map view contains the names of data layers and/or annotation layers to be
displayed in one map window. Also, the display settings of the layers are stored; so
the system knows the colors, widths etc. for the display of each layer. Further, the
georeference is stored, meaning that when you save a map view when zoomed in on



How to… How to screen digitize

270 ILWIS 2.2 Guide

a part of the map, this zoomed area will be displayed when opening the map view
later.

By opening a map view later on, all data and annotation layers which are stored in
the map view are directly displayed in a map window, the map window will have the
same dimensions as when it was stored and there is no need to specify display
options for any layer anymore.

To save annotation as a map view
§ from the map window or from the Annotation editor:
§ open the File menu,
§ choose the Save View or the Save View As ... command.

If this is a new map view, the Save View As ... dialog box appears, in which you can
specify a name and a title for the map view.

8.11.2 How to save a map view

You can save any set of data and annotation layers as currently displayed in a map
window, this means including the current display options of these layers, as a map
view.

A map view contains the names of data layers and/or annotation layers to be
displayed in one map window. Also, the display settings of the layers are stored; so
the system knows the colors, widths etc. for the display of each layer. Further, the
georeference is stored, meaning that when you save a map view when zoomed in on
a part of the map, this zoomed area will be displayed when opening the map view
later.

By opening a map view later on, all data and annotation layers, which are stored in
the map view, are directly displayed in a map window. The map window will have
the same dimensions as when it was stored and there is no need to specify display
options for any layer anymore.

To save the contents of a map window
§ from the map window or from the Annotation editor:
§ open the File menu,
§ choose the Save View or the Save View As ... command.

If this is a new map view, the Save View As ... dialog box appears, in which you can
specify a name and a title for the map view.

8.12 How to screen digitize
Screen digitizing is the process of creating and/or editing a segment or point map
while an existing raster map is displayed as a background in a map window. The
raster map can be for instance a band of a satellite image, a color composite, a
scanned map, or a scanned photograph. By using the mouse, you can directly
digitize elements of interest on the background map.
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1.  Display the background map
Display the map, which you want to use as background in a map window. When the
map already has a correct georeference, i.e. when the status line of the map window
shows Row Col values and XY-coordinates, continue with step 4.

2.  Creating a georeference
When the map is using georef None, i.e. when the status line of the map window
only shows Row Col values, open the File menu in the map window, and choose the
Create Georeference command.

The Create Georeference (in map window) dialog box appears:
§ For a satellite image, for a scanned map, or for a scanned photograph: when a

Digital Terrain Model (DTM) of the area is not available, create a georef
tiepoints.
Specify the coordinate system you want to use.

§ For scanned photograph, which was taken with a normal camera (i.e. no fiducial
marks on the photo) and when a DTM of the area is available, create a georef
direct linear.
Specify the coordinate system and the DTM you want to use.

F For a correct behaviour of a georef direct linear and subsequent screen digitizing, it
is essential that you have marked the 'Interpolation' check box in the Properties
dialog box of your DTM raster map. For more information, refer to the Raster Map
Properties dialog box.

The Tiepoint editor will be opened.

For a scanned photograph which was taken with a photogrammetric camera (i.e.
fiducial marks on the photograph and known principal distance of the camera) and a
DTM of the area is available, create a georef orthophoto. Digitizing on such an
aerial photograph is called monoplotting; continue with topic How to monoplot.

The remainder of the current topic deals with georefs tiepoints and georefs direct
linear.

3.  Using the Tiepoint editor
In the Tiepoint editor, you have to insert tiepoints, also called ground control points,
which establish relationships between the map pixels (row,col) and real world XY-
or XYZ-coordinates.

To add tiepoints:
§ first, click at a recognizable point in the map without coordinates which is

displayed in the map window,
§ the Add Tiepoint dialog box appears. In this dialog box, the row and column

values at the position of the click are filled out.
When you already have some tiepoints, the dialog box will also come up with a
suggestion for the XY-coordinates. This suggestion is the result of the
calculation with the existing tiepoints and using the current transformation
method. This suggestion is a measure of the quality of the current tiepoints. The
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suggestion is merely a suggestion, it is advised to enter your own XY-
coordinates to prevent false accuracy.

Then:
§ click at the same position in a map which already has correct XY-coordinates

and which is displayed in another map window (Master/Slave), or
§ digitize the same point in an analog paper map which is stuck on a digitizer, or
§ read the correct XY-coordinates for this point from a table or an analog paper

map, and type these XY-coordinates in the dialog box.
When editing a georef direct linear or a georef orthophoto, you can optionally
specify a Z-value for the inserted tiepoint; otherwise the height value as found in the
DTM is used.

The inserted tiepoint appears in the map window and in the tiepoint table.

For a georef tiepoints, you need to select a transformation method:
§ For satellite images, an affine transformation will usually do (mathematical

minimum of 3 tiepoints).
§ For a scanned photograph (without DTM), a projective transformation is

recommended (mathematical minimum of 4 tiepoints).

A georef direct linear, which performs a direct linear transformation (DLT) has a
mathematical minimum of 6 tiepoints.

F You should always insert more tiepoints than is mathematically required.
F Tiepoints should be well spread over the map (XY).
F For a georef direct linear, the tiepoints should also be well spread in Z-direction and

they should not be co-planar, i.e. in Z-direction, the tiepoints should not be on a
(tilted) plane.

For more information on the Tiepoint editor, see Georeference Tiepoint editor:
functionality.

When finished editing the georeference, leave the Tiepoint editor by choosing Exit
from the File menu or by clicking the Exit Editor button in the button bar. The raster
map will now use the coordinates as stored in the georeference you just created. The
raster map is still displayed in a map window; the status line now shows Row Col
values and XY-coordinates.

4. Creating and/or editing a segment or point map on the background map
Have the raster map, which now uses correct XY-coordinates and which you want to
use as background displayed in a map window.

To create a new segment or point map, open the File menu in the map window, and
choose Create Segment Map or Create Point Map. The Create Segment Map or the
Create Point Map dialog box appears. Type a map name, specify a domain and
optionally type a description. Accept the coordinate system and map boundaries,
which are already filled out.
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To edit an existing segment or point map, choose the Edit Other Map command
from the Edit menu of the map window, then select the desired editor and select a
map.

The Segment editor or the Point editor is opened. You can now add, edit and delete
segments or points by using the mouse as usual.

When your background map uses a georef direct linear, you may see that an edited
segment or point does not exactly appear at the position of the pencil pointer: this is
a measure of the quality of your georeference in the area. Errors will usually be
larger along the edges of a photograph.
§ When the deviation is small, your georeference is good enough;
§ When the deviation is large, you can check the number, even distribution and

quality of the tiepoints in your georeference, the quality of your DTM, etc.

5.  Resampling the background image, yes or no
The crux of this topic is that you do not need to use the resample operation in order
to screen digitize on images which use a georef tiepoints or on scanned photographs
which use a georef direct linear. An advantage of using the original image or
photograph instead of a resampled one is that the original image is not disturbed by
the resampling; in general, features of interest will be easier to recognize using the
original data.

Performing a resample operation is only required before using MapCalc when you
want to combine raster maps with for instance a georeference corners with raster
maps using a georef tiepoints or a georef direct linear. In this case, before using
MapCalc, resample for instance your image with the georef tiepoints to a georef
corners.

8.13 How to use…

8.13.1 How to use the Georeference Tiepoints editor

This topic gives information on different methods to insert tiepoints in the Tiepoint
editor for a georef tiepoints, a georef direct linear or a georef orthophoto. For more
information on georeference types, see ILWIS objects: georeferences.

To insert tiepoints by using an existing map with coordinates (Master/Slave)
§ Display any map with correct XY-coordinates in a map window (Master).
§ Display the image that you want to give tiepoints (Slave) in another map

window; open the Edit menu and choose Georeference; the Georeference
Tiepoints editor will be started.

§ Make sure that you can identify future tiepoints both in the slave image (row,
col) and in the other master map with the correct georeference and/or coordinate
system (XY-coordinates).

Then:
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§ click in the slave image;
§ the Add Tiepoint dialog box appears, the Row and Column values are filled out;

and
§ click on the corresponding position in the master raster map in the other map

window;
§ in the Add Tiepoint dialog box, the correct X and Y coordinates are filled out;
§ click OK.
Repeat for other tiepoints.

To insert tiepoints by using a map on a digitizer
Stick an analog paper map on the digitizer, setup the digitizer and reference the map.
For more information, see How to setup a digitizer and reference a map.
Start the Georeference Tiepoints editor with the image that you want to give
coordinates. Make sure that you can identify future tiepoints both in the image and
in the map on the digitizer.
Then:
§ click in the image;
§ the Add Tiepoint dialog box appears, the Row and Column values are filled out;

and
§ click with the digitizer cursor on the corresponding position in the map on the

digitizer;
§ in the Add Tiepoint dialog box, the correct X and Y coordinates are filled out;
§ click OK.
Repeat for other tiepoints.

To insert tiepoints by reading coordinates from paper
Start the tiepoint editor with the map that you want to give coordinates.
Then:
§ click with the mouse pointer in the tiepoint editor window on a recognizable

point;
§ the Add Tiepoint dialog box appears, the Row and Column values are filled out;
§ when you already have some tiepoints, the dialog box will also come up with a

suggestion for the XY-coordinates. Do not accept these defaults, but always read
the corresponding XY-coordinates for this point from the paper map.

Repeat for other tiepoints.

To insert tiepoints entirely by keyboard
When you have a complete relation between row and column numbers and X and Y
coordinates on paper, you can also:
§ click on a gray record button in the tiepoint table, or
§ in the map window, press the right mouse button, select the Add Tiepoint

command from the context-sensitive menu;
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then:
§ the Add TiePoint dialog box appears;
§ type Row and Column values and X and Y coordinates for a tiepoint in the

dialog box.
Repeat for other tiepoints.

8.13.2 How to use parameters in scripts

Parameters in a script can replace (parts of) object names, operations, etc.
Parameters in scripts work as DOS replaceable parameters in DOS batch files, and
must be written in the script as %1, %2, %3, up to %9.
The parameters of a script have to be filled out on the command line when you run
the script. The first text string found after the script name will replace %1 in the
script, etc.

Example 1
Suppose you have a segment map 'Contour' and an existing georeference 'Geo' with
a certain pixel size.

To obtain a slope map in degrees and a slope map in percentages, you can create a
script (e.g. Slopes) and type in the script text box:
%2 = MapInterpolContour(%1,geo)
%3 = MapFilter(%2, dfdx)
%4 = MapFilter(%2, dfdy)
%5 = 100 * HYP(%3,%4)/PIXSIZE(%2)
%6 = RADDEG(ATAN(%5/100))

To run this script, type on the command line of the Main window:
run Slopes Contour.mps DEM.mpr DX DY SlopePct SlopeDeg

In script 'Slopes', 'contour.mps' replaces %1, 'dem.mpr' replaces %2, 'DX' replaces
%3, 'DY' replaces %4, 'SlopePct' replaces %5, and 'SlopeDeg' replaces %6.
This script is more elaborately explained in MapCalc & TabCalc: creating and
running scripts.

Of course, you could also specify the objects names and pixel size in the script itself,
thus creating a script without parameters.

Example 2
Suppose you have three landuse maps (LU70, LU80, and LU90) of different years
(1970, 1980, 1990). Each map has an attribute table linked to it (LUTBL70,
LUTBL80, LUTBL90), and each table contains a column YieldMainCrop.

To obtain attribute maps of all landuse maps, you can create a script (e.g. Yields)
and type in the script text box:
Yield%1=MapAttribute(LU%1, YieldMainCrop)
Yield%2=MapAttribute(LU%2, YieldMainCrop)
Yield%3=MapAttribute(LU%3, YieldMainCrop)
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To run the script (e.g. called Yields), type on the command line of the Main
window:
run Yields 70 80 90

In script Yields, '70' replaces %1, '80' replaces %2 and '90' replaces %3. You thus
obtain three attribute maps (Yield70, Yield80, Yield90) from the three input maps
(LU70, LU80, LU90).

Of course, you could also specify the years in the script itself, thus creating a script
without parameters.


