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1 Introduction and background  

1.1 Background 

The AfriAlliance project aims to prepare Africa for future climate change challenges by creating the 

opportunity for African and European stakeholders to work together in the areas of water innovation, 

research, policy, and capacity development. 

Rather than creating new networks, the 16 EU and African partners in this project are consolidating existing 

ones, consisting of scientists, decision makers, practitioners, citizens and other key stakeholders, into an 

effective, problem-focused knowledge sharing mechanism. This will be coordinated by means of an 

innovation platform: the Africa-EU Innovation Alliance for Water and Climate. 

AfriAlliance will support the existing networks in identifying appropriate social innovation and technological 

solutions for key water and climate change challenges. It will capitalise on the knowledge and innovation 

base and the potential in Africa and the EU. The project will support effective means of knowledge sharing 

and technology transfer within Africa and between Africa and the EU, with the aim of increasing African 

preparedness to address the vulnerability of water and climate change-related challenges. The project 

makes extensive use of existing/emerging communication channels and events (EU/African platforms, 

conferences and social media) to streamline climate change issues into water-related networks, thereby 

raising awareness about their impacts and to propose adaptation measures 

1.2 Use of multiple Sensors for Water Resource Monitoring & Forecasting  

One of the innovative aspects of AfriAlliance and more specifically of WP4 is the multiple information 

source gathering approach. The inventory is based on a triple-sensor approach, looking into the capacity 

and efforts on human sensors (citizens, geo-crowdsourcing and communications), physical in-situ sensors 

(like weather station-based meteorological and ground-based water resource and hydrological networks 

such as stream gauging, groundwater, etc.) and space-based satellite sensors.  

 

Figure 1 The AfriAlliance Triple Sensor observation approach for Water Resources Monitoring & Forecasting 

 



 

A major challenge in climate and water information analysis for decision-making at different spatial levels 

and stakeholders (i.e. ranging from governments at country level to local populations at village level) lies in 

the accessibility of the information sources, as well as the reliability and accuracy associated with the dif-

ferent data. Some people may rely heavily (or solely) on rain gauge network information, whereas others 

typically use satellite observations. Yet others, and especially local communities, may find crowdsourcing 

and citizen observatories the best choice.  

In AfriAlliance, an information merging or collocation approach is proposed to support African stakeholders 

in their analysis of climate and weather challenges related to water resources management. This approach 

is derived from the principle that a single observation (e.g. on weather or water availability) at a certain 

location and time will be much more reliable and generally accepted if it is compared to other independent 

observation data sources (of the same location and time period). And as typically done in the weather 

forecasting and prediction world (who were the first do adopt this technique), to merge data sources and 

derive optimal estimates and information. This triple sensor approach launched by AA and an application 

tool is documented in this report. 

 

1.3 Purpose and structure of the Report 

This report describes the Demonstration package for applying a triple sensor collocation approach to 3 

different information sources. The software tool (formal deliverable) contains an open source geospatial 

data and image analysis software (Ilwis v.385.2), and contains a specific Afrialliance Toolbox Plug-in for 

analysing and collocating Triple sensor data in Africa.  Next to this geospatial software, also a web-based 

AA triple sensor collocation demo was developed by ITC and its use is also described in this accompanying 

report.  

The ILWIS Afrialliance Triple Sensor Demo toolbox contained in the software is for users with some prelim-

inary knowledge of geodata and basic skills in GIS analysis and preferably remote sensing.  Use of the 

toolbox needs a prior quick installation (unzip) of the software on a laptop or PC system (Windows-based). 

The web-based Triple collocation demo is for all (incl. novice users) gremials, and demonstrates the princi-

ple of the triple sensor collocation approach. This is a zero-install web application and can be run from any 

browser on most platforms i.e. laptop, iPad, smartphone. 

The introductory section 1, generally describes the AA project goals related to Monitoring & Forecasting 

Climate and Water Challenges in Africa, and introduces the novel AA 3-S approach. In Section 2, the triple 

sensor approach is described in some more details. In Section 3, the data sets used in the demonstration 

of the triple sensor approach are visited in brief. In Section 4, a hands-on guided demonstration is worked 

out, explaining the user how to install and use the software, acquire data and perform the data analysis. 

Section 4 also describes the web-based application. This report supplement to the demonstration package 

(toolbox) and triple collocation web-application refers extensively to the main Afrialliance report 

deliverable (D4.4) on Constraints and Opportunities for Water Resources Monitoring using a Triple Sensor 

approach available on-line (www.afrialliance.org project portal > Knowledge section Tab).   
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2 Triple sensor collocation 

2.1 Short history and proposed novel use 

Triple Sensor Collocation can be used to validate 3 independent observations at a location, when the error-

free true value is not known. With this you can judge, which water or climate observation, i.e. your citizen 

observation, conventional station data or a remotely sensed satellite look-up is most reliable. 

The origins of the triple collocation of data sources originate from meteorology (e.g. Stoffelen, 1998; 

Roebeling et al, 2012). The technique has arisen from the need to jointly analyze e.g. ground station 

measurements of meteorological variables (e.g. wind speed) with weather model- and satellite-based 

predictions of meteorological variables.  The main idea behind triple collocation (in meteorology) is to verify 

and/or to increase the accuracies of global weather forecast modelling output, needed and used in our 

daily weather bulletins, as well as for global aviation, maritime transportation, and early warning of weather 

hazards. The method is closely linked to other mathematical data merging approaches such as data 

assimilation, where typically meteorological station observations are ingested in weather forecast models 

to improve predictions ad forecasts (Bengtsson et al, 1981). 

Currently, and due to the enormous increase in data sources and information provision in all societal 

domains, data validation and quality control of information is becoming a necessary „must do“ step in any 

information gathering, analysis, interpretation and use process. Triple collocation and other control 

techniques are therefore receiving more attention today as a methods for data validation, and applications 

to other data types and sources (beyond meteorology) are getting developed (Zwiebach, 2012; McColl et 

al, 2016). In Afrialliance, a similar methodology for mapping the three independent information sources 

(sensors) for water resource monitoring has been proposed. It can be typically applied to: 

 

• Mapping which of the information sources are available in a certain region or physical area of interest; 

• Verify the agreement (in a statistical sense) among the three sensor data sources. 

 

In the statistical sense, triple collocation is a technique for estimating the variance of the error (noise error) 

and correlation coefficients of the measurement systems (e.g. satellite, in-situ and citizen-based products), 

with respect to the unknown true value of the variable being observed (e.g. soil moisture, wind speed, 

rainfall, surface water occurence, groundwater levels, etc.). 

The three independent data sources in AA are: a) in-situ hydro meteorological or water resource ground 

station observations e.g. soil moisture, surface and shallow ground water levels, etc. b) satellite-based 

estimates of hydrological variables and c) citizen-based observations on water resources.   

Where the basic idea behind this triple sensor collocation is seemingly simple and has certainly 

opportunities, the method is also subject to several constraints and challenges. An analysis of the 

Constraints and Opportunities can be found in the Afrialliance report D4.4 (mentioned earlier).  

 

2.2 Short description of algorithms and triple collocation procedure 

We  will not detail the advanced statistical concepts used for triple collocation of spatial and temporal data. 

This is beyond scope of this document, aiming at a wider audience. We give here a basic explanation of the 

procedure applied in this project context and supply the scientific references for readers with a more 

advanced scientific algorithm interests.  



 

 

Triple Collocation of satellite, in-situ station and citizen observation“ „How it works“? 

The current method reference used for the TC in this Toolbox is based on research of McColl et al (2014), and 

entitled: „Extended Triple Collocation: estimating errors and correlation coefficients with respect to an 

unknown target“ and published in Geophysical Research Letters under DOI:10.1002/2014GL061322). The 

TC algorithms from McColl et al (2014; 2016) were coded first in R-code for initial verification with the 

sample data by the authors and further implemented in Python (currently used in the web-based demo) 

and VisualC++ for full integration in ILWIS. With this build-in Ilwis option, users do not need to use (install 

and run) R or Python on their laptops to perform triple collocation in Ilwis.

The Triple Sensor Collocation can be used to validate 3 independent 

observations at a location, when the error-free true value is not known. With 

this you can judge, which water or climate observation, i.e. your citizen 

observation, conventional station measurement or a remotely sensed satellite 

look-up and retrieval is most reliable. 

The method is based on statistical covariance analysis on three independent 

data sources and yields correlations, errors (RMSE) and permits to rank the 

dataset reliability. 

In Triple Collocation (TC), one dataset (e.g. a 31-day time series of daily 

observations, as used in the demo) is compared to the 2 other sensor data sets 

(also time series of the same variable) and the correlation coefficients based on 

the covariances among the three data sets is evaluated. So, sensor 1 is 

evaluated against sensor (2, 3), sensor 2 against (3, 1) and sensor 3 against (1, 

2). For the equations, we refer to the reference of McColl et al (2014). 

The resulting correlation vector based on this covariance analysis is then ranked 

and assigned a weigth, and the sensor with the higher correlation with respect 

to the 2 other sensors is considered being the most reliable.  

Further, the error variance and root mean Square error (RMSE) are evaluated 

giving an idea on the error margins of the data.  

Pls.  note that due to possible extreme data ranges and possible outliers with 

some sensor observations, correlation coefficients and weigths might get 

values slightly above 1, and even (non-intuitively expected) negative 

correlations are possible (usually due to extreme outliers vs. e.g. very low or 

zero values) and/or possible observation errors. Further research is being 

conducted on triple collocation algorithms for continous, categorical and other 

types of data variables (pls. See also references). 
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3 Description of example data sets 

A limited number of data sets (and used in the demo exercise Chapter 4) were added to this Triple sensor 

Toolbox for demonstration purposes. For more extensive data resources (including acquisition routines), 

we refer to 2 other ILWIS toolboxes (i.e. GEONETCast and ISOD), which can be plugged-in as an Ilwis exten-

sion in this software (see Section 3.2.1). We refer to the Help section and “About” for for more information. 

3.1 In-situ station Data 

In-situ station data represent all near surface data collected in conventional and new ground stations, by 

official authorities, e.g. hydro- & meteorolgical services, regional monitoring and research programs and 

projects. We refer to the scheme on Social Actors involved in data acquisition for Monitoring & Forecasting 

(pages 13-14) in the AA D4.4 report on Constraints and Opportunities for Water Resources Monitoring using 

a Triple Sensor approach available on-line (www.afrialliance.org project portal > Knowledge section Tab).   

 WMO-GTS GSOD (Global Summary of Day) Meteorological station Data 

GSOD or Global Summary of Day data are daily summaries of the 6-hourly (00.00;06.00;12:00;18:00 UTC) 

reported data of high level synoptic station (e.g. at airports,…) from countries to the WMO (World 

Meteorological Org) and using the WMO-GTS or Global Telecommunication System. The global 

meteorological station data summaries provided are based on data exchanged under the World 

Meteorological Organization (WMO) World Weather Watch Program according to WMO Resolution 40.  

This allows WMO member countries to place restrictions on the use or re-export of their data for 

commercial purposes outside of the receiving country.  Data for selected countries may, at times, not be 

available through this system.    

Those countries' data summaries and products which are available here are intended for free and 

unrestricted use in research, education and other non-commercial activities. The data are available via 

http://www.ncdc.noaa.gov/cgi-bin/res40.pl?page=gsod.html and ftp://ftp.ncdc.noaa.gov/pub/data/gsod. 

The input data used in building these daily summaries are the Integrated Surface Data (ISD), which includes 

global data obtained from the USAF Climatology Centre.  The latest daily summary data are normally 

available 1-2 days after the date-time of the observations used in the daily summaries. A few historcal 

online station data files begin already in year 1929, and over 9000 stations' data are typically available.   

The daily elements included in the dataset (available for each station) are: mean temperature, mean dew 

point, mean sea level pressure, mean station pressure, mean visibility, mean wind speed, maximum 

sustained wind speed, maximum wind gust, maximum temperature, minimum temperature, precipitation 

amount, snow depth and indicator for the occurrence of: fog, rain or drizzle, snow or ice pellets, hail, 

thunder and tornado/funnel cloud. Upon import the data is converted to SI units. 

We also refer to Afrialliance report D4.4 paragraph 3.2.1 (pages 27-28) for more information on synoptic 

surface observations. [link] 

 NOAA CPC-FEWS global WMO-GTS daily Data 

One important source of in-situ observed climate information used by NOAA Climate Prediction Center 

(CPC) and many other meteorological agencies for weather and climate applications are the gauge-
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observed precipitation and temperature reports transmitted through the WMO Global 

Telecommunications System (GTS). Together with station reports from other national and international 

sources, the GTS gauge data are used to monitor and assess the climate at station locations and as inputs 

to define analyzed fields of global and regional precipitation and surface (station) temperature. 

 

The Global Telecommunication System (GTS) is the coordinated global system of telecommunication 

facilities and arrangements for the rapid collection, exchange, and distribution of observed and processed 

meteorological information within the framework of the World Weather Watch (WWW). Station reports of 

precipitation, together with those of many other physical variables, are exchanged routinely among the 

World Meteorological Organization (WMO) member countries through the GTS network. At NOAA / CPC, 

these precipitation reports are received and processed to form a database of GTS gauge-based daily 

precipitation. Starting from October 1977, the GTS daily gauge database is updated on a real-time basis. 

On average, daily reports are available from about 6000 GTS stations. The GTS gauge network is relatively 

dense over United States, Western Europe, and east coasts of Australia and China, while it is very sparse 

over several regions including equatorial Africa and Amazon (source: Quality Control of Daily Precipitation 

Reports at NOAA/CPC by Mingyue Chen, Pingping Xie and CPC Quality Control Working Group, Climate 

Prediction Center, CPC/NCEP/ NOAA, available at http://ams.confex.com/ams/pdfpapers/131381.pdf).  

 

The global station rainfall and temperature (minimum and maximum) data, up to a year before present can 

be obtained online from ftp://ftp.cpc.ncep.noaa.gov/fews/gts. 

 

 CPC Gauge-Based analysis of Global Daily Precipitation 

This data set is a first product of the CPC Unified Precipitation Project that is underway at NOAA Climate 

Prediction Centre (CPC). The primary goal of the project is to create a suite of unified precipitation products 

with consistent quantity and improved quality by combining all information sources available at CPC and 

by taking advantage of the optimal interpolation (OI) objective analysis technique. The coverage is global 

(land only) at 0.5 degree spatial resolution. The temporal resolution is daily and the data is available from 

the 1st of January 1979 – Present: 

    1979 – 2005:  Retrospective Version (30K+ gauges) 

ftp://ftp.cpc.ncep.noaa.gov/precip/CPC_UNI_PRCP/GAUGE_GLB/V1.0/  

    2006 - Present: Real-time version   (~17K gauges)  

ftp://ftp.cpc.ncep.noaa.gov/precip/CPC_UNI_PRCP/GAUGE_GLB/RT/ 

Relevant background documents for this data set can be found in the literature references: Xie, P. et al 

(2007), Chen, M. et al (2008) and Chen, M., P. Xie et al (2008).  

 

 

Hereunder are some examples of (research) boundary organizations co-producing secondary surface 

weather and climate observations and they complement the global high-level synoptic WMO-GTS station 

network for real time data applications. 
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 SASSCAL WeatherNet  

The SASSCAL or Southern Africa Science Service Centre for Climate Change and Adaptive Land Management 

program, covering a number of countries in the SADC or Southern Africa region, maintains a number of 

AWS, directly coupled (by GPRS) to the EUMETSAT Data Uplink and Retransmission service or to local GSM 

providers. This data communication technique permits rapid near real time (NRT) data and weather 

information acquisition by end-users and the public (see Figure 9). 

 

Figure 2 Southern Africa SASSCAL near real-time weather data (web-based) access (www.sasscal.org) 

 

The SASSCAL weathernet presents a recent initiative to increase meteorological surface observations and 

data collection over a number of SADC countries (Angola, Botswana, Namibia, South Africa and Zambia). 

The data can be accessed through the webpage www.sasscalweathernet.org. Data collected in Excel (csv) 

format can be read in ILWIS or other software for further use. No automatic import routines are currently 

available in the AA Toolbox, but the generic File>Import>Ilwis>Table (for csv-format) or .>Import 

>ADO>Excel in case of an Excel xls format works for people having some experience with Ilwis.   

 

 WASCAL Data Portal 

The Afrialliance consortium partner, WASCAL (West African Science Service Center on Climate Change and 

Adapted Land Use) is a large-scale research-focused Climate Service Center designed to help tackle this 

challenge and thereby enhance the resilience of human and environmental systems to climate change and 

increased variability. It does so by strengthening the research infrastructure and capacity in West Africa 

related to climate change and by pooling the expertise of ten West African countries and Germany. Funded 

by the German Federal Ministry of Education and Research (BMBF), WASCAL is implemented in a 

collaborative effort by West African and German partners (see more on www.wascal.org). 

It’s data portal also guides people to research data collections across Western Africa. However, a user log-

in name is required for data access. Otherwise, some metadata can be browsed only. For the Afrialliance 

Triple sensor collocation web-based demo, short rainfall data series from 5 WASCAL meteorological 

stations in the small Dano catchment (South west Burkina Faso) were used. These data were obtained 

through direct exchange with Wascal research staff, and used for demonstration purposes. 

 TAHMO - Trans-African Hydro Meteorological Observatory 

The Trans-African Hydro Meteorological Observatory (TAHMO) aims to develop a vast network of weather 

stations across Africa.  



 

14 

 

The idea behind this project is to develop a dense network of hydro-

meteorological monitoring stations in sub-Saharan Africa – one every 30 

kilometres. This entails the installation of 20,000 stations across the 

continent. By applying innovative sensor technology and ICT, TAHMO 

stations are both inexpensive and robust. Stations are placed at schools 

and integrated in educational programs, adding richness to the 

curriculum and helping foster a new generation of scientists. Local 

weather data will be combined with models and satellite observations 

to obtain insight into the distribution of water and energy stocks and 

fluxes. Currently, no automatic import routines are available in the 

toolbox, but authorised (registered) users, can access stations 

in near real time, and download data (e.g. in csv formats). Users 

should be authorized (cooperating or registered ) members of 

the TAHMO network. 

 

We refer further to the Afrialliance report deliverable (D4.4) on Constraints and Opportunities for Water 

Resources Monitoring using a Triple Sensor approach available on-line (www.afrialliance.org project portal 

> Knowledge section Tab).   

 

  

Figure 3 TAHMO network © TAHMO 

http://tahmo.org/about-tahmo-2/ 
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3.2 Earth Observation satellite data 

The amount of available satellite data (raw, processed and derived products) from Earth Observation plat-

forms available today is enormous. A quick browse of the OSCAR or Observing Systems and Capability Re-

view Tool of the WMO at https://www.wmo-sat.info/oscar/satellites shows the large number of geosta-

tionary and polar or lower equatorial orbiting satellite systems. Detailed description of these multiple data 

sources is way beyond scope of this document. 

 GEONETCast and ftp-based EO data dissemination and acquisition 

We refer here to two other ILWIS GEONETCast and ISOD Toolbox plug-ins available (for this software) with 

more information on free and open access satellite data available through the EUMETCast near real time 

dissemination system (GNC Toolbox) and data available from open accessible http- or ftp data servers (ISOD 

toolbox). Toolboxes can be downloaded from www.52north.org. The User Manuals (see also references), 

available in the Toolbox Help Tabs (shown below), contain valuable data descriptions and also guided ex-

ercise to acquire (import) the data to your geospatial analysis software.   

 

Figure 4  EUMETCast near real time satellite data import library (GEONETCast Toolbox) 

 

Figure 5  Ftp- or http-based in-situ station and Online satellite data import (ISOD toolbox) 
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Next to these ILWIS Satellite and in-situ Data access toolboxes, several http- and FTP-based satellite data 

web portals are today widely used. We can mention the: 

 EU Copernicus Program and other large int’l EO data portals 

The Copernicus program currently delivers operational data and information services openly and freely in 

a wide range of application areas, including thematic product/data streams of Copernicus services on Land, 

Ocean, Atmosphere and Climate as well as near real-time and archive images acquired by the various ded-

icated Sentinel satellites. The observations from Copernicus Contribution Missions should also be men-

tioned in this respect (http://www.copernicus.eu/main/contributing-missions). All these contribute to op-

erational services in the domain of Land, Marine, Atmosphere, monitoring, as well as security, emergency 

management and climate change services.  

Access to COPERNICUS products is through online portals, for the global land service GIO2 is through:  

• http://land.copernicus.eu/global/products. 

Free access to near real time and archived data from the ESA Sentinels 1, 2 is currently provided through 

the European Space Agency or ESA “Science Hub”: 

• https://scihub.copernicus.eu/  

The “Copernicus Online Data Access” Portal at EUMETSAT (Darmstadt) for ESA Sentinel-3:  

• https://coda.eumetsat.int  

Pls. see also the EUMETView direct ftp-access of S-3 (available in the Toolbox EO Menu). 

and for Sentinel-1 and S-2 also via the French CNES mirror portal (Toulouse):   

• https://peps.cnes.fr/rocket/#/home  

or the USGS portal:  

• https://landsatlook.usgs.gov/sentinel2/viewer.html 

 

Examples of other large int’l archives for other medium to medium high resolution satellites are: 

• USGS Earth Explorer at https://earthexplorer.usgs.gov/  

• NASA Giovanni at https://giovanni.gsfc.nasa.gov/giovanni/ 

• GOOGLE Earth Engine: https://earthengine.google.com/  (ps. also Sentinel data) 

• SPOT:  https://www.theia-land.fr/en/products/spot-world-heritage 

• LANDSAT: https://landsatlook.usgs.gov/viewer.html 

• ASTER: https://lpdaac.usgs.gov/dataset_discovery/aster 

• CBERS: http://www.dgi.inpe.br/siteDgi/english/index_eng.php 

The Group on Earth Observations (GEO), through its global earth observation system of systems (GEOSS) 

portal (http://www.geoportal.org/) is offering information and links to many EO resources including other 

data and websites (e.g. other producers, e.g., JAXA, JMA, CMA, SANSA, etc.).  

 

Hereunder, we will only succinctly describe the data sets used in the Triple sensing collocation demo.  
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 EUMETSAT - EUMETView 

EUMETView is a new and rapid way to visualise EUMETSAT satellite data, in near real time. Typically the 

Geostationary MSG Meteosat Second Generation satellites (Atlantic main service and the IODC Indian 

Ocean service) are used to monitor the weather, atmosphere, land surface and oceans. Next to the MSG 

satellites, also the ESA Sentinel-3 polar orbiter(s) are available from EUMETVIEW. For more information, 

pls. Visit https://www.eumetsat.int/website/home/Images/EUMETView/index.html 

 

„EUMETView is a visualisation service that allows users to view EUMETSAT 

imagery in an interactive way. It is currently a pilot service (EUMETSAT, 

2018)“. Users can opt to download te data in „picture view“ e.g. jpg format, 

but also in geospatial data formats like GeoTIFF or NetCDF. This permits 

import and further use and processing of the data in the ILWIS software (or 

any other e.g. QGIS) using the standard File>Import>GDAL libraries.  

EUMETVIEW is a nice web-based alternative to users not having access to 

an EUMETCAst dish antenna receiving and data processing system. Those 

who have such a reception system, can use the ILWIS GEONETCast Toolbox, 

which contains all tools and import libraries for the HRIT and LRIT formats 

(standard data dissemination formats for near real time Level 1.5 MSG data). 

The internet-based EUMETVIEW cannot compete with the fast download speeds (20-45 Mbits/sec) typical 

for EUMETCast receiving systems using DVB-S2 based data transmission. We refer to the ILWIS GEONETCast 

Toolbox, available at https://52north.org/software/software-projects/ilwis-toolboxes/ for information on a 

HRIT/LRIT format MSG Data Retriever. EUMETVIEW will function well if one has a good internet connection. 

 

 CHIRPS – Rainfall (Global) 

Climate Hazards Group Infrared Precipitation with Station data (CHIRPS) is a 30+ year length of record 

quasi-global rainfall dataset. Spanning 50°S–50°N (and all longitudes), starting in 1981 to near-present,  

CHIRPS incorporates 0.05° resolution satellite imagery with in-situ station data to create gridded rainfall 

time series for trend analysis and seasonal drought monitoring. As of May 1st, 2014 version 1.8 of CHIRPS 

is complete and available (source: http://chg.geog.ucsb.edu/data/chirps/). Data is retrieved from ftp://chg-

ftpout.geog.ucsb.edu/pub/org/chg/products/CHIRP/ and is available in pentad and monthly temporal in-

tervals. Each pentad is consisting of 5 days, 6 pentads per month. 

More detailed information can be obtained from USGS report (Funk et al 2014) and the home website of 

the CHIRPS data producers at http://chg.geog.ucsb.edu/data/chirps/. 

The CHIRPS data were used as an example for satellite-based rainfall data in the Triple Collocation demon-

stration exercise (Chapter 4). We refer to the ISOD Toolbox for acquisition other global (or regional) rainfall 

data. 

 CMORPH – Rainfall - Global 

CMORPH (CPC MORPHing technique) produces global precipitation analyses at very high spatial and 

temporal resolution. This technique uses precipitation estimates that have been derived from low orbiter 

satellite microwave observations exclusively, and whose features are transported via spatial propagation 

Figure 6  EUMETView 
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information that is obtained entirely from geostationary satellite IR data. At present it is incorporating 

precipitation estimates derived from the passive microwaves aboard the DMSP 13, 14 & 15 (SSM/I), the 

NOAA-15, 16, 17 & 18 (AMSU-B), and AMSR-E and TMI aboard NASA's Aqua and TRMM spacecraft, 

respectively. These estimates are generated by algorithms of Ferraro (1997) for SSM/I, Ferraro et al. (2000) 

for AMSU-B and Kummerow et al. (2001) for TMI. Note that this technique is not a precipitation estimation 

algorithm but a means by which estimates from existing microwave rainfall algorithms can be combined. 

Therefore, this method is extremely flexible such that any precipitation estimates from any microwave 

satellite source can be incorporated. With regard to spatial resolution, although the precipitation estimates 

are available on a grid with a spacing of 8 km (at the equator), the resolution of the individual satellite-

derived estimates is coarser than that - more on the order of 12 x 15 km or so. The finer "resolution" is 

obtained via interpolation. In effect, IR data are used as a means to transport the microwave-derived 

precipitation features during periods when microwave data are not available at a location. Propagation 

vector matrices are produced by computing spatial lag correlations on successive images of geostationary 

satellite IR which are then used to propagate the microwave derived precipitation estimates. This process 

governs the movement of the precipitation features only. At a given location, the shape and intensity of 

the precipitation features in the intervening half hour periods between microwave scans are determined 

by performing a time-weighting interpolation between microwave-derived features that have been 

propagated forward in time from the previous microwave observation and those that have been 

propagated backward in time from the following microwave scan. This latter step is referred to as 

"morphing"  (source: http://www.cpc.ncep.noaa.gov/products/janowiak/cmorph_description.html).  

We further refer to the webpages mentioned and also to the ILWIS ISOD Toolbox for more information on 

downloading and using CMORPH rainfall data, next to several other data sets. 

 

 FEWSNET Vegetation cover - Africa 

As an example of satellite vegetation monitoring data, we have opted here to highlight some readily down-

loadable medium high resolution vegetation index data based on the old-workhorses, the MODIS sensors 

on-board the AQUA and TERRA platforms (2000 to + - present). Pls. note that MODIS sensor is phasing out 

soon and is being replaced by the NASA - VIIRS sensor and also the ESA Sentinel-3 systems. Also SPOT-

Vegetation and PROBAV 1-km resolution (1998 to present) time series of vegetation indices are available 

for the Copernicus Global data portal and through the GEONETCast near real time data dissemination sys-

tems (see also Section 3.2.2). As we are not linked to a EUMETCast receiving system or data server, we will 

use a secure web download for a widely used vegetation index over Africa, i.e., the FEWSNET NOAA eMODIS 

250m NDVI, but obtained from the European EU-JRC-MARS download site. In eMODIS, the 250-m resolu-

tion and decadal products present valuable land cover information, for a wide variety of applications.  

 

For those not familiar with EO-based vegetation monitoring, just a short note on NDVI:  

The Normalized Difference Vegetation Index (NDVI) provides a measure of the amount and vigor of vege-

tation at the land surface. The magnitude of NDVI is related to the level of photosynthetic activity in the 

observed vegetation. In general, higher values of NDVI indicate greater vigor and amounts of green biomass 

and vegetation. NDVI is and can be derived from many satellite sensors and platforms. The NDVI shown 

here is derived from data collected by the MODIS team of the National Aeronautical and Space Administra-

tion (NASA) and used by the FEWSNET network. The NDVI is basically calculated from two wavelength 

channels (visible Red and Near Infrared) of a satellite sensor, using the following algorithm: 

NDVI = (NIR - VIS)/(NIR + VIS) 
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A minor modification to this basic equation is applied in case of an eMODIS NDVI. NDVI is a nonlinear func-

tion that varies between -1 and +1 (undefined when NIR and VIS are zero). Values of NDVI for vegetated 

land generally range from about 0.1 to 0.7, with values greater than 0.5 indicating dense vegetation. Since 

the late 1980's, the Famine Early Warning System (FEWS) has used NOAA - AVHRR data to produce dekadal 

(10-day) composite NDVI images of Africa and has built a valuable archive of these data from mid-1981 to 

present. Since early 2000, MODIS 1-km, 500-m and 250-m sensor resolution data have also been used. All 

these data can be used e.g. to monitor long term (and short term) trends in vegetation cover, and can also 

be linked to causal factors such as climate, land use and human impacts. SPOT-Vegetation data and its 

follow-up PROBAV sensor are also available and currently also ESA Sentinel-3 can also be used, but these 

data record starts in the ‘90s. NDVI’s and many more vegetation related indices can be produced by many 

more satellite sensors at different resolutions. SPOT-VGT and currently PROBAV vegetation data can be 

found at the VITO (B) web portal at https://www.vito-eodata.be/PDF/portal/Application.html#Home. 

 

3.3 Citizen-based data 

At this stage, we did not inventory and gather large citizen-based data sets from Africa. Instead, we opted 

here to view and use (as an example), the Water Point Data Exchange database, available on the internet. 

However we do request interested persons to do research on open accessible citizen observations related 

to water resources (and other relevant observations) and communicate the results with the developers, 

 WPDx Water Point Database 

The Water Point Data Exchange is governed by a diverse group of WASH experts, interested in monitoring 

water and sanitation issues and progress across the world. Citizen-based data collection methods are used 

to gather information and report on status of water supply points, water availability, etc. The WPDx 

database can be accessed freely on https://www.waterpointdata.org/water-point-data and data points + 

information can be retrieved on a country basis. In this Demo Package, we used a dataset from Burkina 

Faso, retrieved mid-May or 2018-05-23 from the website. 

 

More citizen-based monitoring data will and can be added in the future, or by the user of this software 

and/or by the developers. As the Toolbox setup is open source, an intermediate to advanced ILWIS user 

can add new data entries and processing routines to the system. 

 

3.4 Forecast and Numerical Weather Prediction model-based data 

 

Forecasting of weather can be done at very short time interval (see e.g. METAR-TAF), but usually it is done 

at 6, 12 24-hr to 10-day (240-hr) time scale by the large Global Circulation models or Numerical Weather 

Prediction (NWP) Models at the global (and regional) weather forecasting centers (e.g. US-NCEP, EU-

ECMWF, Brazil-CPTEC, Australia-BOM, China-CMA and more). Several countries have own facilities and 

models for weather forecasting e.g. UK (UKMET), France (Arpège), SAWS (South Africa), etc. Most countries 

adopt regional and/or higher resolution versions of these larger global or regional weather forecast models. 
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Large amounts of historical (re-analysis data such as the US-MERRA and EU ERA-interim) and current 

forecast data are available from servers like the European ECMWF and US-based NCEP/NOAA, GMAO and 

more. Besides atmospheric data, also land surface variables (e.g. soil moisture,) and other parameters are 

available from several large model outputs. We include here only 2 examples of data (based on global data 

which are useful for agriculture, water, weather and climate resources monitoring. First, a very short term 

weather forecast from the WMO (and ICAO) affiliated Meteo services (not model but observation based) 

is shown. 

 6-hourly Weather forecasts from METAR & TAF 

This very short term forecasts present reports, derived from airport station observations and made by avi-

ation meteorologists and forecasters (and not from global models). Reports from actual weather (and 6-

hourly forecast) of all ICAO (Int’l Civil Aviation Organization) registered (and operational) airports are con-

tained in 6-hourly METAR (i.e. 06.00 UTC; 12.00UTC, etc.) or Meteorological Airport Reports, and in 6-

hourly Terminal Aerodrome Forecasts (TAF), respectively one hour ahead of METAR. These information’s, 

typically used by airline pilots and other navigators is accessible through several telecom channels, but info 

is typically coded. A code reader - converter is therefore required. The following two web portals can be 

used to see what METAR and TAF is all about, incl. downloading. [http://en.allmetsat.com/metar-taf/  ;  

https://www.aviationweather.gov/metar/gis].  Pls. see the ISOD Toolbox for retrieval. The ISOD toolbox can 

be used for retrieval of these short term 6-hourly weather forecasts from ICAO coded airports. 

 US – NOAA - GFS-based (10-day) Global weather Forecasts  

The US - NOAA’s CPC or Climate Prediction Centre (i.e. one of the National Centers for Environmental 

Predicition or NCEP) is providing forecasts on Weather and Climate Parameters for Africa, like Precipitation, 

Temperature, Winds, Heights, MSLP, Relative Vorticity, SST, etc. using their NWP Model (available at 

http://www.cpc.ncep.noaa.gov/products/international/africa/africa.shtml). The Global Forecast System 

(GFS) is a weather forecast model produced by the National Centres for Environmental Prediction (NCEP). 

Dozens of atmospheric and land-soil variables are available through this dataset, from temperatures, winds, 

and precipitation to soil moisture and atmospheric ozone concentration. The entire globe is covered by the 

GFS at a base horizontal resolution of 18 miles (28 kilometres) between grid points, which is used by the 

operational forecasters who predict weather out to 16 days in the future. Horizontal resolution drops to 

44 miles (70 kilometres) between grid point for forecasts between one week and two weeks. The GFS model 

is a coupled model, composed of four separate models (an atmosphere model, an ocean model, a land/soil 

model, and a sea ice model), which work together to provide an accurate picture of weather conditions 

(source: http://www.ncdc.noaa.gov/data-access/model-data/model-datasets/global-forcast-system-gfs. 

 Seasonal Forecasts (90-day) from WMO – Regional Climate Outlook Forums 

The analysis of seasonal weather patterns, and effects of global or regional climate phenomena (e.g. the 

strengths of ENSO or El Nino - La Nina, the Indian Ocean Dipole, North Atlantic Oscillation, equatorial Mad-

den Julian oscillations and more) on our weather at the 3-montlhy (90-day) time scale, and also the seasonal 

forecasting is done by climate centers and a number of WMO Regional Climate Outlook Forums. In Africa, 

the RCOFs are organized as shown in Figure 7. 
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Figure 7   WMO Regional Climate Outlook Forums – Africa 

The WMO allied African RCOFs are closely affiliated and in fact strongly depending for their weather fore-

cast data and information, next to the national NMHS Services, from three main African meteorological 

centers, i.e. ACMAD, ICPAC, the SADC-Centre and also the SAWS (South African Weather Service) for the 

Southern Africa region. Pls. see also the Afrialliance Report Deliverable D4.4 for more information.  

 

 EU – ECMWF – IFS model based Data 

Most of the European Center for Medium range Weather Forecasting (ECMWF) data derived from their IFS 

or “Integrated Forecasting System” global model are available from the ECMWF data servers at 

www.ecmwf.int.     

The EU-JRC-IES is using these data to provide interesting data for monitoring agricultural production and 

food security. The Monitoring Agricultural Resources (MARS) Unit (http://mars.jrc.ec.europa.eu/mars/) is 

focusing on crop production, agricultural activities and rural development. The MARS Unit provides timely 

forecasts, early assessments and the scientific underpinning for efficient monitoring and control systems. 

Data needed for this purpose is based on various ECMWF including the ERA-Interim and the OPE (opera-

tional deterministic ECMWF model). Long time series of dekadal rainfall (from 1989 onwards at 0.25 degree 

spatial resolution) is made available online through JRC’s SPIRITS webpage (http://spirits.jrc.ec.eu-

ropa.eu/?page_id=184). The routine provided here is merging the various windows into a global precipita-

tion map (in mm / dekad), both for the Interim as well as the operational data. For further information also 

consult the MARS Crop Yield Forecasting System wiki, available at: http://marswiki.jrc.ec.eu-

ropa.eu/agri4castwiki /index.php/Main_Page 

 

The MARS ECMWF-based meteorological database is a daily weather data base based on various European 

Centre for Medium-Range Weather Forecasts (ECMWF) sources. The MARS ECMWF data set includes ERA-

INTERIM (from 1989 to March 2013) and OPE (operational deterministic ECMWF model) data currently 

covering the period April 2013-April 2014. The ERA-INTERIM data set is a reanalysis of the global 
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atmosphere. Due to this reanalysis system, ERA-INTERIM has proven to have better performance compared 

to previous reanalysis data sets such as ERA-40, see also 3.16.8. The following variables are available: mean 

temperature (C), maximum temperature (C), minimum temperature (C), ET0 (in mm, according to Penman-

Monteith, based on dew point, daily radiation sum, wind speed, and temperature) and rainfall (mm). A 

number of pre-processing steps were developed in the MARS project, to prepare the data as input to the 

crop models. For instance x-hourly data are aggregated to daily time steps and a downscaling method was 

developed consisting of an inverse distance weight interpolation (IDW) from the 0.75 degree ERA-INTERIM 

grid to the 0.25 degree OPE grid and of a bias correction between the IDW-interpolated ERA-INTERIM 

model and the OPE model (not applied to rainfall). The dataset has a global coverage and the time series is 

from 1989 onwards, but from April 2014 there is currently an interruption of the service reported. 

Temporal resolution is daily although only the dekadal product is presently distributed by JRC. The spatial 

resolution: 0.25 degrees (http://marswiki.jrc.ec.europa.eu/datadownload/index.php and 

http://spirits.jrc.ec.europa.eu/). Dekadal format expected by the routine is yyyymmdekdek, e.g. 20101201, 

for the first dekad of December. 
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4 Guided demonstration exercises 

 

The download locations for this software, documentation and demo exercises are: i> the Afrialliance Pro-

ject web portal (www.afrialliance.org) or (01-Jan-2019 onwards) also from https://52north.org/software/ 

software-projects/ilwis-toolboxes/. A preview of last version(s) and sample data can also be downloaded 

from ftp://ftp.itc.nl/pub/52n/AfriAlliance/. The download location contains 3 zip files: 

- Softwares.zip with ILWIS3852.zip and three small ancillary Open source ware \extrasoft.zip containing 

install files of the utilities: Irfanview, Notepad++, and 7zip. Note that these are optional utilities. 

- Sampledata.zip with 2 exercise data zip files: ilwisout.zip (data explore/import examples) and Da-

nocase.zip (triple collocation demo data sets).  

- ToolboxUserGuide.zip with reports & other Toolbox Manuals. Ps. User guide also in software Help. 

4.1 Installing ILWIS Open and the Afrialliance Triple Sensor Toolbox 

We use the ILWIS v3.8.5.2 version in this manual version (Nov-2018) and in software directory ..\soft-

ware\ILWIS3852.zip. This version, contains a build-in first version of the Afrialliance Toolbox v1.0. If for any 

reason, you have already an ILWIS installation on your PC, you will still need to copy this version and put 

this aside or next to your other (older) Ilwis. This is not a problem, as multiple different Ilwis instances can 

be run on your system (one at a time). Ps. ILWIS is not a large software (30MB) and Toolbox (+- 90 MB), so 

not storage space hungry, Ps. the sample data may be more voluminous (+- 500 MB).  

 

Copy and Unzip the Ilwis3852.zip to a working drive e.g. c:\ or d:\... or similar. Pls. do NOT unzip the IL-

WIS385.zip to your D:\Program Files or Program Files (x86) Windows directories, or to your Desktop!! These 

directories are usually “write protected” and the Toolboxes need read/write access to their software sub-

directories. The desktop location has a very long Windows “path” which does not work with all Toolbox 

routines. Pls. make things easy, and unzip to an open drive e.g. C:\, D:\. E:  

 

Browse to your newly created drive name: \ILWIS385x directory and create a “Shortcut to Desktop” of the 

ILWIS.exe application, which you will find in root of the newly created D:\ILWIS385 directory. You can also 

just open Ilwis by just double-clicking on this Ilwis.exe (executable windows application). Easier is however 

to use the Desktop Shortcut Icon to launch Ilwis. Note: you do need to unzip the ILWIS3852.zip file. ILWIS 

will not start if you double-click ilwis.exe inside the zip file. 

 

Create a working or output directory for the data using e.g. Windows explorer > Create New Folder, some-

where on the root of a drive. Pls. use a short directory name e.g. .\Afrialliance or .\ilwisout….. (Your own 

choice). D:\ilwisout will be used as Ilwis working directory or data catalog through this manual. 

 

Copy and Unzip the ilwisout.zip to your Ilwis working directory (data catalog) e.g. d:\ilwisout. Pls. first create 

this new folder (directory) using Windows File explorer. This zip contains Ilwis file samples of the output 

(generated by the ftp-based data import routines of the Toolbox. This is useful for users without good (or 

no) internet access and permits to browse results from the Ilwis data imports and (pre-) processing. Imports 

with the toolbox will generate copies of the files (in many instances i.e. if equal time stamps are used). 
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Open ILWIS and browse to the working directory (your Ilwis data catalog). Note that this working directory 

is still empty, if you didn’t copy any data yet. Get some look and feel of the ILWIS GUI.  Ps. if you now close 

and open ILWIS again, it will open with your working catalog active (visible). 

On opening Ilwis v3.85.2, the following windows will be shown. Scroll down in the Operations-Tree until 

you find the Afrialliance Triple Sensor Icon. The data catalog should indicate e.g. d:\ilwisout or … In case, 

you don’t see this Folder, pls. create it first using Window File explorer > New Folder.. 

 

Figure 8  Ilwis v.3 GUI with Data Catalogue and Operation Tree > Afrialliance Triple Sensor Plug-in 

 

Now Open the Triple Sensor [+] and Open the Toolbox. If you also open the Level-1 [+], then you will find 

this Menu structure. By clicking on the respective entries, you will be guided to the applications. 

 

Figure 9  Triple Sensor Demo Toolbox (after opening main Tabs to Level-2 Sub-menu) 
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4.2 Retrieve and explore example data sets  

Let’s explore some data sets described briefly in Chapter 3. In order to do the data and tool explorations, 

users should be linked to a good internet connection (with sufficient download speed). Downloads 

represent typically compressed data files ranging from <1MB to 10MB. The maximum download size in this 

Demonstration toolbox is 100MB for 250-m resolution eMODIS Vegetation Index data.  

 

Get your ILWIS Ready: configuration of input – output directories 

Start ILWIS3852 (e.g. from your desktop Icon) and then open the “Triple-Sensor” > “Toolbox” that is found 

in the Operation-Tree on the left of the ILWIS window. Inspect the menu of the Toolbox and open the item 

“Configuration” > “Folders”.   

Note that here the assumption is made that 

you have created, a directory called 

“.\Ilwisout” or any other own name on your 

local storage drive. For all the items under 

Folders (Chirps, Cmorph, CPC_gauge, 

GSOD,…) specify the appropriate directory 

“D:\Ilwisout” and press “Save” to store the 

‘drive:\directory’ ilwis output setting. Close 

the Toolbox and use the ILWIS Navigator to 

move to the directory “D:\Ilwisout”. Close 

ILWIS and start ILWIS again, and confirm that 

the location of your data catalogue is 

“D:\Ilwisout”. Now, from the Operation-Tree, 

start the “Triple-Sensor” > “Toolbox”, and 

you are ready to start the exercises. Note that if you have changed working directory during an active ILWIS 

session, it is advised to close ILWIS and start it again. This is very fast. This way ILWIS (and Windows!) will 

“remember” the most recently used working directories. Pls. Note that running any data import operation 

with the Toolbox, with the wrong data catalogue & output folder active, will give a fatal (import) error in Ilwis. 

 

 Import WMO-GTS GSOD synoptic meteorological station data 

Within the Triple-Sensor toolbox, utilities are available to import data from the global meteorological data 

archive maintained and updated by US - NOAA - NCDC, providing „Global surface Summary Of Day“ or GSOD 

data on meteorological station variables. First a map will be visualized showing the global locations and the 

station numbers of the climatological stations (over 27750 records). From the “Triple-Sensor Toolbox” main 

menu select the “In-Situ Station Data” > “WMO-GTS GSOD Meteo Station Data” > “Stations map of Global 

Figure 10   Configuration of your output folders (a/o Ilwis data 

catalogue) 
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surface summary of day product produced by the NCDC” sub menu. Confirm (check data catalogue window 

name) that your “Output Directory” is “D:\Ilwisout” and press “Import”.  

After import, a map view will be shown, 

indicating the locations of the stations. Moving 

the mouse over the map, while keeping the left 

mouse button pressed, provides information on 

the station number. Additional information 

(attributes) is shown at the bottom-left of the 

map window. Zoom into the area of interest and 

move the mouse over a station to see addidional 

details about that station, such as station name, 

USAF number, coordinates and elevation. The 

USAF station code number should be noted as 

this is used during the subsequent extraction of 

the daily summary data. 

To extract the station data, from the “Triple-Sensor Toolbox” main menu select the “In-Situ Station Data” 

> “WMO-GTS GSOD Meteo Station Data” > “Import GSOD station data” sub menu. Specify the “Year”, and 

enter the USAF number from the previous step in “Station”, confirm that the “Output Directory” is correct, 

and press “Import”. Here use is made of the station “Ilha do Sal”, year is “2015” and USAF station number 

is “085940”.  Note that a 6 digit station code is required; in case the station has only a 5 digit code the 

station number coding should be preceded by a zero (0). The USAF station code for Praia is “085890”. Here 

Sal station is used for further explanation, but you can freely substitute it with ‘Praia’. (Ps. Praia has now 2 

USAF codes; only one is operational; old aerodrome and new airport locations). 

Additional information on the data is provided when selecting the “Metadata” option. The import routine 

downloads, extracts and processes the data. Additional columns are calculated providing the data in SI 

units, like temperature (also minimum and maximum), dew point, visibility, wind speed and maximum wind 

speed, precipitation. Note that if during import an error message appears that ILWIS cannot find a table, 

close ILWIS, start ILWIS again and repeat the import. This error occurs when navigating to another directory 

during the import. 

When the import routine has finished, close the “Triple-Sensor Toolbox” by pressing the “Cancel” button 

on the bottom-right of the Toolbox, then refresh the catalogue by selecting from the ILWIS menu the option 

“Window” > “Refresh”. To visualize the imported station data, open the imported table by double-clicking 

it. Its name is formatted like “st_USAFno_year”, in this case “st_084940_2015” or “st_085940_2015”. 

Inspect the table content. In the menu of the table window, click on the “Graph” icon, in the subsequent 

popup window, don’t select an X-axis (unselect it), and for the Y-axis select the attribute to be visualized, 

here “Prcp_mm” and press “OK”. 

Now from the graph elements on the left, the visualization properties can be changed. Double click the 

layer labeled “- Prcp_mm”. In the Graph options, change the name to “Precipitation”, select a “Needle” 

representation, instead of a point, optionally change the color to “Blue” and press “OK”. 

Now from the menu of the graph window, select “Edit” > “Add Graph” > “from Columns” and select for the 

Y-Axis the table attribute “TempMIN_C” and press “OK”. Double click the layer “- TempMIN_C”. In the 

Graph options, change the name to “Minimum Temperature”, select a “Line” representation, instead of a 

point, optionally change the color to “Magenta”, at “Use Y-Axis” select “Right”, and press “OK”. 

In the graph elements on the left, enable (double click) the “Y-Axis Right” , then double-click the item to 

set the Axis Text “Temperature”, set the Min-Max Interval to “-10” and “50” respectively, uncheck the 

Figure 11  WMO GTS station map Africa (with active map info)
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option “Show Grid”, and press “OK”. Note that the data range required can be obtained from the statistics 

pane which is shown at the bottomof the table. 

Repeat the procedure for the attribute “tempMAX_C” and “Dewp_C”, call these “Maximum Temperature” 

and “Dewpoint Temperature” respectively, select as representation “line” and select appropriate colors, 

and ensure that the Y-Axis Right is used. In the graph window itself the title can be modified. Double click 

on the title in the Graph and consult figure 2.3.1 for a sample title.  

The graph can be saved on disk with the “Save” button of the graph window, so that it can be re-opened 

as-is another time. 

Figure 2.3.1 Daily Air Temperatures for Ilha do Sal airport (2015), USAF station number 085940 

 

Figure 12  ILWIS table column Graphs of GSOD daily air temperatures (station code „st_085940“2015) 

 

 Import and analyse NOAA CPC-FEWS WMO-GTS daily station Data 

This routine – in contrast to the previous GSOD import routine which imports a daily time series (one year) 

of one station -  imports for a specified day all globally available (i.e. reporting to the WMO-GTS system) 

station temperature (min, max) and precipitation data. A large table will be generated by ILWIS with data 

collumns and several thousands (+- 8000) of records of station ID data, latitute – longitude and temperature 

and rainfall data.  
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Figure 13  Import of all available global GSOD (PRECIP, TEMP) station data for a specified day 

The screenshot above performs an import of 01-Oct-2018 global station data. This import will create an 

ILWIS table object named „gts_20181001.tbt“ in your Data Catalog. See screenshot below. The import and 

table generation in Ilwis will take a few to 10-30 seconds. Pls. Be patient until the routine closes. 

You can open the table and browse the content. The records represent the stations and collumns data. E.g. 

browse to the reported Precipitation collumn. 

By using the Table to Pointmap option in ILWIS, e.g. a global daily station-

based rainfall map can be created. You can do this in several ways: 

- Go to the Operations Tab > Table Operations > Table to Pointmap. In 

the box use, X, Y cols for X, Y (lon-lat) and select LATLON as coordinate 

system (or LATLONwgs84). 

- Select Use Attribute Column as Input, and select reported 

precipitation. 

- Give an output name e.g. gts_20181001_prcp and click Show. 

- A global station pointmap with circles (stations) and with colors 

representing the precipitation will be shown (and created). 

- Overlay the pointmap with a countryboundary using the Layer > Add 

Layer > Filter All> Basemaps> country_boundaries>ok. 

You can change the colours using the Display Tools > Portrayal> 

Representation Menu. You can also change the circles by e.g. filled circles 

or dots using (double click) > Symbolization. Pls. Note that this whole 

Table to Point map operation can also be called using a Right-hand mouse 

click when on the Table file Object (in the Data Catalogue). 

Figure 14  Example of Ilwis data 

catalogue with im-

ported file objects 
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Figure 15   Map Quick display of global (daily) PRECIP station (point) data 

 

Figure 16  Zoom-in on West Africa recorded GTS stations (filled circle colour symbolization) 

 

This global point data can be further interpolated to a gridded field (after carefull selection of the spatial 

interpolation routine). We however strongly recommend to use the CPC Gauge-based Analysis data set, 

which has been already carefully interpolated, and is available in the Triple Sensor Toolbox > In-Situ Station 

data > CPC-Gauge based global daily PCP analysis. 

 Import CPC Gauge-Based analysis of Global Daily Precipitation 

This gridded 0.5 Degree or approx. 50 km grid resolution near the equator data set in fact contains the 

interpolated station data from the WMO-GTS and CPC-FEWS (see abovesecton 4.2.2). Pls. Use these data 

if you require gridded fields (e.g. full contry coverage) of daily station-based rainfall data. The import of the 

01-Oct-2018 would be as follows. Go to the in-sity Menu and CPC-Gauge based …. And type your date. An  

import will be performed. Pls. Wait until the routine closes.  
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A CPC-Pgauge_20181001 raster map object is created. Open this map, change the color look-up table, using 

the Display Tools > Portrayal> Representation (using Double-click) > Use mpe_sum as colour Look-up-Table 

or LUT. Then overlay the map with the country_boundaries Layer (from the Layer>Add Layer Menu>Filter 

All>Basemap collection). See under 4.2.2. A map as shown below is created. 

 

Figure 18  Map view of gridded global precipitation (01-Oct-2018), displayed using a MPE_SUM Colour LUT 

If you zoom in to e.g. a country or smaller areas, then you can also use Open Street Map (OSM) as an 

overlay. Once, you open a map object, this OSM background map layer can be obtained from the Layer > 

Add Layer Menu > Filter All > Base maps > openstreetmap. You should increase the Transparency of this 

OSM map to be able to view the rainfall map. Do this by opening the Display Tools>Transparency Button 

and increase to e.g. 30%.  

 

 View SASSCAL WeatherNet, WASCAL an TAHMO data sources 

The data from these in-situ stations, collected by these organizations, can (at this moment) not be directly 

imported in this Toolbox. The user has to access and browse the respective websites and download data 

e.g. as an Excel or .csv data files. These files can be imported as Table in ILWIS from the 

File>Import>ILWIS>Table Menu. Pls. See the example given by the Citizen Data Import (use case Dano, 

Burkina Faso). 

 

Figure 17  Import of gridded global daily precipitation data from NOAA/NCEP/CPC 
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 View and import current satellite weather data with EUMETView 

From the Earth Observation Satellite Data Menu, open the EUMETView Near real time MSG and Sentinel-3 

Tab, for the most recent EUMETSAT image data, and hold-on until the application is launched. This depends 

on your internet speed. You can now browse a variety of geostationary MSG Meteosat weather satellite 

image data (i.e. wavelength bands), but also derived visualized MSG products. The polar orbiting ESA Sen-

tinel-3 is also available. 

 

Figure 19  View and Import of Near Real Time EUMETSAT data using EUMETView - ftp 

First explore some Imagery > Meteosat MSG wavelength bands TIR10.8, WV6.7, IR3.9 and VIS0.6. For ex-

ample, the Thermal Infrared 10.8 µm channel permits to view cloud cover [day and night], whereas the 

visible solar 0.6 µm channel will illustrate the typical solar illumination “day-night” observation cycle. 

 

Figure 20  EUMETView screen (MSG thermal band 10.8 µm shown and Field-of-View of Atlantic Service) 

Then Go to Visualized Products and explore near real-time MPE rainfall fields (i.e. the MSG MultiSensor 

Precipitation Estimate). This tells where it is raining at this moment and also the intensity of rainfall (last 

15-min) from eastern Brasil to Africa. Europe and Middle east (based on the MSGMPE algorithm).The IODC 

service (at 41.5 lon) provides information for countries around the Indian Ocean. 
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Figure 21  EUMETView of Visualized MSG data (near real time MPE Multisensor Precipitation Estimate) 

From RGB composites, also explore a Daytime Natural Color Composite.  You can download an image (of 

choice) using the Download Button ↓ (upper right) and the GeoTIFF - full resolution - option.  

 

Figure 22  EUMETView of MSG Daytime Natural Colour Composite image  

To import this downloaded Geotiff file in Ilwis, first locate it on your laptop (your internet browser generic 

download folder) and optionally copy (or move) the file from this download location to the Ilwis Data Cat-

alog (directory). An example filename of this 55 MB map (full MSG  disk image) is: 

meteosat-msg_natural_overlay-ne_10m_coastline_overlay-ne_10m_admin_0_boundary_lines_land.tif 

Go to the File Menu > Import Tab > GDAL > Raster > GeoTiff>… and perform the import to Ilwis (using e.g. 

output name matches input or a name of choice). 
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Figure 23  Import of downloaded (GeoTiff) data from EUMETView with the File>Import>GDAL Menu 

 

A file container (containing the three RGB bands + kappa file) of the same name, a coordinate system and 

georeferenced file will be present in your data catalog.  

 

Figure 24  View of imported MSG files in Data Catalogue: coordinate, georeference, maplist, histogram files 

Open the file Maplist (double click on Icon), then Open the Color Composite using Open as Maplist.  

You should invert the Color Scheme (RGB 1,2,3 to BGR 3,2,1) to display the same color composite. To do 

this, open the Display Tools> Color Composite (Double-Click)> Select Bands and reverse the 1>3 and 3>1.  

Pls, overlay the map with the country boundaries (in yellow). 
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Figure 25  Meteosat MSG Field of View (3-km resolution DNC colour composite) 

 

From this large MSG 3-km resolution map, sub maps e.g. for all countries or regions of interest in the field 

of view of MSG (Atlantic Service shown here) can be made with Ilwis (File > Submap menu in view window). 

Also the Indian Ocean IODC service is available as well as the global ESA-Sentinel-3 OLCI sensor orbital data. 

 

Figure 26   ESA-SENTINEL-3 OLCI orbital quick look (shown in false colour LUT) 
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 Import CHIRPS rainfall data 

To import CHIRPS precipitation data for Africa, select from the “AFRIALLIANCE” > “Toolbox”. Main menu 

the item Earth Observation Satellite Data and further to the >“CHIRPS – Rainfall - Africal” sub menu. In this 

case only the “Date” field and the “Output Directory” need to be specified. Pls. work in your data catalog, 

as specified in the Toolbox configuration for CHIRPS. The CHIRPS v2.0 data are delayed (+-2 months), due 

to merging with stations.  

Go to CHIRPS V2.0 Dekad (10-day) and select a Date stamp select e.g. “2018071” and press “Import”. This 

is the first dekad (day 01-10) of August 2018. After the import has been completed, display the newly 

created map “chirps_201007d1”, using as Representation “Pseudo” (see Display Tools). Add the country 

boundaries (no Info, boundaries only) and use pixel information to inspect the values. If you use the 

PSEUDO Color Look-up table, you better apply a color Stretch (reduce the max. value) for a better view 

(from the Display Menu). You can also use a rainfall MPE-sum Representation for a nicer look. Change this 

using the Portrayal – Representation settings from the Display Tools Menu. 

 

 

To import the data from the CHIRPS pentad precipitation data (aggregated to 5 days)  

“CHIRPS V2.0 pentad” sub menu. There are 6 pentad per month, so use 1 to 6 after the year-month data 

stamp, e.g. Date stamp select “2018076” (for the last pentad of July 2018) and press “Import”. After the 

import has been completed, display the newly created map “chirps_201007p6”, using as Representation 

“MPE-sum”. Add the country boundaries (no Info, boundaries only) and use pixel information to inspect 

the values.  
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To import the data from the CHIRPS daily precip-

itation data, go to the 

“CHIRPS V2.0 daily” sub menu. Use a Date stamp 

select “20180701” (for 01-July-2018) and press 

“Import”. After the import has been completed, 

display the newly created map 

“chirps_20180701”, using as Representation 

“Pseudo or MPE-sum”. If using the Pseudo Color 

LUT, you should stretch the color range (e.g. re-

duce the max. value), using the Display Tools 

Stretch Menu. Add the country boundaries (no 

Info, boundaries only). 

 

Pls. note that for multiple imports, i.e. time se-

ries, other automated (batch file) ILWIS-based 

routines exist. See also Triple Collocation Menu 

and/or also the GEONETCast Toolbox User Guide 

v.1.6 (par.4.1 p.125-128) or contact the develop-

ers. 

 Import CMORPH global rainfall data 

Using the CMORPH Tab will permit you to import a range of global satellite precipitation data based on the 

CMORPH algorithms. The procedure is similar to CHIRPS. We advise to get first familiar with the several 

data sets available (see Chapter 3) and also the information websites and references supplied. For import 

of CMORPH rainfall data, we further refer to the ISOD Toolbox User Guide (also included in the Documen-

tation, and/or downloadable from the www.52north.org together with the ISOD toolbox. 

  

 Import FEWSNET Vegetation Cover data for Africa 

From the Earth Observation Satellite Data sub-Menu, this import routine will permit you to import FEW-

SNET eMODIS 250-m NDVI vegetation index data. As a 250-m resolution yields rather large file size, the 

import is done per four quadrants of Africa North, East, South and West.  

Pls. for Zambia, Go to Dekadal NDVI – Southern Africa – last 3 dekads and perform an import. Pls. note that 

import will take a while (e.g. > 60 seconds to several minutes in slow internet environments, due to large 

raw i.e. +100MB data size). You need to find of course the dekad equivalent number [0-36 dekads in a year] 

and specify this after the year as dekad number. E.g. the 10-day periods or dekads of January have numbers: 

01 (day 01-10), 02 (day 11-20), and 03 (day 21-31) and June have numbers: 16, 17, 18 and so on. Here a 

view of a last dekad of July 2018 import for eMODIS NDVI of Southern Africa. 

Figure 27  CHIRPS v.2 daily precipitation (01-July-2018) dis-

played using a stretched “Pseudo” Colour LUT 
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Figure 28   Import of FEWSNET 250-m vegetation index (NDVI) data (e.g. Southern Africa region) 

 

After importing a vegetation cover (index) map, pls. apply an adapted NDVI1 Color LUT to the map, as 

shown below (a Southern Africa eMODIS, 2nd dekad September 2018). All maps in ILWIS can be easily sub 

mapped using the File>Submap function, available in the Display window (top left). You can then save this 

as a separate map (see below e.g. a subset of Zambia, Zimbabwe, NE Mozambique of the eMODIS NDVI 

Vegetation Index map). Pls. note that dark green colors indicate more dense green vegetation, yellowish 

less dense and white pixels represent no data values (cloud coverage did not permit uptake of an image 

during that decade at satellite overpass). Negative values e.g. on water surfaces may be observed in NDVI 

maps, as water surfaces typically absorb NIR near Infrared more than Red wavelengths. Large waterbodies 

are usually masked out of NDVI land cover data. Also time series can easily be generated. 

 

 

Figure 29   Ilwis map views of 250-m NDVI vegetation index data (using an NDVI1 Colour LUT)  
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 Import Citizen WPDx (WaterPointData Exchange) data 

As an example for importing citizen-based observations, we show here the import of a dataset of Burkina 

Faso (used later under 4.3) , downloaded from the WPDx WaterPointData exchange database at  

https://www.waterpointdata.org/water-point-data. Just select “Burkina Faso” as the country and click 

“Download country data” to download the data as excel.csv formatted file. Depending on the moment that 

you download the file, it will have a name that looks like “wpdx_data_export-2018-11-01T08-48-14.csv”. 

Ps. For sake of speed and practice, the datafile is supplied with the demo in the sub-directory .\sampledata. 

Copy the file to the “Working Directory” e.g. “D:\Ilwisout”. 

Then start ILWIS, and navigate to the “Working Directory”. The file is not visible in the ILWIS Catalog 

because it still has to be imported into the ILWIS file format. To do so, in the ILWIS menu, choose “File” > 

“Import” > “ILWIS” > “table” > “Comma delimited”. The form has entries for (among others) Input and 

Output. At Input, click the “…” button on the right, and select the wpdx_data_export…csv file. Then click 

“Options…”. In the first screen, just confirm the preview of the selected file, and click “Next”. In the second 

screen titled “Import Table Wizard - Edit Column Details”, change the “Nr. of Header lines” to 2 (instead of 

0). ILWIS uses the first 10 lines of the table to estimate the data-types of the columns. Some corrections 

are required: 

Change the “Domain Type” of row “water_source” to “string”. To do so, double-click the current domain 

type “value”, select “string” from the list, then click on any other item (e.g. on “water_tech”) to confirm 

the change. 

Apply the same (change to string domain type) for rows “status_id”, “pay”, “installer”, “adm1”, “adm2”, 

“photo_lnk”, “fecal_coliform_presence” and “subjective_quality”. 

For row “install_year” change the Columns “Min”, “Max” and “Precision” to resp. 1900, 2050, 1, for row 

“lat_deg” change the “Min”, “Max” and “Precision” to resp. -90, 90, 0, and for “lon_deg” change the “Min”, 

“Max” and “Precision” to resp. -180, 180, 0 . 

Optionally you can also choose not to import all 30 columns of the table. When importing less columns, the 

last columns will be omitted. However keep the columns “lat_deg”and “lon_deg”. 

Click “Finish” to confirm the choices. Then click “OK” to perform the actual Import of this csv file into the 

ILWIS Table format. If you haven’t changed the Output filename, the ILWIS file will have the same name as 

the original csv file. 

Note: WPDx may change the columns in their csv files over time. If this happens, above instructions must 

not be taken literally. 

Double-click the table to open it and have a look at its content. 
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Figure 30   View of Citizen Water point data table (Burkina Faso; imported from WPDx.org, 01-Nov-2018) 

Click with the Right mouse button on “status_id” (the header of the column), and from the menu that 

appears choose “Properties”. In the form that appears, click the button “Create new Domain from Strings 

in column”. Just click “OK” in the form that pops up. 

Close the table. Back in the ILWIS Catalog, confirm that two new items appeared, both named “status_id”, 

but with a different icon. The one is Domain Class “status_id” and the other is Representation “status_id”. 

Double-click the Representation “status_id” and change the colors so that “no” =  Red, “unknown” = Yellow 

and “yes” = green. 

Close the representation. In the ILWIS Catalog, click on the table with the Right mouse button. From the 

menu that appears, choose “Table Operations” > “Table to PointMap…”. In the “Table to PointMap” form 

that appears, change “X Column” to “lon_deg”, “Y Column” to “lat_deg”, and in “Coordinate System” 

choose “LatlonWGS84” from the list. In “Output Point Map” type the output filename, e.g. 

“WPDxBurkinaFaso”. Then click “Show” to create the pointmap. It will automatically open in a new Map 

Window when done. 

  In this point map, one can clearly see the 

challenges of importing complex tabular data 

from open databases. Some outliers (one 

extreme at 0 (zero) latitude  is visible. Also 

are there no WPDx observation points from 

[0 to 1 degree] west from the 0- longitude 

meridian. This data flaws are also visible in 

the raw WPDx.csv file. Of course, raw data 

can be inspected and cleaned or corrected in 

Ilwis (or Excel). 

 

Figure 31    Observer point coordinate issues detected in WPDx data (@ Greenwich 0-longitude meridian) 

 

A better view is obtained when adding „OpenStreetMap“ as a background map. 
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Note: this step assumes that you have an internet connection. Alternatively any other of the background 

maps can be used as a background. 

Click with the Right mouse button on the white space in the layer-management area on the left, below 

“Background”. From the menu that appears, choose “Add Layer…”. Change the “Filter” to “Base maps”. 

From the list above, select “openstreetmap”, and click “OK”. 

The OpenStreetMap tiles are downloaded and appear on-top. Use the mouse to re-arrange the layers in 

the layer-management, so that “openstreetmap” is under “WPDxBurkinaFaso”. 

Change the colouring of the Burkina Faso water points. 

In the layer-management, click on the “+” (plus) before the “WPDxBurkinaFaso” Point Map to open it. Then 

click on the “+” before “Display Tools”, and then on the “+” before “Display Attribute”. Change the “Display 

Attribute” to “status_id”. The colors of the points change, but we need to change the symbols. For this, 

double-click “Symbolization”, change the “Symbols” to “filled-circle”, click “Apply” and then “Close”. The 

green locations represent the working water points in Burkina Faso. Note that some points are not placed 

where expected. This is because of errors in the WPDx csv file that must be manually corrected. Also for 

some reason we don’t know yet, there are no points between -1 and 0 degrees longitude. 

 

Figure 32   WPDx data visualization using Open Street Map (as background) 

The display of specific groups of points can easily be enabled/disabled. Click the “+” before “Portrayal”, and 

then click the “+” before “Representation”. Unselect e.g. the “yes” to hide all working water points. Only 

the non-working and the ones with an unknown status remain on the map. Use the “Zoom” and “Pan” 

buttons of the Map Window to change the mouse action, and zoom-in to a specific location. 

 

 

Figure 33   WPDx „working water points “only, visualized from WPDx Burkina Faso dataset 
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 View 6-hourly (current) weather forecasts at airport locations  

Decoded METAR or TAF reports from civil airports (using a ICAO-ID code) are requested in this routine from 

the  https://aviationweather.gov/.. , an US-NOAA-NWS National Weather Service linked website. Other 

download sites and options are possible, but this site delivers continuous up-to-date (present time) data. 

Run the application which goes to the Aviation Weather Service website. Browse (move and scroll) the 

global map to your Region of Interest (ROI) and check for available (actively reporting airport stations). A 

coded METAR report will  be shown when pointing (clicking) on a station. To get the decoded report 

(readible data by non-aviation meteorologists), request the decoded METAR a/o including TAF report 

(issued 1-hour ahead of the 6-hourly METAR. To do so, first Look-up the IDs or ICAO code (e.g. GVAC is Sal 

Island, Cape Verde; EHAM for Schiphol airport, etc.), and Use Request METAR data (See data entry on 

webpage under station map). You can also find ICAO airport codes on the internet (Tabular information). 

The METAR report will give you the current (assumed valid for 6-hours ahead) air temperature, dew 

temperature, air pressure, Rel. Humidity %, wind speed and direction, rainfall including type, cloud base 

and ceiling, and octets (i.e. cloud cover), and more information supplied to aviation pilots etc. Also the TAF 

report can be included. 

 

 

Figure 34   View & retrieval of METAR and TAF reports from Aviation Weather Center web portal 

 

 Import NOAA - GFS  Global Forecasting System (10-day) weather Forecasts 

You can import and derive (from present to max. 240-hours ahead or 10-days), forecasts of the global 

weather e.g. rainfall and temperature for the whole world from the US-based - NCEP - CPC Numerical 

Weather Prediction model(s). ILWIS downloads, imports and creates own maps, which can be used later, 

and also displayed as a Slide show animation (e.g.), using the maplist View Menu.  
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Figure 35   Import of Global Forecasting System GFS - current to 10-day - forecasts (precipitation) 

The window above shows an import of a 10-day global rainfall forecast time series (24-hr, 48-hr, 72-hr and 

so on until 240-hr) derived from the US GFS forecasting system foe 02-Nov-2018 to 10 days ahead. 

The import will generate 10 global daily (1 to day 10) forecast maps in your Data Catalog. 

 

 

 

 

 

 

 

 

 

 

 

 

A visual time series animation can be 

created, after storing all the 10 maps in a maplist (using File>Create>Maplist) and then using the maplist 

Open and Visualization (open as Animation function).  Also first add the country boundaries and select a 

good Color LUT (e.g. MPE-SUM shown here). Then click on the Display Tools and then Run. The animation 

meny will appear. 

 

 View Seasonal Forecasts from WMO – RCOF (Regional Climate Outlook Forums) 

The Toolbox allows to look-up web-based seasonal (90-days ahead) forecast information from the WMO 

RCOFs (See also Section 3.4.3). Basic information on the WMO-RCOF institutions, using the Toolbox, can be 

obtained from the next Toolbox open/import: 

Figure 36   Imported GFS files [24-hr to 240-hr] (left) and view of a 

single day global forecast (right) 
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Figure 37   View access to WMO-RCOF information (from WMO, ICPAC, ACMAD, SADC-centre) 

A few web mapping services are implemented in the toolbox e.g. see GHACOF, SARCOF etc., permitting 

access to the different Regional Climate Outlooks for Africa. The up-to-date aspect of this seasonal fore-

casts and information depends on the web dissemination service quality of the information providers (pls. 

see also Disclaimer in the Toolbox Help). 

 

 Import EU-JRC-MARS dekadal global agrometeorological data 

Check the output directory (when starting a new data import, it is wise to do this small check). 

From the ILWIS Operations-Tree, open the Afrialliance “Triple Sensor” Toolbox and go to the left hand 

menu tree (bottom) and open the item “Configuration” > “Folders”. For the Folder item under “JRC_IES” 

specify your appropriate Ilwis output directory (e.g. d:\Ilwisout) and press “Save” to store the drive: \direc-

tory settings. Move to the working directory using the ILWIS Navigator. Close ILWIS and open it again. 

 

Import an ECMWF-based MARS Operational Agrometeorological data of Africa.  

Open the “Triple Sensor” Toolbox and select the Forecasts – Model-based Data sub Menu. Go to the option 

“EU-ECMWF-IFS based Data” and then “JRC-IES-MARS AgroMeteo Operational" > and then “10-day 

Temperature – Average (C)”. Note that the routine expects a year-month dekad input, e.g. specify for last 

dekad of August 2018 the following time stamp: “20180821”. Note the dekads are number 01, 11 and 21, 

for the 1st, 2nd and last dekad of the month respectively. Check the output folder and press “Import”. After 

the import has been completed display the new map created: “ope_africa_tav_20180821”, use as 

Representation “Pseudo” and press “OK”, add the country boundaries (no Info, boundaries only) and using 

the mouse with the left button pressed inspect the map values. Note the unit is in degree Celsius. 

If other products are imported note the file name conventions; the prefixes used are ‘int’ and ‘ope’, 

indicating the Interim and Operational products, region names are self-explanatory and product variables 

are defined as: rain, evpt, rad, tav, tmax and tmin for the rainfall, evapotranspiration, global radiation sum, 

average temperature, maximum temperature and minimum temperature. When importing multiple time 

steps of the same variable for the same region, note that the time step can also be changed in the ILWIS 

command line and the routine can be executed by pressing <enter>. 

The pictures below show two ECMWF Operational Data imports e.g. Average air temperature (10-day) 

during 3dt dekad of August 2018 and 10-day accumulated rainfall of the 3th dekad of October 2017. Both 
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maps were displayed using a Pseudo Color LUT, but stretched. Pls. Nite that this are quick „open map“ 

routines and full output maps can also be made with legend, coordinate windows, northing, scale bar 

etc…  

  

Figure 38   Dekadal 2-m average air temperature 

from ECMWF Operational archive (e.g. 

21-31 August 2018) 

Figure 39   Dekadal (10-day) precipitation sum 

from ECMWF Operational archive 

(e.g. 21-31 Oct 2017) 
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4.3 Triple Collocation demo exercise  

 Running the web-based Afrialliance Triple Collocation Demo 

The Afrialliance web-demo illustrates the technique for rainfall observations (July 2015) near Dano in 

Southwest Burkina Faso, a research area of West African Afrialliance partner WASCAL. Citizen locations 

were extracted from the Open access WPDx or Water Point Database. Citizen names were adapted 

(privacy) and rain data were simulated for demo purposes. Observed meteorological station data were 

obtained from WASCAL.org and CHIRPS2 was used as open access satellite precipitation. Pls. Go to the 

following web-address to open the demo: http://afrialliance.itc.utwente.nl/triplesensor/    

 

Figure 40   View of the web-based Triple Sensor Collocation Demo application 

 

The references of the current Triple Collocation approach and statistical method applied can be found in: 

McColl et al (2014). Extended Triple Collocation: estimating errors and correlation coefficients with respect to an 

unknown target. Geophysical Research Letters. 10.1002/2014GL061322. 
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Mannaerts, C.M., Maathuis, B., Wehn, U., Gerrets, T., Riedstra, H., Becht, R. and Lemmens, R. (2017) - Afrialliance 

Project Report Deliverable 4.4: Constraints and Opportunities for Water Resources Monitoring & Forecasting using 

the Triple Sensor approach. Available here [link] 

The data sources used in the web-demo are from Wascal (2018) http://www.wascal.org ; Chirps (2018) 

http://chg.geog.ucsb.edu/data/ and WPDx (2018) http://www.waterpointdata.org (see this Toolbox).  

 

 Performing Triple Collocation using the Ilwis Triple Sensor Toolbox 

We hereafter describe the ILWIS geospatial analysis procedure to perform the Triple Collocation as shown 

in the Web-based application. When using Ilwis, the user is “in command” of his datasets, and also even-

tually other Triple Collocations can be done, with different data sets, (as shown), and/or in different geo-

graphic Region of Interest (ROI) or study areas, and also with other satellite, station and citizen sourced or 

forecast model-based data. We will illustrate here two demonstration use cases. 

 

Important Notice: The data for this Triple Collocation demo are available from the SAMPLEDATA \ Da-

nocase.zip and should be available (unzipped) in your work directory e.g. “..:\ilwisout”, d:\Danocase… 

 

4.3.2.1 Triple Collocation of Satellite CHIRPS, WASCAL station meteo and Citizen WPDx Dano 

In this first triple collocation analysis (TC), we will simulate exactly the same situation as in the web-demo 

in the Dano catchment, Southwest Burkina Faso. The data sources here are: 

- CHIRPS satellite rainfall : period: 01 to 31-July 2015; daily interval; 5Km spatial resolution grid 

- WASCAL station rainfall data; 5 stations with 01-31 July 2015 observed rainfall 

- CITIZEN WPDx location (11 reporters): 01-31 July - 11 citizen observer locations (simulated data); 

Note that the citizen rainfall data were generated for test purposes. Reporter names were also changed for 

privacy reasons. The locations are real WPDx documented water observation points. The WASCAL meteo 

station data were spatially interpolated (using an inverse-distance weighted or IDW interpolation algo-

rithm, standard available in Ilwis) to gridded station daily rainfall maps. Data are present as a map list (31 

days), similar to the CHIRPS data. Pls. note that the current triple collocation application in Ilwis requires 

two gridded data sets and one point data set (e.g. citizen’s observations). 

 

Start ILWIS, and confirm that the location of your data catalogue is “D:\Ilwisout” (or any other directory 

with your sample data). If this is not the case, navigate to make this the current “Working Directory”. 

From the Operation-Tree, start the “Triple-Sensor” > “Toolbox”. 

From the “Triple-Sensor Toolbox” main menu select the “Get Time Series for Triple Collocation” sub menu. 

In there, three sub-entries are found: “Satellite Data – CHIRPS V2.0 daily PCP …”, “In Situ Data – CPC global 

PCP data …” and “Citizen Data – July 2015 PCP of Dano area …”. 

In this first demo exercise with the sample data, the first 2 download steps for “Getting Time Series for 

Triple Collocation” i.e. internet download of satellite and station data, must be skipped (as we use data 

available from disk).  

Only choose the third sub-entry “Citizen Data – July 2015 PCP of Dano area …” confirm that the “Output 

Directory” is “D:\Ilwisout” and press “Import”. As mentioned earlier, only daily data of July 2015 is provided. 

The data will be copied to “D:\Ilwisout”. Also a Polygon Map of the Dano catchment area “DanoCatchment” 

will be copied to your working data catalog “D:\Ilwisout”. 
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Figure 41  Input Menu for performing Triple Collocation of 3 sensors  

And a (created) point map will be opened (as shown below). 

 

Figure 42   Resulting point map (initial output with point statistics bottom left) 

 

Now proceed to Section 4.3.3 for TC data analysis and visualization (as this procedure is equal for the second 

use case below, with internet data imports). 

 

4.3.2.2 Triple collocation of Satellite CHIRPS, CPC-Gauge based global PCP and Citizen WPDx Dano  

 

In this second demonstration of a triple collocation analysis (TC), we will simulate a situation similar to the 

web-demo in the Dano catchment, but using other in-situ station data. The data sources here are: 

- CHIRPS satellite rainfall : period: 01 to 31-July 2015; daily interval; 5Km spatial resolution grid 

- CPC Gauge-based Global PCP analysis data: 01-31 July 2015 ; WMO-GTS gauge observed rainfall 

- CITIZEN WPDx location (11 reporters): 01-31 July - 11 citizen observer locations (simulated data); 

Pls. note that the CPC-Gauge based PCP has been interpolated to a 0.5 degree gridded map surface (see 

section 3.1.3.).  
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Important Notice: Pls. note that this internet ftp-based satellite and station time series data import will be 

time consuming, pending largely on your internet download speed (approx. 5- 10 min to …..). Use previous 

TC (section 4.3.2.1) if you want to proceed more rapidly with TC data analysis (and go to Section 4.3.3). 

 

Start ILWIS, and confirm that the location of your data catalogue is “D:\Ilwisout”. If this is not the case, 

navigate to make this the current “Working Directory”. 

From the Operation-Tree, start the “Triple-Sensor” > “Toolbox”. 

From the “Triple-Sensor Toolbox” main menu select the “Get Time Series for Triple Collocation” sub menu. 

In there, three sub-entries are found: “Satellite Data – CHIRPS V2.0 daily PCP …”, “In Situ Data – CPC global 

PCP data …” and “Citizen Data – July 2015 PCP of Dano area …”. Go through all three entries and download 

the corresponding data. Note that since the Citizen Data provided is daily data of July 2015, also the Satellite 

Data and the In Situ Data must exactly correspond to this (daily observation) time window or date-range. 

Otherwise the Triple Collocation cannot be performed correctly. 

Choose the first sub-entry “Satellite Data – CHIRPS V2.0 daily PCP …”, confirm that the “Output Directory” 

is “D:\Ilwisout”, in “Date (yyyymm)” type “201507” and press “Import”. Depending on the speed of your 

internet connection and of your computer, this may take around 15 to 30 minutes. 

Now choose the second sub-entry “In Situ Data – CPC global PCP data …”, confirm that the “Output 

Directory” is “D:\Ilwisout”, in “Date (yyyymm)” type “201507” and press “Import”. 

At last choose the third sub-entry “Citizen Data – July 2015 PCP of Dano area …”, confirm that the “Output 

Directory” is “D:\Ilwisout” and press “Import”. As mentioned earlier, only data of July 2015 is provided. The 

data will be copied to “D:\Ilwisout”. Also a Polygon Map of the Dano catchment area “DanoCatchment” will 

be copied to “D:\Ilwisout”. 

Back in the “Triple-Sensor Toolbox” main menu select the “Triple Collocation Processing” > “TC of Rainfall” 

> “TC of CHIRPS, CPC and Citizen Data” sub menu, and press “Open”. The form “Pointmap Triple 

Collocation” will pop-up. Tip: this form can also be started outside the toolbox, by selecting the 

corresponding application in the “ILWIS Point Operations”. 

Proceed by selecting the appropriate input for the form. Click the box next to “Maplist Sensor 1” to open 

the file selector, and select the item “chirps_Africa_201507”. Then click the box next to “Maplist Sensor 2”, 

and similarly select the item “CPC_Pgauge_201507”. Also click the box next to “Pointmap Sensor 3”, and 

select the item “citizen_data_Dano_july2015”. Then enter a name for the output filename (e.g. 

“tc_Dano_july2015”), and click “Show” to perform the Triple Collcation computations, and create the 

pointmap. It will automatically open in a new Map Window when done. 

  

 

 

 

 

 

Figure 43  Triple Collocation Input Menu screen and initial point map output 
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Proceed to section 4.3.2.3 for TC data analysis and visualization. 

 

 TC demo data analysis, interpretation and visualization 

Hereunder, a detailed Ilwis procedure to analyze and visualize  TC output is given. This can be done for both 

use cases (Triple collocations under 4.3.2.1. and 4.3.2.2). The procedure below uses the last CHIRPS –CPC - 

Citizen-WPDx data (i.e. Section 4.3.2.2 filenames). Pls. Use other file names (i.e. table and pointmap names 

from Section 4.3.2.1) to analyse the Section 4.3.2.1 use case. 

The locations are the same as the ones of the “citizen_data_Dano_july2015” Point Map, and the coloring 

of the points is the default of ILWIS for this type of map, which is one distinct color per point. However the 

new Point Map “tc_Dano_july2015” was assigned an attribute table that was computed by the Triple 

Collocation application. Keep the Point Map “tc_Dano_july2015” open, but close the Triple Sensor Toolbox. 

Then in the ILWIS catalog, double-click the table “tc_Dano_july2015” to open it. This is the attribute-table 

that corresponds to the Triple Collocation Point Map. 

Note the difference with the Point Map “tc_Dano_july2015”, the filename is the same, but the icons differ. 

The first item is the Point Map, the second is the table: 

 

After opening the table, explore the attributes that were computed by the Triple Collocation application. 

You can resize the columns if some text is not readable. 

  

Figure 44   View of Triple Collocation output table with point statistics 

 

The attributes w1, w2 and w3 are the weights that are assigned to each of the inputs that were used 

(“Maplist Sensor 1”, “Maplist Sensor 2” and “Pointmap Sensor 3”). They are computed based on the three 

31-days time-series for each location. A higher weight indicates a higher confidence in the data of the 

corresponding sensor. 

The attributes r1, r2 and r3 indicate the ranking of the sensors. For instance, in the first row, the third 

sensor (“Pointmap Sensor 3”, which represents the citizen-data) received rank 1, since it has the highest 

weight out of the three sensors. 
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The attributes rhosq1, rhosq2 and rhosq3 are the squares of the weights. 

Finally the attributes errvar1, errvar2 and errvar3 are the error variances of the weights. 

Now we are going to compute colors for each of the points that correspond to the triangluar red-green-

blue triple-collocation legend that was introduced in the web-demo of the previous paragraph. 

The goal is to compute Red, Green and Blue values for each location, ranging from 0 to 255, using the 

following formulas, and add them as an RGB Color attribute to the table, that will then be used for coloring 

the points. 

Red = 255*rhosq2/max(rhosq1,rhosq2,rhosq3) 

Green = 255*rhosq3/max(rhosq1,rhosq2,rhosq3) 

Blue = 255*rhosq1/max(rhosq1,rhosq2,rhosq3) 

Explanation: 

High weights for Satellite data (w1) contribute to the Blue color 

High weights for In Siitu data (w2) contribute to the Red color 

High weights for Citizen data (w3) contribute to the Green color 

We use rhosq1, rhosq2 and rhosq3 (the squared versions of w1, w2, w3) to get a higher contrast in the 

colors. Close the Point Map “tc_Dano_july2015”, but keep the table “tc_Dano_july2015” open. 

In the table, the white space between the buttons and the column-headers is named “table command-

line”. It is a space where a command can be entered. It is marked in red in the following picture. 

 

 

Figure 45   Command line (in Ilwis Table operations) 

In this “table command-line”, enter the following formula (if you have the digital version of this document, 

it is preferred to use copy/paste, for preventing typing mistakes). The formula is to be typed in one line, 

despite the fact that in this document the lines are wrapped, unintentionally splitting the formula in 3 lines. 

color_tc:=COLOR(255*rhosq2/max(rhosq1,rhosq2,rhosq3), 
255*rhosq3/max(rhosq1,rhosq2,rhosq3), 
255*rhosq1/max(rhosq1,rhosq2,rhosq3)) 

Explanation: this formula uses the same computations as before, creating the RGB values in a single step. 

After typing or pasting the formula, the table will look similar to this: 
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Figure 46   View of active command-line (in Ilwis Table operations) 

 

Press <ENTER> to execute the formula. If it was typed correctly, a “Column Properties” window will pop-

up, asking for confirmation that a new column named “color_tc” is to be created from this formula. 

Click OK to proceed computing the new column. It will be added to the 

table.  

 

 

 

 

. 

Figure 47  View of new Column  

(color_tc) properties  
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Figure 48   View of new „color_tc“ column (added by command line operation)   

Now go back to the ILWIS catalog and double-click the Point Map “tc_Dano_july2015” to open it. 

 

Figure 49  Point map (initial) view with new color_tc colour scheme 

The colors are still the same as before, the ILWIS default of one distinct color per point. 

Now change the colouring of the “tc_Dano_july2015” points, to the colours that we computed earlier. 

In the layer-management of the Map Window, click on the “+” (plus) before the “tc_Dano_july2015” Point 

Map to open it. Then click on the “+” before “Display Tools”, and then on the “+” before “Display Attribute”. 

Change the “Display Attribute” to the newly created “color_tc”. Then double-click “Symbolization”, change 

the “Symbols” to “filled-circle”, and the “Symbol scale” to 0.7, and click “Apply” and then “Close”. 

Add the Dano catchment polygon map as a background layer. 

Click with the Right mouse button on the white space in the layer-management area on the left, below 

“Background”. From the menu that appears, choose “Add Layer…”. Select the item named 

“DanoCatchment”, enable “Extend Map Boundaries” and click OK. 

The Dano catchment polygon map is added on-top. Use the mouse to re-arrange the layers in the layer-

management, so that “ DanoCatchment” is under “tc_Dano_july2015”. 
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Change the colouring of the “DanoCatchment” Polygon Map. 

In the layer-management of the Map Window, click on the “+” (plus) before the “DanoCatchment” Polygon 

Map to open it. Then click on the “+” before “Display Tools”, then on the “+” before “Portrayal” and then 

on the “+” before “Fixed Colors”. Change the selection to “Single color”, then double-click on “Single color” 

to select a new color. Change it to “Magenta”. Click Apply and Close. 

Under the “Display Tools” of “DanoCatchment”, click the “+” before “Boundaries”, then double-click the 

item labeled “Line style”. Change the Line thickness to 2, and the Line Color to “SkyBlue”. Click Apply and 

Close. 

Under the “Display Tools” of “DanoCatchment”, click the “+” before “Areas”, then double-click the item 

under “Areas” that is labeled “Transparency (0)”. Change the transparency to 95. Click Apply and Close. 

Adding OpenStreetMap as an additional background layer. 

Click with the Right mouse button on the white space in the layer-management area on the left, below 

“Background”. From the menu that appears, choose “Add Layer…”. Change the “Filter” to “Base maps”. 

From the list above, select “openstreetmap”, and click “OK”. 

The OpenStreetMap tiles are downloaded and appear on-top. Use the mouse to re-arrange the layers in 

the layer-management, so that “openstreetmap” is under “ DanoCatchment”. 

Now the colors are as similar as possible to the web-demo. The differences are only attributed to slight 

difference in the data-sources used for the web-demo, which were reduced in size for performance reasons 

(and a different OpenStreetMap server is used). 

 

 

Figure 50   Final view of TC output (with Open Street Map background and Triple sensor colour scheme) 

 

Further Data exploration: On the bottom-left of the Map Window, ensure that “Continuous” is enabled. 

Move the mouse over the TC locations, and (when the mouse is close to a point), the Triple Collocation 
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attributes of that location (w1, w2, w3, ranking, etc.), are shown at the bottom-left of the map window. 

Optionally increase the size of the attributes box for better visibility. 

 

 Running triple sensor collocation analysis with own data. 

The Triple Sensor Toolbox and Triple Collocation processor in ILWIS permit in principle to perform a TC in 

any region or area of interest on the globe. Data at all spatial scales (e.g. village level, province, catchment, 

country or region) and any time period length and 

interval can be analysed with high precision. 

Using the extensive projection and coordinate sys-

tem libraries of Ilwis, all areas of the world can be 

projected. In this Afrialliance Triple Sensor toolbox, 

focus is however on African Regions of Interest 

(ROI).  

When you wish to use Triple Collocation with your 

own datasets, you will need to supply time series 

from three different sensor sources that have over-

lap in space (i.e. same ROI), and match also exactly 

in time. Time periods can be any time interval, but 

this interval and time step (of observation) must be equal for all three sensors. Of course, time series pre-

processing can be done on the data (where needed). It is also essential that the data sources collocate in 

the spatial domain (window). 

We also assume that data are accessible (via internet or other source). In case of downloading and gener-

ation of satellite or large image time series, a fast internet connection is recommended (to speed up pre-

processing and the generation of time series).    

Two of the three sensor time series must be raster-based i.e.l gridded data sets (and available as ILWIS Map 

Lists). The number of bands in the two Map Lists must be the same, and correspond to the same time-unit, 

e.g. 1 band = 1 day, or 1 hour, or 15 minutes. Pls. note that Ilwis users can generate Ilwis map lists using 

GDAL routines (www.gdal.org) from e.g. netCDF, GeoTiff, grib and most other data formats. 

The third time series supplied must be Point-based data (i.e. an ILWIS Point Map with Attribute Table). Each 

record in the table must correspond to one point (1-to-1 relationship between point map and table). The 

points must preferably be inside the boundaries of both Map Lists. Points that are outside the boundaries 

of one or both Map Lists will be considered as having one or two sensors less (no data for one or two 

sensors), which is not suitable as “input” to the Triple Collocation algorithm. 

The time series data of the points must be placed in value-columns. The number of columns must be the 

same as the number of bands in each Map List. Each column will correspond to one band. E.g. the first 

column will be matched with the first band of the first Map List, and with the first band of the second Map 

List. It is allowed for the Point Map to have more columns than the number of bands in the Map Lists. Then 

it is considered that the first columns contain metadata (e.g. the location name, the observer name, etc.), 

and they will be ignored. Thus for a time series of N time steps, the last N columns of the Point Map will be 

used in the Triple Collocation computations. 

It is not possible to supply one Map List and two Point Maps to the Triple Collocation application. If you 

have this, one of the two Point Maps must be interpolated and rasterized into a Map List (each column 

Figure 51   Global application potential of the Triple Sen-

sor toolbox (world country boundaries using Mol-

lenweider projection in Ilwis) 
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must result into one raster band), and interpolated, e.g. by a “Moving Average”, kriging or other spatial 

interpolation algorithm (e.g. see also use case with WASCAL station meteo data). 

The order in which the three time series are supplied to the Triple Collocation application is not important. 

The output attribute table will contain columns named w1, w2, w3 etc., corresponding to resp. the first, 

second and third time series supplied. 

The current Triple Collocation application is unable to verify temporal incompatibility. For instance, if one 

Map List has 24 bands corresponding to 24 days, and the second one has 24 bands corresponding to the 

24 hours of a day, it will just execute. However, the results will not make sense. 
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6 Appendixes 

6.1 APPENDIX 1: ILWIS v.3x tips and tricks  

- [Installing ILWIS v3x]: Ilwis Open v.3 with Toolbox (supplied as a zip-file) doesn’t need to be 

installed through a Windows setup (msi or setup file), but can just be unzipped to a drive on your 

system, using a folder with a short path name, without empty spaces in the path, e.g. „d:\ilwis385“ 

or similar. 

- [STARTING ILWIS OPEN]: When starting to work with Ilwis 3, first Open Ilwis, then navigate to your 

working directory, close and re-open Ilwis. Ilwis has now registered itself in Windows registry, and 

remembers it’s program locations and the data catalogue (directory) path(s). 

- [COPY and DELETE Ilwis FILES]: You can best delete Ilwis files using the Edit Menu > Delete option. 

This removes all (hidden, non-displayed ancillary files) from your system. Also always copy Ilwis 

files (to other disks or directories) using the Edit Menu > Copy Object to … option, in order to copy 

the object dependencies also. 

- [REFRESH MEMORY]: Pls. use the Refresh (or F5) from the Window Menu, if you do not find a 

filename of something you just created. This is a refresh Memory operation in Ilwis. 

- [RESTORE DEFAULTS]: If you worked much on data and e.g. did overwrite filenames or tried 

operations which are not possible or allowed etc. and if Ilwis is getting slow (or seems to hang), 

you can refresh (clean) the entire Ilwis memory by File > preferences > Advanced > Restore 

Defaults. This resets Ilwis. You will need to navigate back to your work directory for the first time 

again, after resetting Ilwis.   

- [CLOSE APPLICATION]: Kill Ilwis in case of “hanging”. By some not allowed operations, Ilwis Open 

might not work further. In worst case, pls. use the Windows Task Manager from the Windows 

Task Bar to “End Task” -> Ilwis run operations. This is “brute” Windows forced close program, but 

efficient if really needed. Just Re-open Ilwis again.  

- [FILE DEPENDENCIES]: GIS files in general (e.g. also ArcGIS) have much earlier created file 

dependencies and heritages or lineages, which can sometimes be cut, but sometimes also may 

not be removed. The Ilwis Properties button is an important info source to see the dependencies 

of your Ilwis object. Especially earlier Georeferences used to create the (sub)object are important 

file heritages or lineages in Ilwis. 

- [DISPLAY SETTINGS]: Sometimes your Defaults Display settings for e.g. Raster maps looks not good 

(e.g. gtdmax). This raster representation is not nice (in the Ilwis default settings) and should by 

preference be set to Pseudo (colour Look-up). Use File > Preferences > Map Window> Display > 

Default Representations to adapt. 

- [SERVICE OBJECTS]: Pls. remember that in ILWIS, the Domain (-> data type) and georeference, 

coordinate systems are most important Service Objects to take care off. They basically determine 

what you can do on an object. If a certain RS/GIS operation does not work (or you cannot activate 

it), pls. first check the domain type, georeference and dependencies of the objects you are 

working with (or combining, etc.)… 

- ILWIS HELP Menu: Ilwis contains a very well documented Help Menu ! Don’t forget to use it (in 

case more explanation is needed). 


